On 965G glxgears fails with DRM_I830_CMDBUFFER: -22

Bug #66645 reported by Alex Willmer on 2006-10-17
10
Affects Status Importance Assigned to Milestone
mesa (Debian)
Fix Released
Unknown
mesa (Ubuntu)
Undecided
Unassigned

Bug Description

glxgears and other opengl programs fail as follows:

alex@bertha:~$ glxgears
DRM_I830_CMDBUFFER: -22

This is using latest libdrm, kernel, xorg on an intel x3000/G965 chipset. libgl1-mesa-glx 6.5.1~20060817-0ubuntu3 is installed.

Alex Willmer (alex-moreati) wrote :
Alex Willmer (alex-moreati) wrote :
Alex Willmer (alex-moreati) wrote :
Erik Andrén (erik-andren) wrote :

I can confirm this bug

Changed in mesa:
status: Unconfirmed → Confirmed
Paul Sladen (sladen) wrote :

Is this on 6.06LTS, 6.10 or fiesty?

Erik Andrén (erik-andren) wrote :

Both Edgy and Feisty. I haven't tried Dapper.

Benoit Pruneau (bpruneau) wrote :

For information, on Debian, they have already find the trouble:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=394311

But I don't know how to do that with Ubuntu, I'm a beginner in Linux, with Ubuntu 6.10

Paul Sladen (sladen) wrote :

IIRC, this was already applied for 6.10.

Changed in mesa:
status: Unknown → Unconfirmed
Peter Cordes (peter-cordes) wrote :

It's not fixed in AMD64 Edgy. I had to apt-get source ... to build with -fno-strict-aliasing. That fixed that problem.

Changed in mesa:
status: Unconfirmed → Confirmed
Changed in mesa:
status: Confirmed → Fix Released
Alex Willmer (alex-moreati) wrote :

I can confirm this is still not fixed for Feisty. Recompiling mesa 6.5.1~20060817-0ubuntu4 with -fno-strict-aliasing fixed the problem.

Modified configs/debian:

DEBIAN_COMMON_CFLAGS = -ansi -pedantic -Wall -fPIC -std=c99 \
    -fno-strict-aliasing

Confirmed as well here. Could someone produce a package with -fno-strict-aliasing added to CFLAGS/CXXFLAGS in configs/debian and configs/debian-static?

Alex Willmer (alex-moreati) wrote :

I think I've done this right, patch made against current Feisty mesa, fixes the CMDBUFFER error.

A warning is still printed to the console:
libGL warning: 3D driver claims to not support visual 0x5a

This bug seems closely related to latest comments in bugs 62135 & 61951. Following this patch glxgears and ppracer work. Compiz does not, windows appear as blank boxes.

Alex Willmer (alex-moreati) wrote :

I hacked together some custom packages from Debian experimental for libdrm_2.3.0 and mesa_6.5.2. Using these, the "libGL warning: 3D driver claims to not support visual 0x5a" is still reported.

Following installation of these packages and an X server restart desktop-effects half works. Windows draw with a thick black edge surrounding the border, tool tips have a similar white edge. After a short time window contents gradually fail to draw, widgets and icons become blank on hover. Resizing a window restores it's contents.

It would appear there's more to fixing compiz on 965G than upgrading mesa/libdrm.

Alex Willmer (alex-moreati) wrote :

The meaning of the libGL warning can be found on the Gentoo Wiki:
http://gentoo-wiki.com/HARDWARE_Intel_DG965MQMKR#Integrated_Video_Intel_X3000

Visual 0x5a is for 23bit, i810 driver supports only up to 24bit

Alex Willmer (alex-moreati) wrote :

The upgrade in feisty to mesa 6.5.2 and libdrm 2.3.0 has fully fixed this bug. The visual 0x5a message remains, but isn't relevant.

Changed in mesa:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Patches

Remote bug watches

Bug watches keep track of this bug in other bug trackers.