Screen corruption make UNE unusable (xorg issue)

Bug #628727 reported by Sergio Zanchetta on 2010-09-02
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
mesa (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-ati (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: xorg

UNE pre-beta live cd,
Acer 6593G, ATI HD 3470 Video Card

After booting, system is unusable due to screen corruption, see screenshots.
I had to report the bug using console because gdm restarted every time I run "ubuntu-bug xorg" from a terminal in GUI.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: xorg 1:7.5+6ubuntu3
ProcVersionSignature: Ubuntu 2.6.35-19.28-generic 2.6.35.3
Uname: Linux 2.6.35-19-generic i686
Architecture: i386
DRM.card0.DVI.D.1:
 status: disconnected
 enabled: disabled
 dpms: On
 modes:
 edid-base64:
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1680x1050 1400x1050 1280x1024 1440x900 1280x960 1280x854 1280x800 1280x720 1152x768 1024x768 800x600 848x480 720x480 640x480
 edid-base64: AP///////wANryAVAAAAAAAAAQOAIRR4CnfxoFpLliQYT1QAAAABAQEBAQEBAQEBAQEBAQEBfC6QoGAaHkAwIDYAS88QAAAYAAAA/gBOMTU0WjEtTDAxCiAgAAAA/gBDTU8KICAgICAgICAgAAAA/gBOMTU0WjEtTDAxCiAgAP0=
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: On
 modes:
 edid-base64:
Date: Thu Sep 2 09:55:34 2010
LiveMediaBuild: Ubuntu-Netbook 10.10 "Maverick Meerkat" - Beta i386 (20100902)
MachineType: Acer TravelMate 6593
PccardctlIdent:
 Socket 0:
   no product info available
 Socket 1:
   product info: "O2Micro", "SmartCardBus Reader", "V1.0", ""
   manfid: 0xffff, 0x0001
PccardctlStatus:
 Socket 0:
   no card
 Socket 1:
   5.0V 16-bit PC Card
   Subdevice 0 (function 0) [unbound]
ProcCmdLine: BOOT_IMAGE=/casper/vmlinuz noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/hostname-netbook.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: xorg
dmi.bios.date: 08/14/2008
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: V1.04
dmi.board.name: FourPeaks
dmi.board.vendor: Acer
dmi.board.version: Rev
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvrV1.04:bd08/14/2008:svnAcer:pnTravelMate6593:pvr0100:rvnAcer:rnFourPeaks:rvrRev:cvnAcer:ct10:cvrN/A:
dmi.product.name: TravelMate 6593
dmi.product.version: 0100
dmi.sys.vendor: Acer
system:
 distro: Ubuntu
 codename: maverick
 architecture: i686
 kernel: 2.6.35-19-generic

Related branches

Sergio Zanchetta (primes2h) wrote :
Sergio Zanchetta (primes2h) wrote :

It seems to affect just the new "Unity" though.
Opening the task.

Sergio Zanchetta (primes2h) wrote :
Sergio Zanchetta (primes2h) wrote :
Sergio Zanchetta (primes2h) wrote :
Sergio Zanchetta (primes2h) wrote :

In fact I found out that gdm restart just a while after opening firefox.

tags: added: iso-testing
Bryce Harrington (bryce) on 2010-09-02
affects: xorg (Ubuntu) → xserver-xorg-video-ati (Ubuntu)
Bryce Harrington (bryce) on 2010-09-05
tags: added: corruption
Robert Hooker (sarvatt) wrote :

We believe this bug is fixed by this package in maverick, if it is not please reopen this bug.

mesa (7.9~git20100909-0ubuntu1) maverick; urgency=low

  [ Robert Hooker ]
  * New upstream git snapshot up to commit 94118fe2d4b1e5 (LP: #631413)
  * New features include ATI HD5xxx series support in r600, and a vastly
    improved glsl compiler.
  * Remove pre-generated .pc's, use the ones generated at build time
    instead.
  * Remove all references to mesa-utils now that its no longer shipped
    with the mesa source.
  * Disable the experimental ARB_fragment_shader option by default on
    i915, it exposes incomplete functionality that breaks KDE compositing
    among other things. It can be enabled via driconf still. (LP: #628930).

  [ Christopher James Halse Rogers ]
  * debian/patches/04_osmesa_version.diff:
    - Refresh for new upstream
  * Bugs fixed in this release:
    - Fixes severe rendering corruption in Unity on radeon (LP: #628727,
      LP: #596292, LP: #599741, LP: #630315, LP: #613694, LP: #599741).
    - Also fixes rendering in gnome-shell (LP: #578619).
    - Flickering in OpenGL apps on radeon (LP: #626943, LP: #610541).
    - Provides preliminary support for new intel chips (LP: #601052).
  * debian/rules:
    - Update configure flags to match upstream reshuffling.
    - Explicitly remove gallium DRI drivers that we don't want to ship.
  * Update debian/gbp.conf for this Maverick-specific packaging
  * libegl1-mesa-dri-x11,kms: There are no longer separate kms or x11 drivers
    for EGL, libegl1-mesa-drivers now contains a single driver that provides
    both backends.

Date: Tue, 14 Sep 2010 08:55:40 -0400
Changed-By: Robert Hooker <robert.hooker at canonical.com>
Maintainer: Ubuntu X-SWAT <ubuntu-x at lists.ubuntu.com>
Signed-By: Scott Kitterman <ubuntu at kitterman.com>
https://launchpad.net/ubuntu/maverick/+source/mesa/7.9~git20100909-0ubuntu1

affects: xserver-xorg-video-ati (Ubuntu) → mesa (Ubuntu)
Changed in mesa (Ubuntu):
status: New → Fix Released
Didier Roche (didrocks) on 2010-09-24
Changed in unity (Ubuntu):
status: New → Fix Released
Sergio Zanchetta (primes2h) wrote :

Tested with UNE pre-RC. (27-09-2010)

Unity is now usable but with still lots of screen corruptions. (icons too)
See screenshot.

Changed in mesa (Ubuntu):
status: Fix Released → Confirmed
Changed in unity (Ubuntu):
status: Fix Released → Confirmed
Sergio Zanchetta (primes2h) wrote :
Mirco Müller (macslow) wrote :

Sergio, are the icon-corruptions visible all the time? Or only when you e.g. come back from suspend?

Sergio Zanchetta (primes2h) wrote :

@Mirco
Yes, they are visible in a live cd environment.
Corruptions can change the shape or appear/disappear during use.

Didier Roche (didrocks) on 2010-10-09
Changed in unity:
status: New → Confirmed
Neil J. Patel (njpatel) wrote :

Hi, with natty's alpha 1 release around the corner, could you please test Unity 3.x on natty to see if this is still an issue. We've been working hard to lower the gl requirements and hope this this means you'll get a smoother experience now. Marking as incomplete pending your test results.

Changed in unity:
importance: Undecided → High
status: Confirmed → Incomplete
Changed in unity (Ubuntu):
status: Confirmed → Incomplete
importance: Undecided → High
Sergio Zanchetta (primes2h) wrote :

Still present on Natty Alpha1.

Screenshot in attachment.

Changed in unity:
status: Incomplete → Confirmed
Changed in unity (Ubuntu):
status: Incomplete → Confirmed
David Barth (dbarth) wrote :

This really depends on the type of card. I have an ati here as well and can reproduce the rendering corruption. So this is not a Unity bug as much as it is a driver rendering issue.
I'm keeping it open on Unity to keep the issue on the radar, but really handing that over to Bryce and Chris to see how they can help with the driver problem.

David Barth (dbarth) on 2011-01-07
tags: added: driver unity
Changed in unity:
status: Confirmed → Invalid
Changed in unity (Ubuntu):
status: Confirmed → Invalid
bugbot (bugbot) on 2011-01-08
affects: xorg (Ubuntu) → xserver-xorg-video-ati (Ubuntu)
David Barth (dbarth) on 2011-01-21
summary: - Screen corruption make UNE unusable
+ Screen corruption make UNE unusable (xorg issue)
David Barth (dbarth) on 2011-01-21
Changed in unity:
importance: High → Undecided
Changed in unity (Ubuntu Natty):
importance: High → Undecided
Changed in xserver-xorg-video-ati (Ubuntu Natty):
status: New → Triaged
Changed in mesa (Ubuntu Natty):
status: Confirmed → Triaged
Sergio Zanchetta (primes2h) wrote :

Some small rendering corruption are still present using Natty Final.

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/628727

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu laptop testing tracker.

A list of all reports related to this bug can be found here:
http://laptop.qa.ubuntu.com/qatracker/reports/bugs/628727

tags: added: laptop-testing
dino99 (9d9) wrote :
Changed in unity (Ubuntu Maverick):
status: New → Invalid
Changed in mesa (Ubuntu Natty):
status: Triaged → Invalid
Changed in mesa (Ubuntu Maverick):
status: New → Invalid
Changed in xserver-xorg-video-ati (Ubuntu Maverick):
status: New → Invalid
Changed in xserver-xorg-video-ati (Ubuntu Natty):
status: Triaged → Invalid
tags: removed: maverick
bugbot (bugbot) on 2013-05-23
tags: added: maverick
dino99 (9d9) on 2013-05-23
tags: added: bot-stop-nagging
removed: maverick
bugbot (bugbot) on 2013-05-23
tags: added: maverick

Sergio Zanchetta, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p xserver-xorg-video-ati REPLACE-WITH-BUG-NUMBER

Please note, given that the information from the prior release is already available, doing this on a release prior to the development one would not be helpful.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

no longer affects: unity (Ubuntu)
no longer affects: unity (Ubuntu Maverick)
no longer affects: unity (Ubuntu Natty)
no longer affects: xserver-xorg-video-ati (Ubuntu Natty)
no longer affects: xserver-xorg-video-ati (Ubuntu Maverick)
no longer affects: mesa (Ubuntu Natty)
no longer affects: mesa (Ubuntu Maverick)
no longer affects: xserver-xorg-video-ati (Ubuntu)
affects: unity → xserver-xorg-video-ati (Ubuntu)
Changed in xserver-xorg-video-ati (Ubuntu):
status: Invalid → Incomplete
importance: Undecided → Low
dino99 (9d9) on 2015-07-09
Changed in mesa (Ubuntu):
status: Triaged → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for xserver-xorg-video-ati (Ubuntu) because there has been no activity for 60 days.]

Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → Expired
Launchpad Janitor (janitor) wrote :

[Expired for mesa (Ubuntu) because there has been no activity for 60 days.]

Changed in mesa (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers