Launch command "cairo-dock -O" : ubuntu's session crashes and restarts

Bug #573196 reported by lylambda
32
This bug affects 4 people
Affects Status Importance Assigned to Milestone
mesa (Ubuntu)
Undecided
Unassigned

Bug Description

Architecture: i386
DistroRelease: Ubuntu 10.04
Package: 2.1.4-0beta1-20100426-0ubuntu1~ppa0~lucid
ProblemType: Session crash
ProcCmdline: cairo-dock -O
Window Manager: Compiz
Desktop Environment: Gnome
Video Card: Ati M R X300

So, when I launch the command "cairo-dock -O" (-O for use indirect rendering), ubuntu's session crashes and restarts. On the contrary, "cairo-dock -c" works properly (the dock appears correctly with cairo backend) and "cairo-dock -o" too but with some graphical problems (openGL backend, other bug with ati driver).
You can found different logs (/var/log/Xorg.0* , /var/log/Xorg.failsafe.log* and ~/.xsession-errors*) here --> http://dl.free.fr/pu0g0saQK
Thanks !

---
Architecture: i386
CurrentDmesg:
 [ 39.502144] ppdev: user-space parallel port driver
 [ 40.816175] b44: eth0: Link is up at 100 Mbps, full duplex.
 [ 40.816179] b44: eth0: Flow control is off for TX and off for RX.
 [ 40.816456] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
 [ 51.504027] eth0: no IPv6 routers present
DistroRelease: Ubuntu 10.04
DkmsStatus: Error: [Errno 2] Aucun fichier ou dossier de ce type
MachineType: Acer, inc. Aspire 1650
Package: mesa (not installed)
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: root=UUID=310300e1-4cf9-4c18-aefa-7ed72b740cca ro quiet splash vga=771
ProcEnviron:
 LANGUAGE=fr_FR:fr:en_GB:en
 LANG=fr_FR.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Tags: lucid lucid
Uname: Linux 2.6.32-21-generic i686
UserGroups: adm admin audio cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 08/31/05
dmi.bios.vendor: Acer
dmi.bios.version: 3A33
dmi.board.name: Crane II
dmi.board.vendor: Acer, Inc.
dmi.board.version: Not Applicable
dmi.chassis.type: 1
dmi.chassis.vendor: , Inc.
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAcer:bvr3A33:bd08/31/05:svnAcer,inc.:pnAspire1650:pvrNotApplicable:rvnAcer,Inc.:rnCraneII:rvrNotApplicable:cvn,Inc.:ct1:cvrN/A:
dmi.product.name: Aspire 1650
dmi.product.version: Not Applicable
dmi.sys.vendor: Acer, inc.
system:
 distro: Ubuntu
 codename: lucid
 architecture: i686
 kernel: 2.6.32-21-generic

---
Architecture: i386
CurrentDmesg:
 [ 39.502144] ppdev: user-space parallel port driver
 [ 40.816175] b44: eth0: Link is up at 100 Mbps, full duplex.
 [ 40.816179] b44: eth0: Flow control is off for TX and off for RX.
 [ 40.816456] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
 [ 51.504027] eth0: no IPv6 routers present
DistroRelease: Ubuntu 10.04
DkmsStatus: Error: [Errno 2] Aucun fichier ou dossier de ce type
MachineType: Acer, inc. Aspire 1650
Package: mesa (not installed)
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: root=UUID=310300e1-4cf9-4c18-aefa-7ed72b740cca ro quiet splash vga=771
ProcEnviron:
 LANGUAGE=fr_FR:fr:en_GB:en
 LANG=fr_FR.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Tags: lucid lucid
Uname: Linux 2.6.32-21-generic i686
UserGroups: adm admin audio cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 08/31/05
dmi.bios.vendor: Acer
dmi.bios.version: 3A33
dmi.board.name: Crane II
dmi.board.vendor: Acer, Inc.
dmi.board.version: Not Applicable
dmi.chassis.type: 1
dmi.chassis.vendor: , Inc.
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAcer:bvr3A33:bd08/31/05:svnAcer,inc.:pnAspire1650:pvrNotApplicable:rvnAcer,Inc.:rnCraneII:rvrNotApplicable:cvn,Inc.:ct1:cvrN/A:
dmi.product.name: Aspire 1650
dmi.product.version: Not Applicable
dmi.sys.vendor: Acer, inc.
system:
 distro: Ubuntu
 codename: lucid
 architecture: i686
 kernel: 2.6.32-21-generic

lylambda (lylambda)
description: updated
description: updated
lylambda (lylambda)
description: updated
affects: ubuntu → mesa (Ubuntu)
Revision history for this message
Bryce Harrington (bryce) wrote :

Hi lylambda,

Please run the command 'apport-collect BUGNUMBER', which will attach several files we need for debugging.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: crash
tags: added: needs-xorglog
tags: added: needs-lspci-vvnn
Changed in mesa (Ubuntu):
status: New → Incomplete
Revision history for this message
lylambda (lylambda) wrote : BootDmesg.txt

apport information

tags: added: apport-collected
description: updated
Revision history for this message
lylambda (lylambda) wrote : GdmLog.txt

apport information

Revision history for this message
lylambda (lylambda) wrote : GdmLog1.txt

apport information

Revision history for this message
lylambda (lylambda) wrote : GdmLog2.txt

apport information

Revision history for this message
lylambda (lylambda) wrote : Lspci.txt

apport information

Revision history for this message
lylambda (lylambda) wrote : Lsusb.txt

apport information

Revision history for this message
lylambda (lylambda) wrote : PciDisplay.txt

apport information

Revision history for this message
lylambda (lylambda) wrote : ProcCpuinfo.txt

apport information

Revision history for this message
lylambda (lylambda) wrote : ProcInterrupts.txt

apport information

Revision history for this message
lylambda (lylambda) wrote : ProcModules.txt

apport information

Revision history for this message
lylambda (lylambda) wrote : RelatedPackageVersions.txt

apport information

Revision history for this message
lylambda (lylambda) wrote : UdevDb.txt

apport information

Revision history for this message
lylambda (lylambda) wrote : UdevLog.txt

apport information

Revision history for this message
lylambda (lylambda) wrote : XorgConf.txt

apport information

Revision history for this message
lylambda (lylambda) wrote : XorgLog.txt

apport information

Revision history for this message
lylambda (lylambda) wrote : XorgLogOld.txt

apport information

Revision history for this message
lylambda (lylambda) wrote : Xrandr.txt

apport information

Revision history for this message
lylambda (lylambda) wrote : glxinfo.txt

apport information

Revision history for this message
lylambda (lylambda) wrote : monitors.xml.txt

apport information

Revision history for this message
lylambda (lylambda) wrote : setxkbmap.txt

apport information

Revision history for this message
lylambda (lylambda) wrote : xdpyinfo.txt

apport information

Revision history for this message
lylambda (lylambda) wrote : xkbcomp.txt

apport information

description: updated
Revision history for this message
lylambda (lylambda) wrote : BootDmesg.txt

apport information

Revision history for this message
lylambda (lylambda) wrote : GdmLog.txt

apport information

Revision history for this message
lylambda (lylambda) wrote : GdmLog1.txt

apport information

Revision history for this message
lylambda (lylambda) wrote : GdmLog2.txt

apport information

Revision history for this message
lylambda (lylambda) wrote : Lspci.txt

apport information

Revision history for this message
lylambda (lylambda) wrote : Lsusb.txt

apport information

Revision history for this message
lylambda (lylambda) wrote : PciDisplay.txt

apport information

Revision history for this message
lylambda (lylambda) wrote : ProcCpuinfo.txt

apport information

Revision history for this message
lylambda (lylambda) wrote : ProcInterrupts.txt

apport information

Revision history for this message
lylambda (lylambda) wrote : ProcModules.txt

apport information

Revision history for this message
lylambda (lylambda) wrote : RelatedPackageVersions.txt

apport information

Revision history for this message
lylambda (lylambda) wrote : UdevDb.txt

apport information

Revision history for this message
lylambda (lylambda) wrote : UdevLog.txt

apport information

Revision history for this message
lylambda (lylambda) wrote : XorgConf.txt

apport information

Revision history for this message
lylambda (lylambda) wrote : XorgLog.txt

apport information

Revision history for this message
lylambda (lylambda) wrote : XorgLogOld.txt

apport information

Revision history for this message
lylambda (lylambda) wrote : Xrandr.txt

apport information

Revision history for this message
lylambda (lylambda) wrote : glxinfo.txt

apport information

Revision history for this message
lylambda (lylambda) wrote : monitors.xml.txt

apport information

Revision history for this message
lylambda (lylambda) wrote : setxkbmap.txt

apport information

Revision history for this message
lylambda (lylambda) wrote : xdpyinfo.txt

apport information

Revision history for this message
lylambda (lylambda) wrote : xkbcomp.txt

apport information

Revision history for this message
Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

Hi lylambda,

This bug was reported against an earlier version of Ubuntu, can you
test if it still occurs on Lucid?

Please note we also provide technical support for older versions of
Ubuntu, but not in the bug tracker. Instead, to raise the issue through
normal support channels, please see:

    http://www.ubuntu.com/support

If you are the original reporter and can still reproduce the issue on
Lucid, please run the following command to refresh the report:

  apport-collect 573196

If you are not the original reporter, please file a new bug report, so
we can work with you as the original reporter instead (you can reference
bug 573196 in your report if you think it may be related):

  ubuntu-bug xorg

If by chance you can no longer reproduce the issue on Lucid or if you
feel it is no longer relevant, please mark the bug report 'Fix Released'
or 'Invalid' as appropriate, at the following URL:

  https://bugs.launchpad.net/ubuntu/+bug/573196

Changed in mesa (Ubuntu):
status: Incomplete → New
status: New → Incomplete
tags: added: needs-retested-on-lucid-by-june
Revision history for this message
jack_russell (sapajou-bar) wrote :

I have a similar issue (on an MSI S271 laptop) as explained in the duplicate

when I launch the command "cairo-dock -O" (-O for use indirect rendering) i can't see no applets and when I take out an applet of the dock it crashes with the message :

Cairo-Dock has crashed (sig 8).
It will be restarted now (cairo-dock -O -m -m).
Couldn't guess if it was an applet's fault or not. It may have crashed inside the core or inside a thread
Sorry, Cairo-Dock has encoutered some problems, and will quit.

whith the command "cairo-dock -o" (openGL) the problem is the same

ProblemType: Bug
Video Card: ATI Radeon Xpress 200M
DistroRelease: Ubuntu 10.04
Package: cairo-dock-core 2.1.3-10-lucid-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic i686
Architecture: i386
Date: Fri May 7 17:38:52 2010
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
ProcEnviron:
 LANG=fr_FR.utf8
 SHELL=/bin/bash
SourcePackage: cairo-dock

Bryce Harrington (bryce)
tags: removed: needs-xorglog
tags: removed: needs-lspci-vvnn
Changed in mesa (Ubuntu):
status: Incomplete → Confirmed
Revision history for this message
jack_russell (sapajou-bar) wrote :
Revision history for this message
jack_russell (sapajou-bar) wrote :
description: updated
Bryce Harrington (bryce)
tags: added: lucid
Revision history for this message
Olry Pascal (pascal-olry900) wrote :

I have a similar problem as jack_russel on an Packard bell Imedia

Revision history for this message
Olry Pascal (pascal-olry900) wrote :
Revision history for this message
Olry Pascal (pascal-olry900) wrote :
Revision history for this message
Takkat (takkat-nebuk) wrote :

No crashes here but graphic problems: some Applets are not rendered in openGL-mode when detached from dock (see bug #581350)

Revision history for this message
olivier (ollefebvre2) wrote :
Download full text (13.4 KiB)

name of display: :0.0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_ARB_multisample, GLX_EXT_import_context, GLX_EXT_texture_from_pixmap,
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_copy_sub_buffer,
GLX_OML_swap_method, GLX_SGI_make_current_read, GLX_SGI_swap_control,
GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,
GLX_SGIX_visual_select_group
client glx vendor string: Mesa Project and SGI
client glx version string: 1.4
client glx extensions:
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,
GLX_MESA_copy_sub_buffer, GLX_MESA_swap_control,
GLX_MESA_swap_frame_usage, GLX_OML_swap_method, GLX_OML_sync_control,
GLX_SGI_make_current_read, GLX_SGI_swap_control, GLX_SGI_video_sync,
GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,
GLX_SGIX_visual_select_group, GLX_EXT_texture_from_pixmap
GLX version: 1.2
GLX extensions:
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_copy_sub_buffer,
GLX_MESA_swap_frame_usage, GLX_OML_swap_method, GLX_SGI_make_current_read,
GLX_SGI_video_sync, GLX_SGIS_multisample, GLX_SGIX_fbconfig,
GLX_SGIX_pbuffer, GLX_SGIX_visual_select_group,
GLX_EXT_texture_from_pixmap
OpenGL vendor string: DRI R300 Project
OpenGL renderer string: Mesa DRI R300 (RV410 5652) 20090101 x86/MMX/SSE2 TCL DRI2
OpenGL version string: 1.5 Mesa 7.7.1
OpenGL extensions:
GL_EXT_compiled_vertex_array, GL_EXT_texture_env_add,
GL_ARB_depth_texture, GL_ARB_draw_buffers, GL_ARB_fragment_program,
GL_ARB_imaging, GL_ARB_multisample, GL_ARB_multitexture,
GL_ARB_occlusion_query, GL_ARB_point_parameters, GL_ARB_provoking_vertex,
GL_ARB_shadow, GL_ARB_shadow_ambient, GL_ARB_texture_border_clamp,
GL_ARB_texture_compression, GL_ARB_texture_cube_map,
GL_ARB_texture_env_add, GL_ARB_texture_env_combine,
GL_ARB_texture_env_crossbar, GL_ARB_texture_env_dot3,
GL_MESAX_texture_float, GL_ARB_texture_mirrored_repeat,
GL_ARB_texture_rectangle, GL_ARB_transpose_matrix,
GL_ARB_vertex_array_bgra, GL_ARB_vertex_buffer_object,
GL_ARB_vertex_program, GL_ARB_window_pos, GL_EXT_abgr, GL_EXT_bgra,
GL_EXT_blend_color, GL_EXT_blend_equation_separate,
GL_EXT_blend_func_separate, GL_EXT_blend_logic_op, GL_EXT_blend_minmax,
GL_EXT_blend_subtract, GL_EXT_convolution, GL_EXT_copy_texture,
GL_EXT_draw_range_elements, GL_EXT_framebuffer_blit,
GL_EXT_framebuffer_object, GL_EXT_fog_coord,
GL_EXT_gpu_program_parameters, GL_EXT_histogram, GL_EXT_multi_draw_arrays,
GL_EXT_packed_depth_stencil, GL_EXT_packed_pixels,
GL_EXT_point_parameters, GL_EXT_polygon_offset, GL_EXT_provoking_vertex,
GL_EXT_rescale_normal, GL_EXT_secondary_color,
GL_EXT_separate_specular_color, GL_EXT_shadow_funcs,
GL_EXT_stencil_two_side, GL_EXT_stencil_wrap, GL_EXT_subtexture,
GL_EXT_texture, GL_EXT_texture3D, GL_EXT_texture_cube_map,
GL_EXT_texture_edge_clamp, GL_EXT_texture_env_combine,
GL_EXT_texture_env_dot3, GL_EXT_texture_filter_anisotropic,
GL_EXT_texture_lod_bias, GL_EXT_texture_mirro...

tags: added: bios-outdated-3a45
removed: needs-retested-on-lucid-by-june
Timo Aaltonen (tjaalton)
Changed in mesa (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers