libsdl1.2-dev has trouble installing (dapper) because of libarts-dev dependancy

Bug #56939 reported by Edm00se on 2006-08-19
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
glib2.0 (Ubuntu)
Medium
Unassigned
libsdl1.2 (Ubuntu)
Undecided
Unassigned
mesa (Ubuntu)
Medium
Unassigned

Bug Description

In Dapper (6.06) I tried to install libsdl1.2-dev.Which yields:
libsdl1.2-dev: Depends: libartsc0-dev but it is not going to be installed

On trying to install libartsc0-dev:
libartsc0-dev: Depends: libglib2.0-dev but it is not going to be installed

On trying to install libglibe2.0-dev:
libglib2.0-dev: Depends: libglib2.0-0 (= 2.10.2-1ubuntu3) but 2.10.3-0ubuntu1 is to be installed

So it looks like I have a newer version of libglib2.0 installed than it wants to force on me. Talk about being accosted by your computer. A dependency fix would be nice.

Thanks for the help.

Changed in libsdl1.2:
importance: Untriaged → Medium
status: Unconfirmed → Confirmed
Mark Reitblatt (mark-reitblatt) wrote :

I have a problem installing libsdl1.2-dev, but not the one you have. The problem seems to come from some strange dependency problem with libgl1-mesa-dev and libglu1-mesa-dev.

The following packages have unmet dependencies.
  libglu1-mesa-dev: Depends: libglu1-mesa (= 6.4.1-0ubuntu8) but 6.5.1-0ubuntu10 is to be installed
                    Depends: libgl1-mesa-dev but it is not going to be installedor
                             libgl-dev
E: Broken packages

Changed in glib2.0:
importance: Untriaged → Medium
status: Unconfirmed → Needs Info
Edm00se (edm00se) wrote :

I wound up being able to install libsdl1.2-dev when instead of using apt-get to install it, I used aptitude.

So:
sudo apt-get install libsdl1.2-dev
  wasn't working but what did was:
sudo aptitude install libsdl1.2-dev

Hi there, can you please ensure that you have the dapper-updates repositary enabled and do an 'apt-get get update'.

Aptitude also has better dependancy resolution, can you please try the suggested to:

  sudo aptitude install libsdl1.2-dev

and see if that copes better with updating the required chain.

Changed in glib2.0:
status: Needs Info → Rejected
Changed in mesa:
status: Confirmed → Rejected
Changed in libsdl1.2:
status: Unconfirmed → Needs Info
jisk (attema) wrote :

Hi,

I've got the same problem. (on Dapper 6.06). I've added all repositories, and tried both synaptic and aptitude.

'sudo aptitude install -f libsdl1.2-dev' gave the following:

...
The following packages are BROKEN:
  libglib2.0-dev
...
The following packages have unmet dependencies:
  libglib2.0-dev: Depends: libglib2.0-0 (= 2.10.2-1ubuntu3) but 2.10.3-0ubuntu1 is installed.

Daniel Holbach (dholbach) wrote :

Please attach your /etc/apt/sources.list to the bug report.

jisk (attema) wrote :

My /etc/apt/sources.list is attached here.

Daniel Holbach (dholbach) wrote :

Try adding

deb http://nl.archive.ubuntu.com/ubuntu/ dapper main restricted universe multiverse
deb-src http://nl.archive.ubuntu.com/ubuntu/ dapper main restricted universe multiverse

instead of

deb http://nl.archive.ubuntu.com/ubuntu/ dapper main restricted
deb-src http://nl.archive.ubuntu.com/ubuntu/ dapper main restricted

jisk (attema) wrote :

I changed the sources.list, still the same problem.

libglib2.0-dev still depends exactly on libglib 2.10.2-1ubuntu3 and doesn't accept the installed 2.10.3-0ubuntu1

Paul Dufresne (paulduf) wrote :

Hi! I am a bug triager making a follow up on this bug and make sure it is complete enough for a developer to investigate.
I am reopening on glib2.0 (source package for libglib2.0-dev), as it is this one that 'seems' to have a dependency problem.
I don't understand why it was rejected by Paul Sladen.
I am making it Confirmed on glib2.0 since the info requested have been given, although not from original poster.
Looking on https://launchpad.net/ubuntu/+source/glib2.0/ I see that your libglib2.0-dev version 2.10.3-0ubuntu1 have been "released" in pocket
updates (that's the only version to be there). I don't really kows what it means, but this is surely significative.

Changed in glib2.0:
status: Invalid → Confirmed
Paul Dufresne (paulduf) wrote :

Changing from 'Incomplete' to 'Confirmed' on libsdl1.2 too.

Changed in libsdl1.2:
status: Incomplete → Confirmed
Sebastien Bacher (seb128) wrote :

not a glib2.0 bug

Changed in glib2.0:
status: Confirmed → Invalid
Paul Dufresne (paulduf) wrote :

Sorry Sebastien! Seems it is the second time I walk on your toes in less than 24 hours.
I'd like better understand why it is not a glib2.0 bug.
Personally the problem seems more related to glib2.0-dev depends on an exact version of of libglib, than it has to do with libsdl1.2.
Seems the bug reporter would have problem installing any package that depends directly on indirectly on libglib2.0-dev, not just libsdl1.2.

Really just wishing better understand.

Sebastien Bacher (seb128) wrote :

That's alright, thank you for bug triaging ;)

The glib package is not known to be broken on dapper and other users would have opened bugs before if it was. The bug mentions "libglib2.0-dev: Depends: libglib2.0-0 (= 2.10.2-1ubuntu3) but 2.10.3-0ubuntu1 is to be installed", could you run "apt-cache policy libglib2.0-0 libglib2.0-dev libartsc0-dev"? It looks like libglib2.0-0 has been installed from dapper-updates and that you removed the updates source and it can't find the matching libglib2.0-dev version now

Paul Dufresne (paulduf) on 2007-07-08
Changed in libsdl1.2:
status: Confirmed → Incomplete
jisk (attema) wrote :

Thanks for trying to solve it! I'm now using Feisty, on which libsdl etc. is working fine btw, so I can't check the "apt-cache policy libglib2.0-0 libglib2.0-dev libartsc0-dev" anymore. I did edit /etc/apt/sources.list a few times, so the explanation in the previous post seems possible.

Paul Dufresne (paulduf) wrote :

Well I am closing the bug then.
Thanks jisk for these infos!

Changed in libsdl1.2:
assignee: nobody → dufresnep
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments