AIGLX: reverting to software rendering - AIGLX: Screen 0 is not DRI capable

Bug #537721 reported by Garazi on 2010-03-11
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
mesa (Ubuntu)
Undecided
Unassigned
Nominated for Maverick by Chris Mayo

Bug Description

AIGLX error: dlopen of /usr/lib/dri/nouveau_vieux_dri.so failed (/usr/lib/dri/nouveau_vieux_dri.so: cannot open shared object file: No such file or directory)

This error occurs during xorg init and it has as effect to disable DRI functionality.
So my display even in 2D is very slow.

I tried to add the following lines in a xorg.conf containing the same default config logged in xorg.0.log :
Section "ServerFlags"
Option "AIGLX" "off"
EndSection

Section "Extensions"
Option "Composite" "Disable"
EndSection

I tried this to follow recommendations of this web page :
http://fedoraproject.org/wiki/RenderingProject/aiglx#How_can_I_disable_AIGLX_and_the_compositing_extension.3F

But it was useless. DRI was always based on a software rasterizer.

I hope these informations will be enough interesting to help...

ProblemType: Bug
Architecture: i386
CurrentDmesg: [ 46.188007] eth2: no IPv6 routers present
Date: Thu Mar 11 23:10:05 2010
DistroRelease: Ubuntu 10.04
DkmsStatus: Error: [Errno 2] Aucun fichier ou dossier de ce type
MachineType: MSI MS-6380
Package: libgl1-mesa-dri 7.7-4ubuntu1
ProcCmdLine: root=UUID=9ec18bc6-8ce5-4ef5-b771-219d8a7dfdb1 ro quiet splash
ProcEnviron:
 LANG=fr_FR.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
SourcePackage: mesa
Uname: Linux 2.6.32-16-generic i686
dmi.bios.date: 11/30/2001
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 07.00T
dmi.board.name: MS-6380
dmi.board.vendor: MSI
dmi.board.version: 2.0
dmi.chassis.asset.tag: 0123ABC
dmi.chassis.type: 3
dmi.chassis.vendor: Uknown Chassis Manufacture
dmi.chassis.version: Version 1.00
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr07.00T:bd11/30/2001:svnMSI:pnMS-6380:pvr2.0:rvnMSI:rnMS-6380:rvr2.0:cvnUknownChassisManufacture:ct3:cvrVersion1.00:
dmi.product.name: MS-6380
dmi.product.version: 2.0
dmi.sys.vendor: MSI
system:
 distro: Ubuntu
 codename: lucid
 architecture: i686
 kernel: 2.6.32-16-generic

Garazi (garazi111) wrote :
Bryce Harrington (bryce) on 2010-03-12
Changed in mesa (Ubuntu):
status: New → Confirmed
Robert Hooker (sarvatt) wrote :

nouveau_vieux_dri.so does not exist in lucid, it is something in mesa 7.8 and the error message is normal and harmless. 2D acceleration is not dependant on AIGLX, there is not going to be any 3D support for nouveau in lucid. From your logs 2D EXA acceleration is working as intended.

Changed in mesa (Ubuntu):
status: Confirmed → Invalid
Garazi (garazi111) wrote :

Thanks for the answer !!

I have some few questions...

Is it also normal that glxinfo returns "OpenGL renderer string: Software Rasterizer" ?
And is it normal that compiz effects cannot be activated from "Preferences->Appearence" ?
Are they both needing 3D acceleration, 2D is not sufficient for them ?

emlinux (joel-emlinux) wrote :

Have similar problem on Dell D800 Laptop w/ Nvidia GeForce 4Ti chip.
Worked ok on previous releases but fails on 3.6.32. Kernel
X.log shows missing /usr/lib/dri/nouveau_vieux_dri.so but symptoms are different.
Icons and task bar are pixelated and distorted, but text and background pix are OK.
Tried reinstalling packages x-server-xorg-video-nouveau and libdrm-nouveau1
did not install this .so

pbhj (pbhj) wrote :

Same for me.

X using the nouveau driver for my geforce2 gts is extremely slow and cumbersome. Crashes often too.

LinuxFreak (bwvienna) wrote :

Hi,

At the 2.Nov.2010 i did the common update at synaptic and it killed my xserver.
(EE)AIGLX error: dlopen of usr/lib/dri/nouveau_viuex_dri.so could not be found or opened.

Before that i suddenly could in GDM not log in any more, it had an endless-loop, and jumped always back, after clicking my user..
the next day i had the (EE)AIGLX error: and the xserver died.. and i had in

.xsession-errors:
.: 34: Can't open /home/user/.profile

I found out, that on an old 10 GB hardisk (which i had installed some month ago), there was the AIGLX error too! but without the xserver problem i have now.

regards Astrophysik

_______
full story only in in german:
http://forum.ubuntuusers.de/topic/ee-aiglx-error-ubuntu-is-running-with-low-grap/

LinuxFreak (bwvienna) wrote :
LinuxFreak (bwvienna) wrote :

After these packets i got the error on lucid 10.04.1 -32Bit with the kernels:

2.6.32.25-generic
2.6.32.24-generic
2.6.32.21-generic

vg. AP

Garazi (garazi111) wrote :

Hi,

I have finally solved the problem by following this method (described in two different pages) :
http://ubuntuforums.org/showpost.php?p=10028543&postcount=38
http://www.oblurb.com/ubuntu-maverick-meerkat-nvidia-96-and-compiz.html

Paulus/laudaka (laudaka) wrote :

Hi,
I encountered this error while trying to install Ubuntu 10.04 (Lucid) on a low memory system as described here: https://help.ubuntu.com/community/Installation/LowMemorySystems

I had a prompt in tty7 that was clearly in an xterm of X11 but I couldn't type anything. So that's why I thought something was wrong. I still could switch to tty1 and the other virtual terminals. Turns out it was a beginner error why I thought X11 was malfunctioning. It had nothing to do with this error message.

The xterm in the X11 session in tty7 was working perfectly fine. I only needed to move the mouse cursor so the mouse cursor was hovering over the xterm. Then you can type in the xterm. As soon as you move the mouse away you can't type in the xterm any more.

And yes I know this might be off-topic for this bug report. But maybe other people Google this very same error message. When they are building an Ubuntu installation step by step.

Thanks for the tips mentioned here,
Paulus/laudaka

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers