[unichrome] netbook-launcher assert failure: netbook-launcher: via_tex.c:427: viaSwapOutWork: Assertion `sz == vmesa->total_alloc[heap]' failed.

Bug #534719 reported by Oliver Gerlich on 2010-03-08
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mesa
Confirmed
Medium
mesa (Debian)
Fix Released
Unknown
mesa (Ubuntu)
Medium
Unassigned
netbook-launcher (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: netbook-launcher

Started Lucid Alpha3 Netbook Edition (i386) on a VIA Epia system, booted from USB stick. It booted and can be used basically, but the whole "desktop" area does not react to clicks, and after a few minutes running it the Apport symbol came up for this crash. No idea what really caused this or what the netbook-launcher does. Currently, the "desktop" can be displayed but still does not react to clicks.

ProblemType: Crash
Architecture: i386
AssertionMessage: netbook-launcher: via_tex.c:427: viaSwapOutWork: Assertion `sz == vmesa->total_alloc[heap]' failed.
Date: Mon Mar 8 22:33:57 2010
DistroRelease: Ubuntu 10.04
DkmsStatus: Error: [Errno 2] No such file or directory
ExecutablePath: /usr/bin/netbook-launcher
GConfNonDefault:
 /apps/netbook-launcher/disable_single_instance=false
 /apps/netbook-launcher/force_low_graphics=false
LiveMediaBuild: Ubuntu-Netbook 10.04 "Lucid Lynx" - Alpha i386 (20100224.3)
MachineType: VIA Technologies, Inc. VT8623-8235
Package: netbook-launcher 1:2.1.13-0ubuntu1
ProcCmdLine: BOOT_IMAGE=/casper/vmlinuz noprompt cdrom-detect/try-usb=true file=/cdrom/preseed/hostname-netbook.seed boot=casper initrd=/casper/initrd.lz quiet splash -- debian-installer/language=de console-setup/layoutcode?=de
ProcCmdline: netbook-launcher --show-favorites
ProcEnviron:
 LANG=de_DE.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-14.20-generic
RelatedPackageVersions:
 xserver-xorg 1:7.5+1ubuntu8
 libgl1-mesa-glx 7.7-3ubuntu1
 libdrm2 2.4.18-1ubuntu2
 xserver-xorg-video-intel 2:2.9.1-1ubuntu6
Signal: 6
SourcePackage: netbook-launcher
StacktraceTop:
 __kernel_vsyscall ()
 raise () from /lib/tls/i686/cmov/libc.so.6
 abort () from /lib/tls/i686/cmov/libc.so.6
 __assert_fail () from /lib/tls/i686/cmov/libc.so.6
 viaSwapOutWork () from /usr/lib/dri/unichrome_dri.so
Title: netbook-launcher assert failure: netbook-launcher: via_tex.c:427: viaSwapOutWork: Assertion `sz == vmesa->total_alloc[heap]' failed.
Uname: Linux 2.6.32-14-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 05/19/2004
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: 6.00 PG
dmi.board.name: EPIA-M
dmi.chassis.type: 3
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvr6.00PG:bd05/19/2004:svnVIATechnologies,Inc.:pnVT8623-8235:pvr:rvn:rnEPIA-M:rvr:cvn:ct3:cvr:
dmi.product.name: VT8623-8235
dmi.sys.vendor: VIA Technologies, Inc.
glxinfo: Error: [Errno 2] No such file or directory
system:
 distro: Ubuntu
 architecture: i686kernel: 2.6.32-14-generic

Oliver Gerlich (ogerlich) wrote :
Oliver Gerlich (ogerlich) wrote :
visibility: private → public
Oliver Gerlich (ogerlich) wrote :

Btw. I have changed screen resolution after boot... It came up with 1600x1200@60Hz (apparently the stupid 17" CRT announces that mode) so I used gnome-display-properties to switch to 1152x864@85Hz, to get a usable display.

Didier Roche (didrocks) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. That bug is quite strange as glxinfo show that you have GL rendering. Well, as a workaround, you can try the 2D launcher, logging out from your session and choosing the "UNE 2D session" in gdm.

Changed in netbook-launcher (Ubuntu):
importance: Undecided → Low
status: New → Triaged

StacktraceTop:
 __kernel_vsyscall ()
 ?? ()
 ?? ()
 ?? ()
 ?? ()

Changed in netbook-launcher (Ubuntu):
status: Triaged → Invalid
Download full text (5.4 KiB)

Thank you for your report!

However, processing it in order to get sufficient information for the
developers failed (it does not generate an useful symbolic stack trace). This
might be caused by some outdated packages which were installed on your system
at the time of the report:

libgcc1: installed version 1:4.4.3-2ubuntu2, latest version: 1:4.4.3-3ubuntu1
mountall: installed version 2.5, latest version: 2.7
netbook-launcher: installed version 1:2.1.13-0ubuntu1, latest version: 1:2.1.14-0ubuntu1
libbonobo2-common: installed version 2.24.2-1, latest version: 2.24.2-1build1
libxrandr2: installed version 2:1.3.0-2, latest version: 2:1.3.0-2build1
libnetbook-launcher-0: installed version 1:2.1.13-0ubuntu1, latest version: 1:2.1.14-0ubuntu1
libldap-2.4-2: installed version 2.4.21-0ubuntu1, latest version: 2.4.21-0ubuntu2
libbonoboui2-common: installed version 2.24.2-1ubuntu2, latest version: 2.24.2-1ubuntu3
tzdata: installed version 2010b-1, latest version: 2010c-1
libwnck-common: installed version 1:2.29.6-0ubuntu1, latest version: 1:2.29.91-0ubuntu1
libbonoboui2-0: installed version 2.24.2-1ubuntu2, latest version: 2.24.2-1ubuntu3
libglade2-0: installed version 1:2.6.4-1, latest version: 1:2.6.4-1build1
libgl1-mesa-glx: installed version 7.7-3ubuntu1, latest version: 7.7-4ubuntu1
libasound2: installed version 1.0.22-0ubuntu4, latest version: 1.0.22-0ubuntu6
libplymouth2: installed version 0.8.0~-10ubuntu1, latest version: 0.8.0~-12
libgtk2.0-common: installed version 2.19.5-1ubuntu6, latest version: 2.19.6-1ubuntu4
libncursesw5: installed version 5.7+20090803-2ubuntu2, latest version: 5.7+20090803-2ubuntu3
coreutils: installed version 7.4-2ubuntu1, latest version: 7.4-2ubuntu2
libgdu0: installed version 2.29.0~git20100222.e85476-1, latest version: 2.29.90-2
libgail-common: installed version 2.19.5-1ubuntu6, latest version: 2.19.6-1ubuntu4
gvfs: installed version 1.5.4-0ubuntu1, latest version: 1.5.5-0ubuntu1
libglib2.0-0: installed version 2.23.4-1ubuntu1, latest version: 2.23.5-1ubuntu1
lzma: installed version 4.43-14ubuntu1, latest version: 4.43-14ubuntu2
libpcre3: installed version 7.8-3, latest version: 7.8-3build1
libgail18: installed version 2.19.5-1ubuntu6, latest version: 2.19.6-1ubuntu4
cpp-4.4: installed version 4.4.3-2ubuntu2, latest version: 4.4.3-3ubuntu1
libc-bin: installed version 2.11.1-0ubuntu2, latest version: 2.11.1-0ubuntu4
libcairo2: installed version 1.8.8-2ubuntu2, latest version: 1.8.10-2ubuntu1
libgnomeui-common: installed version 2.24.2-1, latest version: 2.24.2-1build1
libgvfscommon0: installed version 1.5.4-0ubuntu1, latest version: 1.5.5-0ubuntu1
libart-2.0-2: installed version 2.3.20-2, latest version: 2.3.20-2build1
libstartup-notification0: installed version 0.10-1, latest version: 0.10-1build1
libgnome-menu2: installed version 2.29.91-0ubuntu1, latest version: 2.29.92-0ubuntu2
ncurses-bin: installed version 5.7+20090803-2ubuntu2, latest version: 5.7+20090803-2ubuntu3
findutils: installed version 4.4.2-1, latest version: 4.4.2-1ubuntu1
tsconf: installed version 1.0-7, latest version: 1.0-7build1
cpio: installed version 2.10-1ubuntu1, latest version: 2.10-1ubuntu2
libncurses5: installed version 5.7+20090803-2ubun...

Read more...

tags: removed: need-i386-retrace
Bryce Harrington (bryce) on 2010-03-10
tags: added: crash
Changed in mesa (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) wrote :

Hmm, not entirely certain what is going wrong here. Looks like the -openchrome driver loaded properly, but the dri driver failed for some reason. You could try switching DRI off in xorg.conf as a workaround.

Changed in mesa (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Changed in mesa:
status: Unknown → Confirmed
Changed in mesa (Debian):
status: Unknown → Confirmed
summary: - netbook-launcher assert failure: netbook-launcher: via_tex.c:427:
- viaSwapOutWork: Assertion `sz == vmesa->total_alloc[heap]' failed.
+ [unichrome] netbook-launcher assert failure: netbook-launcher:
+ via_tex.c:427: viaSwapOutWork: Assertion `sz ==
+ vmesa->total_alloc[heap]' failed.
Changed in mesa:
importance: Unknown → Medium
Changed in mesa:
importance: Medium → Unknown
Changed in mesa:
importance: Unknown → Medium
Changed in mesa (Debian):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.