Ubuntu

mesa applications crash Mobility 7500 and corrupt filesystem

Reported by rlangner on 2009-11-05
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
mesa (Ubuntu)
Undecided
Unassigned

Bug Description

After upgrading to Karmic with ATI Mobility 7500 graphics, applications which use 3D graphics and the libgl1-mesa-dri 7.6.0-1ubuntu4 libraries crash the entire system.

The crash corrupts the file-system and commands are no longer available.

For for example the command "ls" returns:

error while loading shared libraris: /lib/i686/cmov/libc.so.6 : invalid ELF header

After rebooting, the file-system is corrupt and has to be repaired with fsck.

Bryce Harrington (bryce) wrote :

Hi rynolangner,

Please attach the output of `lspci -vvnn` and `dmesg`, and attach your /var/log/Xorg.0.log (and maybe Xorg.0.log.old) file from after reproducing this issue. If you're using a custom /etc/X11/xorg.conf please attach that as well.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: crash
tags: added: needs-xorglog
tags: added: needs-lspci-vvnn
Changed in mesa (Ubuntu):
status: New → Incomplete
rlangner (rynolangner) wrote :
rlangner (rynolangner) wrote :
rlangner (rynolangner) wrote :
rlangner (rynolangner) wrote :
rlangner (rynolangner) wrote :
rlangner (rynolangner) on 2009-11-17
Changed in mesa (Ubuntu):
status: Incomplete → Confirmed
status: Confirmed → In Progress
status: In Progress → New
rlangner (rynolangner) wrote :

This bug appears to be related to Debian bug #550977

rlangner (rynolangner) on 2009-12-12
Changed in mesa (Ubuntu):
assignee: nobody → Bryce Harrington (bryceharrington)
assignee: Bryce Harrington (bryceharrington) → nobody
Gary.Pajer (gary-pajer) wrote :

A partial workaround: downgrade libgl1-mesa to jaunty. See http://www.ode2.com/?p=44 Prevents file system corruption; renders incorrectly in a some cases.

Gary.Pajer (gary-pajer) wrote :

I get apparently the same bug (file system corruption) on my system (Thinkpad T41, Kubuntu 9.10, kernel 2.6.31-17-generic) using Mesa 7.7 from xorg-edgers see https://launchpad.net/~xorg-edgers/+archive/ppa and https://wiki.ubuntu.com/XorgOnTheEdge). Although I neglected to check the exact mesa version, I believe it was 7.7.0~git20100104+mesa-7-7-branch.1e414df8-0ubuntu0sarvatt

See also this kernel bug report: http://bugzilla.kernel.org/show_bug.cgi?id=14535
and this Debian report: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=550977
It's also reported on other Linuxes

The Debian people classify it "critical" and I have to agree. The whole system comes down irretrievably, with file system damage and possible data loss. How can we figure out if the bug is in the kernel or in mesa?

Gary.Pajer (gary-pajer) wrote :

I also tried kernel 2.6.32-02063203-generic with the default mesa package 7.6.0-1ubuntu4. Same result: file system corruption.

Alexander Kiel (alexanderkiel) wrote :

I have a Dell D600 Laptop here. It has a Radeon 9000 (RV250). I installed Ubuntu Netbook Remix 9.10. After the first boot into the new system, I can't start any application and I get the described errors. So the bug effects normal users just installing UNR on a laptop with old Radeon cards since UNR uses 3D for normal desktop.

Gary.Pajer (gary-pajer) wrote :

I'd like to get some traction on this bug. It causes system crashes, file system corruption, and data loss.
With those serious symptoms I think it's importance should be bumped up from "Undecided", and perhaps assigned to someone other than "Unassigned". The Debian people classify it "critical" http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=550562

 It might be a kernel problem, but it hasn't gotten much traction at bugzilla.kernel either http://bugzilla.kernel.org/show_bug.cgi?id=14535 and they suggest making sure that it has a high priority in the distros as well as the kernel.

Personal note: I really need the 3D functionality to do my work. I'm practically dead in the water on this machine, not to mention the file system corruption I experience now and then when I accidently execute a 3D app.

Gary.Pajer (gary-pajer) wrote :

FYI, this bug has been fixed upstream in both kernel and Mesa. See http://bugzilla.kernel.org/show_bug.cgi?id=14535 and the 1-line fix to Mesa: http://cgit.freedesktop.org/mesa/mesa/commit/?id=b75d40736997911e00cab339a7f15ec9bc86e535

Bryce Harrington (bryce) on 2010-03-05
tags: added: karmic
Timo Aaltonen (tjaalton) wrote :

closing as fixed, lucid has mesa 7.7 and kernel drm from 2.6.33.

Changed in mesa (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.