(Needs mesa 25b492b9) Some games using 3D-acceleration don't work on Jaunty with ATI chipsets

Bug #374590 reported by Burned Out on 2009-05-10
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xserver-xorg-driver-ati
Fix Released
Medium
mesa (Ubuntu)
Medium
Unassigned

Bug Description

Some games (Seen people have this problem with Wolfenstein: Enemy Territory, Warsow, and a few other games) don't run at all on Ubuntu 9.04 with the Radeon driver (Might concern other drivers for Radeon cards too).

When trying to Enemy Territory it didn't launch at all, instead screen went black for a second or so and my resolution was set to 800x600.

Running through console printed this:

ET 2.60b linux-i386 May 8 2006
----- FS_Startup -----
Current search path:
/home/burneddi/.etwolf/etmain
/usr/local/games/enemy-territory/etmain/pak2.pk3 (22 files)
/usr/local/games/enemy-territory/etmain/pak1.pk3 (10 files)
/usr/local/games/enemy-territory/etmain/pak0.pk3 (3725 files)
/usr/local/games/enemy-territory/etmain/mp_bin.pk3 (6 files)
/usr/local/games/enemy-territory/etmain

----------------------
3763 files in pk3 files
execing default.cfg
couldn't exec language.cfg
execing autoexec.cfg
execing valenickcrap.cfg
execing class.cfg
Hunk_Clear: reset the hunk ok

------- Input Initialization -------
Joystick is not active.
------------------------------------
Bypassing CD checks
----- Client Initialization -----
----- Initializing Renderer ----
-------------------------------
----- Client Initialization Complete -----
----- R_Init -----
...loading libGL.so.1: Initializing OpenGL display
...setting mode 4: 800 600
Using XFree86-VidModeExtension Version 2.2
XF86DGA Mouse (Version 2.0) initialized
XFree86-VidModeExtension Activated at 800x600
Using 8/8/8 Color bits, 24 depth, 0 stencil display.
X Error of failed request: BadMatch (invalid parameter attributes)
  Major opcode of failed request: 1
  Minor opcode of failed request: 0
  Serial number of failed request: 41
X Error of failed request: BadWindow (invalid Window parameter)
  Major opcode of failed request: 18
  Minor opcode of failed request: 0
  Serial number of failed request: 42
X Error of failed request: BadWindow (invalid Window parameter)
  Major opcode of failed request: 18
  Minor opcode of failed request: 0
  Serial number of failed request: 43
X Error of failed request: BadWindow (invalid Window parameter)
  Major opcode of failed request: 8
  Minor opcode of failed request: 0
  Serial number of failed request: 44
X Error of failed request: BadWindow (invalid Window parameter)
  Major opcode of failed request: 12
  Minor opcode of failed request: 0
  Serial number of failed request: 45
X Error of failed request: BadWindow (invalid Window parameter)
  Major opcode of failed request: 18
  Minor opcode of failed request: 0
  Serial number of failed request: 48
X Error of failed request: BadDrawable (invalid Pixmap or Window parameter)
  Major opcode of failed request: 136
  Minor opcode of failed request: 7
  Serial number of failed request: 53
X Error of failed request: BadValue (integer parameter out of range for operation)
  Major opcode of failed request: 154
  Minor opcode of failed request: 26
  Serial number of failed request: 53
Received signal 11, exiting...
Muistialueen ylitys (<-- Sorry, my Ubuntu locale is finnish, in english that'd be something like "exceeded memory area")

The game ran fine on 8.10 with my ATI Radeon 8500 card using the "radeon" driver. Same driver on 9.04 didn't work. glxinfo | grep render said that direct rendering is on.

"Fixed" this by reinstalling to 8.10, would be nice to have this working in 9.04.

Related branches

Created an attachment (id=25687)
xorg config file

Created an attachment (id=25688)
xorg log file

Download full text (3.3 KiB)

Some games (Seen people have this problem with Wolfenstein: Enemy Territory, Warsow, and a few other games) don't run at all on Ubuntu 9.04 with the Radeon driver (Might concern other drivers for Radeon cards too).

When trying to Enemy Territory it didn't launch at all, instead screen went black for a second or so and my resolution was set to 800x600.

Running through console printed this:

ET 2.60b linux-i386 May 8 2006
----- FS_Startup -----
Current search path:
/home/burneddi/.etwolf/etmain
/usr/local/games/enemy-territory/etmain/pak2.pk3 (22 files)
/usr/local/games/enemy-territory/etmain/pak1.pk3 (10 files)
/usr/local/games/enemy-territory/etmain/pak0.pk3 (3725 files)
/usr/local/games/enemy-territory/etmain/mp_bin.pk3 (6 files)
/usr/local/games/enemy-territory/etmain

----------------------
3763 files in pk3 files
execing default.cfg
couldn't exec language.cfg
execing autoexec.cfg
execing valenickcrap.cfg
execing class.cfg
Hunk_Clear: reset the hunk ok

------- Input Initialization -------
Joystick is not active.
------------------------------------
Bypassing CD checks
----- Client Initialization -----
----- Initializing Renderer ----
-------------------------------
----- Client Initialization Complete -----
----- R_Init -----
...loading libGL.so.1: Initializing OpenGL display
...setting mode 4: 800 600
Using XFree86-VidModeExtension Version 2.2
XF86DGA Mouse (Version 2.0) initialized
XFree86-VidModeExtension Activated at 800x600
Using 8/8/8 Color bits, 24 depth, 0 stencil display.
X Error of failed request: BadMatch (invalid parameter attributes)
  Major opcode of failed request: 1
  Minor opcode of failed request: 0
  Serial number of failed request: 41
X Error of failed request: BadWindow (invalid Window parameter)
  Major opcode of failed request: 18
  Minor opcode of failed request: 0
  Serial number of failed request: 42
X Error of failed request: BadWindow (invalid Window parameter)
  Major opcode of failed request: 18
  Minor opcode of failed request: 0
  Serial number of failed request: 43
X Error of failed request: BadWindow (invalid Window parameter)
  Major opcode of failed request: 8
  Minor opcode of failed request: 0
  Serial number of failed request: 44
X Error of failed request: BadWindow (invalid Window parameter)
  Major opcode of failed request: 12
  Minor opcode of failed request: 0
  Serial number of failed request: 45
X Error of failed request: BadWindow (invalid Window parameter)
  Major opcode of failed request: 18
  Minor opcode of failed request: 0
  Serial number of failed request: 48
X Error of failed request: BadDrawable (invalid Pixmap or Window parameter)
  Major opcode of failed request: 136
  Minor opcode of failed request: 7
  Serial number of failed request: 53
X Error of failed request: BadValue (integer parameter out of range for operation)
  Major opcode of failed request: 154
  Minor opcode of failed request: 26
  Serial number of failed request: 53
Received signal 11, exiting...
Muistialueen ylitys (<-- Sorry, my Ubuntu locale is finnish, in english that'd be something like "exceeded memory area")

The game ran fine on 8.10 with my ATI Radeon 8500 card using the "radeon" driver. Same driver on 9....

Read more...

Created an attachment (id=25726)
Don't expose fbconfigs without stencil if stencil is accelerated

Does this Mesa patch help?

Same problem here. I can confirm that downgrading the xserver fixed the issue for Enemy Territory with the reported errors.

Other OpenGL apps were very slow in the new version.
My card is an ATI Technologies Inc RV280 [Radeon 9200 PRO]

Same problem here with quake3

Using XFree86-VidModeExtension Version 2.2
XF86DGA Mouse (Version 2.0) initialized
XFree86-VidModeExtension Activated at 800x600
Using 8/8/8 Color bits, 24 depth, 0 stencil display.
X Error of failed request: BadMatch (invalid parameter attributes)
  Major opcode of failed request: 1
  Minor opcode of failed request: 0
  Serial number of failed request: 41
X Error of failed request: BadWindow (invalid Window parameter)
  Major opcode of failed request: 18
  Minor opcode of failed request: 0
  Serial number of failed request: 42
X Error of failed request: BadWindow (invalid Window parameter)
  Major opcode of failed request: 18
  Minor opcode of failed request: 0
  Serial number of failed request: 43
X Error of failed request: BadWindow (invalid Window parameter)
  Major opcode of failed request: 8
  Minor opcode of failed request: 0
  Serial number of failed request: 44
X Error of failed request: BadWindow (invalid Window parameter)
  Major opcode of failed request: 12
  Minor opcode of failed request: 0
  Serial number of failed request: 45
X Error of failed request: BadWindow (invalid Window parameter)
  Major opcode of failed request: 18
  Minor opcode of failed request: 0
  Serial number of failed request: 48
X Error of failed request: BadDrawable (invalid Pixmap or Window parameter)
  Major opcode of failed request: 136
  Minor opcode of failed request: 7
  Serial number of failed request: 53
X Error of failed request: BadValue (integer parameter out of range for operation)
  Major opcode of failed request: 154
  Minor opcode of failed request: 26
  Serial number of failed request: 53
Received signal 11, exiting...
Segmentation fault

Changed in ubuntu:
status: New → Confirmed

I modified the 'Don't expose fbconfigs without stencil if stencil is accelerated' patch a little to work on the stable 7.4.1 Mesa branch and applied it. Unfortunately it didn't change anything, I still get the same behaviour and console output when trying to start the game.

I'll try to compile and install the Mesa 7.5 development branch with the same patch and see if that makes a difference.

Same problem with version 7.5-rc1.

However I might be doing something wrong with compiling/installing it because glxinfo | grep version still indicates: 'OpenGL version string: 1.3 Mesa 7.4.1'. I think this should be 'Mesa 7.5'? Do I need to do anything special after compiling and installing the new Mesa library in order to use it?

ATI officially dropped support for a whole boatload of chipsets with the latest release. You are probably no longer using the proprietary driver because your card is not supported. The problem is, the latest X.org is not supportd by the old driver.

Try:

glxinfo |grep 'direct rendering'

Yes=Good
No=Bad

Your 3D will not be good enough for games without direct rendering.

(In reply to comment #6)
> However I might be doing something wrong with compiling/installing it because
> glxinfo | grep version still indicates: 'OpenGL version string: 1.3 Mesa
> 7.4.1'. I think this should be 'Mesa 7.5'?

Sounds like maybe you're using indirect rendering, try setting LIBGL_DEBUG=verbose to get more information.

Note that for the patch to take effect you also need to restart the X server and verify with

grep _dri /var/log/Xorg.0.log

that it's loading the patched r300_dri.so. Guess I should have mentioned this before.

Yes, I know and I am using the open source radeon-driver (card is a readeon 9500 pro).
Direct rendering works and 3D efects on KDE4.2 work, too (nevertheless I turned off the effects).

So as I can see the bug is in X.org or the open source driver?

Burned Out (burneddi) wrote :

If I can recall, fglrx never supported cards below Radeon 9600.

I'm now running Ubuntu 8.10, direct rendering is ON, driver is RADEON.
In Ubuntu 9.04, direct rendering was ON, driver was RADEON. The game just refused to launch.

So I would theorize it's a bug with X.org.

Ok, I misunderstood. I was running through the list of bugs looking for some
I thought I understood. I had a problem with the latest proprietary driver
and wanted to maybe share solutions where possible.

--
Bryan Harris
Research Engineer
Structures and Materials Evaluation Group
<email address hidden>
http://www.udri.udayton.edu/
(937) 229-5561
On Wednesday 13 May 2009 11:47:45 Burned Out wrote:
> If I can recall, fglrx never supported cards below Radeon 9600.
>
> I'm now running Ubuntu 8.10, direct rendering is ON, driver is RADEON.
> In Ubuntu 9.04, direct rendering was ON, driver was RADEON. The game just
> refused to launch.
>
> So I would theorize it's a bug with X.org.

I am not sure if it is a bug in Xorg, because nvidia-driver with nvidia cards works fine whith the new version of xorg. So I suggest it is a problem in the open source radeon driver...

Scott Howard (showard314) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage. I have classified this bug as a bug in xserver-xorg-video-ati.
For future reference you might be interested to know that a lot of applications have bug reporting functionality built in to them. This can be accessed via the Report a Problem option in the Help menu for the application with which you are having an issue. You can learn more about this feature at https://wiki.ubuntu.com/ReportingBugs.

affects: ubuntu → xserver-xorg-video-ati (Ubuntu)
Wladimir Krasnov (wk2001) wrote :

I think we were not sure, where the bug belongs to, but xserver-xorg-video-ati seems right, thank you!

Wladimir Krasnov (wk2001) wrote :

Can anynone try to install the xserver-xorg-video-ati driver from this PPA: https://edge.launchpad.net/~ubuntu-x-swat/+archive/x-updates/ ? It is newer (04/22)...
Does it work with it? (I currently have no possibility to test it)

Alright. Sorry for the long delay, I've been very busy.

I just recompiled the r300 driver with the patch and it did fix it! The game works very well now. I also compiled the Mesa sources from git without the patch, to make sure it wasn't just the newer Mesa code that fixed it, but without the patch it doesn't work. So thank you very much Michel!

I'm not really sure what to do with this bug. Should I mark it as resolved? Will this patch make it into the code for Mesa 7.5?

I will be out of the office from Monday May 25th through Wednesday June 3rd for a conference in Spain. I will still be checking and responding to email, but keep in mind my time zone when expecting a response.

For any time sensitive Linux issues, please contact Amit Bhutani.
For any critical FI related issues, please contact Veronica Camp.

The patch of Michel here: https://bugs.freedesktop.org/show_bug.cgi?id=21653 seems to solve the problem!

But can someone describe me please how I can apply it on my ubuntu (I am familiar with make, gcc etc. but still need a small tutorial, please)

Changed in xserver-xorg-driver-ati:
status: Unknown → Confirmed
Scott Howard (showard314) wrote :

If you are interested in patching (or fixing this bug), check out this link:
https://wiki.ubuntu.com/Bugs/HowToFix

Also, join #ubuntu-bugs or #ubuntu-motu on IRC (freenode), and ask any questions you have.

Ubuntu's IRC channels (and instructions on how to use IRC) are found at https://help.ubuntu.com/community/InternetRelayChat.

What most likely will happen to this bug:
1) someone at X.org will fix this bug
2
) the fix will be incorporated into a future version of the drivers from X.org
3) Debian will package the future version from X.org
4) Ubuntu will import Debian's package

If you'd like to help with the process, follow the instructions at https://wiki.ubuntu.com/Bugs/HowToFix, post your patch here, and subscribe ubuntu-universe-sponsors (as described in the "HowToFix" wiki page). It also would be helpful to get your patch into Debian. Ask around on #ubuntu-motu for help with that.

(In reply to comment #8)
>
> I'm not really sure what to do with this bug. Should I mark it as resolved?

No, that's only done once the fix lands in Git.

> Will this patch make it into the code for Mesa 7.5?

Not sure yet. It's really just a workaround and may not help in all cases, e.g. when running X at depth 16. It would probably be better to fix the xserver GLX code to mark the 32 bit ARGB visual as non-conformant again without DRI2.

The patch attached in this bug also fixed my problem in bug #21936

*** Bug 21936 has been marked as a duplicate of this bug. ***

tags: added: bitesize

Better fix pushed to Git master / mesa_7_5_branch as 25b492b976632269dfa3de164545d50a53c090ce and cherry-picked to mesa_7_4_branch as a3537de1ddc834c2e6efc05bca4d1e4b1a51242e .

Changed in xserver-xorg-driver-ati:
status: Confirmed → Fix Released
Changed in xserver-xorg-video-ati (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged

I'll make a debdiff/ubuntu version of the previously mentioned patch

Changed in xserver-xorg-video-ati (Ubuntu):
assignee: nobody → David Stansby (dstansby)
status: Triaged → In Progress

Seems like the ubuntu source is quite a mess at the moment, and I can't find the file mentioned in the patch above. I think I'll leave this one to upstream.

Changed in xserver-xorg-video-ati (Ubuntu):
assignee: David Stansby (dstansby) → nobody
status: In Progress → Confirmed
Bryce Harrington (bryce) wrote :

Bumping over to mesa since upstream patched that to fix this issue.

Changed in xserver-xorg-video-ati (Ubuntu):
status: Confirmed → In Progress
summary: - Some games using 3D-acceleration don't work on Jaunty with ATI chipsets
+ (Needs mesa 25b492b9) Some games using 3D-acceleration don't work on
+ Jaunty with ATI chipsets
affects: xserver-xorg-video-ati (Ubuntu) → mesa (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mesa - 7.6.0~git20090817.7c422387-0ubuntu1

---------------
mesa (7.6.0~git20090817.7c422387-0ubuntu1) karmic; urgency=low

  [Bryce Harrington]
  * Checkout from git 20090817 (master branch) up to commit
    7c4223876b4f8a78335687c7fcd7448b5a83ad10
    + Add DRI2 support to -ati
      (LP: #329654, #404428, #327698, #321108)
    + Fix portion of MythTV Frontend does not work with RADEON DRI
      (LP: #341898)
    + Fix selection mode on RS482
      (LP: #273329)
    + Fix issue running 3D acceleration games on ATI chipsets
      (LP: #374590)
    + Provide DRI2 swap buffers
      (LP: #377090)
    + Fix blender unusable with UXA when DRI2 enabled
      (LP: #353763)
  * Drop 108_bo_assertion.patch (applied upstream)

  [Robert Hooker]
  * Only added debian/ tree from origin/ubuntu
  * Enable r600 driver. Note that it requires seperate drm modules
    not provided in this PPA or in ubuntu, and also does not work with
    KMS.

 -- Bryce Harrington <email address hidden> Fri, 21 Aug 2009 16:13:50 -0700

Changed in mesa (Ubuntu):
status: In Progress → Fix Released
Changed in xserver-xorg-driver-ati:
importance: Unknown → Medium
Changed in xserver-xorg-driver-ati:
importance: Medium → Unknown
Changed in xserver-xorg-driver-ati:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.