Ubuntu

OpenGL subroutine man pages missing

Reported by Yohumbus on 2006-02-19
68
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Ubuntu
Medium
Unassigned
mesa (Debian)
New
Undecided
Unassigned
mesa (Ubuntu)
Low
Unassigned

Bug Description

As a convenience issue it seems that the man pages for programming openGL aren't installed with any of the development or documentation packages for X or mesa. From various sites I have gathered that these generally come with the development files for X.org but Im not sure... I have installed the KDE development metapackage and I get the kdevelop doc .toc file for opengl but it is useless without the man pages installed

Aric Cyr (acyr) wrote :

OpenGL man pages have been missing since Breezy. I really hope we can get them into Dapper! It is very inconvenient for 3D developers when the GL man pages are not available.

Paul Sladen (sladen) wrote :

Thanks for this - I'll probably hit it when I next want to write some GL code. Can you please do a:

  dpkg -S '/usr/share/man*glBegin*'

to find out which package they used to come from, then an:

  apt-cache show $package_name | grep ^Source:

to find out which source-package. Then we can try to hunt them down again (I think they are probably copied in from somewhere external and perhaps the licensing terms don't allow them to be distributed anymore?)

Changed in mesa-common-dev:
status: Unconfirmed → Needs Info
Russell Power (russell-power) wrote :

I didn't start using Ubuntu until Dapper, so I'm not aware of the original Ubuntu package that would have stored this data.

However, given how useful it's been to me, I scrounged around for a while and found the Debian package that contains the manpages (along with some debug libraries):

http://packages.debian.org/stable/libdevel/xlibmesa-gl-dev

Manually unpacking and copying the manpages over has really made me happy :). Not sure if that's helpful for building the final package, but it's certainly useful for me in the interim. I didn't see any licensing info in the pages themselves; but since they're in debian stable it seems like there shouldn't be too much of a conflict.

Paul Sladen (sladen) wrote :

Hi Russell,

This is from the stable version of Debian (aka 'sarge'); if you can find the equivalent testing/unstable package that the manpages from moved to they should be in the same place in Ubuntu.

The package, as included above is a virtual package that is present to support migrations between versions of Debian/Ubuntu.

I apologise that I don't off-hand know which package they would be in now; if you find the name of one of the manpages that you have installed and try searching with it on:

  http://packages.debian.org/

or packages.ubuntu.com then we maybe able to track down if they've been moved somewhere else; and if not, to look into repackaging them. (Ideally first by getting them back into Debian and synching across to Ubuntu).

Searching for glBegin on debian yielded only the result previously
mentioned, in stable. The package is absent from unstable/testing.

On ubuntu, it seems the package disappeared after hoary which had it
in a package of the same name:

http://packages.ubuntu.com/hoary/libdevel/xlibmesa-gl-dev

It's not present in breezy or dapper.

Google doesn't report any other packages that have picked up the man page:

http://www.google.com/search?q=glbegin.3x.gz+site:packages.debian.org&hl=en&lr=&pwst=1&filter=0

But some packages have (obviously) picked up the slack in terms of say, libgl.a.

http://www.google.com/search?hl=en&q=libGL.a+site%3Apackages.debian.org+-xlibmesa-gl-dev

I'm not sure which of these new packages *should* contain the man
pages, if any, but hopefully you'll have a better idea then me :).

R
On 8/13/06, Paul Sladen <email address hidden> wrote:
> Hi Russell,
>
> This is from the stable version of Debian (aka 'sarge'); if you can
> find the equivalent testing/unstable package that the manpages from
> moved to they should be in the same place in Ubuntu.
>
> The package, as included above is a virtual package that is present to
> support migrations between versions of Debian/Ubuntu.
>
> I apologise that I don't off-hand know which package they would be in
> now; if you find the name of one of the manpages that you have
> installed and try searching with it on:
>
> http://packages.debian.org/
>
> or packages.ubuntu.com then we maybe able to track down if they've been
> moved somewhere else; and if not, to look into repackaging them.
> (Ideally first by getting them back into Debian and synching across to
> Ubuntu).
>
> --
> OpenGL subroutine man pages missing
> https://launchpad.net/bugs/32042
>

dhenry (tfc-duke) wrote :

These man pages are still missing in Edgy... since Breezy. Is there a chance to see them in edgy?

Timo Aaltonen (tjaalton) wrote :

They cannot be distributed due to licensing issues. Hopefully it will be resolved soon.

Changed in mesa:
importance: Wishlist → Low
status: Needs Info → Confirmed
Changed in mesa:
status: Unknown → Confirmed
Kjmph (kjmph) wrote :

Bump... we are now up to 7.10, and still no OpenGL manpages on Ubuntu?

kubuntu_user (anibalmorales) wrote :

Other distributions, like Fedora, include them. ???

coorasse (arodi) wrote :

How to manually install them?

dhenry (tfc-duke) wrote :

I don't know if those pages exist in 'man' format, but you can get latests online at : http://www.opengl.org/sdk/docs/man/

Kjmph (kjmph) wrote :

Here is a starter copy of them in man format:

ftp://ftp.sgi.com/sgi/opengl/doc/

See mangl.tar.Z, manglu.tar.Z, and manglx.tar.Z. I think these are the same man pages installed on Gentoo, and on Mac OS X.

dhenry (tfc-duke) wrote :

These manpages are very old.

coorasse (arodi) wrote :

I resolved with man packages. there is a Imakefile in each one. Just give xmkmf && make && make install

Changed in mesa:
status: Confirmed → Fix Committed
Changed in mesa:
status: Fix Committed → Fix Released
Sulaiman A. Mustafa (seininn) wrote :

people, there should be at least one package containing openGL man pages. i know this might seem unimportant these days, but not everyone enjoys a stable internet connection! i really hope the man pages are included in 9.04..

Bryce Harrington (bryce) on 2009-07-21
Changed in mesa (Ubuntu):
assignee: nobody → Bryce Harrington (bryceharrington)
Bryce Harrington (bryce) on 2009-08-21
Changed in mesa (Ubuntu):
status: Confirmed → Triaged

This isn't making it into Karmic is it?

Peter Rhone (prhone-gmail) wrote :

If a fix has been committed, can someone please document it here? I don't know what package to install, if any, to get the documentation. For now I have been forced to install the package I found here: http://emergent.unpythonic.net/01157053957

Ruslan (b7-10110111) wrote :

I haven't find any package in the repo.
Here you can find a deb with man pages:
http://emergent.unpythonic.net/01157053957

Maybe at least this package can be added to the repo?..

Bryce Harrington (bryce) on 2010-04-30
Changed in mesa (Ubuntu):
assignee: Bryce Harrington (bryceharrington) → nobody
Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

Hi Yohumbus,

This bug was reported against an earlier version of Ubuntu, can you
test if it still occurs on Lucid?

Please note we also provide technical support for older versions of
Ubuntu, but not in the bug tracker. Instead, to raise the issue through
normal support channels, please see:

    http://www.ubuntu.com/support

If you are the original reporter and can still reproduce the issue on
Lucid, please run the following command to refresh the report:

  apport-collect 32042

If you are not the original reporter, please file a new bug report, so
we can work with you as the original reporter instead (you can reference
bug 32042 in your report if you think it may be related):

  ubuntu-bug xorg

If by chance you can no longer reproduce the issue on Lucid or if you
feel it is no longer relevant, please mark the bug report 'Fix Released'
or 'Invalid' as appropriate, at the following URL:

  https://bugs.launchpad.net/ubuntu/+bug/32042

Changed in mesa (Ubuntu):
status: Triaged → Incomplete
tags: added: needs-retested-on-lucid-by-june

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in mesa (Ubuntu):
status: Incomplete → Invalid
Kjmph (kjmph) wrote :

Come on! This bug still exists in 10.04, it has been over four years! Rather than just closing it so the "process" can look pretty, can't we fix it???

Thank you for taking the time to report this bug and helping to make Ubuntu better. My apologies as I should not have marked this Invalid. The issue that you reported is one that should be reproducible with the live environment of the Desktop CD of the development release - Maverick Meerkat. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find out more about the development release at http://www.ubuntu.com/testing/ . Thanks again and we appreciate your help.

Changed in mesa (Ubuntu):
status: Invalid → Incomplete
Kjmph (kjmph) wrote :

I'm trying it now, but I think everyone agrees, we don't mind if it isn't in the official install, we would just like to be able to install a package that can provide the manpages.

I'll get back to you.

Kjmph (kjmph) wrote :

I just installed the latest development release and apt-get installed mesa-common-dev. I was not able to do a man glBegin. This is still a problem.

scottku (scottku) wrote :

I have mesa-common-dev installed on 10.10 and also still don't see the man pages. This has been an annoyance for years. Thankfully, there are some deb files here that install them:
http://emergent.unpythonic.net/01157053957

tags: added: manpage
removed: needs-retested-on-lucid-by-june
Changed in mesa (Ubuntu):
status: Incomplete → New

> I was not able to do a man glBegin. This is still a problem.

Of course you shouldn't be using functions like glBegin() to begin with. If not already done, the documentation should be also updated to, if not remove references to, at least strongly warn users about using such deprecated functionality.

Bryce Harrington (bryce) wrote :

[Still is an issue; the Debian bug linked to this is not relevant for the current issue.]

(This is low priority, but patches would be welcome.)

Changed in mesa (Ubuntu):
status: New → Triaged
Changed in mesa (Debian):
importance: Unknown → Undecided
status: Fix Released → New
Dylan Smith (dylan-ah-smith) wrote :

The instructions at http://www.opengl.org/wiki/Getting_started/XML_Toolchain_and_Man_Pages specify specify the subversion repository to get the up to date man pages, and the prerequisites (e.g. DTDs) needed to process the xml files. I successfully used docbook2x-man (docbook2x package) to convert all the xml files to man pages. The same could probably be done for an ubuntu package.

Alex Rudnick (alex-rudnick) wrote :

This is still pretty ridiculous. The deb package at http://emergent.unpythonic.net/01157053957 works fine, but who's maintaining the OpenGL packages for Ubuntu? ...

Tom Fogal (tfogal) wrote :

I feel this bug is miscategorized. These man pages should not come from Mesa, for two reasons:

 . not all systems use Mesa; some systems utilize the proprietary drivers, and they should be able to install these manpages as well.
 . Mesa is not the 'upstream' for these manpages, even if they happen to include the documents. The standards development group in this case is Khronos. Khronos provides a method to create these manapges.

Thus I think this should be a new, separate package which is sourced from the Khronos documentation. Their subversion repository is:

  https://cvs.khronos.org/svn/repos/ogl/trunk/ecosystem/public/sdk/docs/man

and their manpages can be generated using 'docbook2x-man -N' on each XML file.

The Khronos documents are (mostly) considered BSD-licensed:

  http://www.opengl.org/wiki/Getting_started/XML_Toolchain_and_Man_Pages#Licenses

I checked this myself, however. They are actually licensed under one of either the SGI Free Software B license, or the Open Publication License:

  $ grep -i license *.xml | cut -d: -f2 | sort | uniq
            Free Software B License. For details, see
            Free Software B License. For details, see
            Silicon Graphics, Inc. This document is licensed under the SGI
            Silicon Graphics, Inc. This document is licensed under the SGI
            the Open Publication License, v 1.0, 8 June 1999.
            the Open Publication License, v 1.0, 8 June 1999.

The former allows basically free use as long as you don't advertise with "SGI" [1]. The latter is considered a viable Free Documentation License [2], [3]
[1] http://oss.sgi.com/projects/FreeB/
[2] http://www.gnu.org/licenses/license-list.html#RealOPL
[3] http://en.wikipedia.org/wiki/Open_Publication_License

So there appears to be no issue in distributing derivative works.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.