Intel graphic card and hedgewars game

Bug #316683 reported by daimadoshi85 on 2009-01-13
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mesa (Ubuntu)
Undecided
Unassigned

Bug Description

We noted a little bug in textures with Ubuntu's Intel graphic card drivers playing the game hedgewars.
Here are the two topics of hedgewars forum that show it.
http://hedgewars.org/node/754
http://hedgewars.org/node/1080
We know that with a different operating system (Windows) the game works fine, so we are thinking that the troubles are in Intel graphic drivers.
I hope you can help us to solve this problem. Thank you.

Bryce Harrington (bryce) wrote :

Hi dragon-fog,

Please attach the output of `lspci -vvnn`, and attach your /var/log/Xorg.0.log file from after reproducing this issue. If you've made any customizations to your /etc/X11/xorg.conf please attach that as well.

Please attach the output of `lspci -vvnn` too.

[This is an automated message. If this script has reached you erroneously, please accept our apologies; any reply to this message will be sufficient to prevent it from doing further automated processing.]

Changed in xorg:
status: New → Incomplete
Cim (cimcim) wrote :

Hi
This is a lspci -vvnn from root, my xorg.conf and Xorg.0.log after the crash in buglog.zip.

Brice Arnould (un-brice) wrote :

Hi !

I think the bugs description is wrong :
 - I don't think the problem is with the video driver because the same happens with a S3 card. I guess the problem is an incompatibility with mesa.
 - The " little problem " makes the games unplayable, because the map is no longer displayed :-(

There is a workaround. It looks like the problem is in the selective redrawing of the map, in uLand.pas :
| procedure UpdateLandTexture(Y, Height: LongInt);

| begin
| glBindTexture(GL_TEXTURE_2D, LandTexture^.id);
| glTexSubImage2D(GL_TEXTURE_2D, 0, 0, Y, 2048, Height, GL_RGBA, GL_UNSIGNED_BYTE, @LandPixels[Y, 0]);
| end
if I hack those lines to make them redraw the whole map every time (by forcing Y=0 and Height=1023), the problem no longer occurs. Maybe it's a bug in the game triggered by the OpenGL implementation ?

I will cross-post this on the game's forum.

Cim (cimcim) wrote :

Already replied that on a game forum.

daimadoshi85 (dragon-fog) wrote :

Sorry but the developer of the game answered to your post, I quote it here:

"This hack will greatly reduce performance. Even on my Core Quad GF6600 it gets about 0.5 sec to update full map texture, and imagine now this action will be performed on each explosion of ballgun or to draw holes by napalm.
Hedgewars uses just about 10 OpenGL functions. It couldn't use them wrong. It should be a bug in drivers"

Cim (cimcim) wrote :

Yes but what now? The solution with redrawing map is really not good for multiple blows.

Brice Arnould (un-brice) wrote :

I cannot reproduce the bug in Jaunty.

Cim (cimcim) wrote :

So is that means we must wait for 9.04 and it will working there. XD But why we must wait so long :/

Brice Arnould (un-brice) wrote :

Changing to fix released because it is fixed in Jaunty. (I hope I'm doing the right thing)

Changed in mesa:
status: Incomplete → Fix Released
Wiz (thewizhard) wrote :

Bug confirmed on archlinux with driver extra/xf86-video-intel 2.4.3-1.
Can someone notice me about which intel gma driver jaunty is using ?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments