Intrepid, on latest updates (mesa updates - 7.1~rc1-0ubuntu1), compiz no longer works and gives white screen on login

Bug #245888 reported by Vikrant on 2008-07-05
134
Affects Status Importance Assigned to Milestone
Mesa
Fix Released
Medium
mesa (Ubuntu)
High
Unassigned
Intrepid
High
Unassigned

Bug Description

After updates on 4-6th July, this includes a kernal upgrade from 2.6.23.2 to 2.6.23.3, I get white screen on loging in. I have to say blinded by Ctrl f2, metacity --replace, which gives me my desktop...

This is an intel 915gm graphics, And I am running intrepid with all latest updates... Booting into older kernel still produces same white screen. I tried reconfiguring xserver (-phigh) with no success.

ProblemType: Bug
Architecture: i386
Date: Sun Jul 6 01:23:34 2008
DistroRelease: Ubuntu 8.10
Uname: Linux 2.6.26-3-generic i686

compiz --replace logs from a terminal:

kx@Kx-VMZ:~$ compiz --replace
Checking for Xgl: not present.
Detected PCI ID for VGA:
Checking for texture_from_pixmap: present.
Checking for non power of two support: present.
Checking for Composite extension: present.
Failed to initialize TTM buffer manager. Falling back to classic.
Comparing resolution (1280x800) to maximum 3D texture size (2048): Passed.
Checking for nVidia: not present.
Checking for FBConfig: Failed to initialize TTM buffer manager. Falling back to classic.
present.
Checking for Xgl: not present.
Failed to initialize TTM buffer manager. Falling back to classic.
failed to create drawable
failed to create drawable
/usr/bin/compiz.real (core) - Warn: No GLXFBConfig for depth 32
/usr/bin/compiz.real (core) - Info: Couldn't bind redirected window 0x1600046 to texture

failed to create drawable
failed to create drawable
failed to create drawable
/usr/bin/compiz.real (core) - Warn: No GLXFBConfig for depth 32
/usr/bin/compiz.real (core) - Warn: No GLXFBConfig for depth 32
/usr/bin/compiz.real (core) - Warn: No GLXFBConfig for depth 32
/usr/bin/compiz.real (video) - Warn: No 8 bit GLX pixmap format, disabling YV12 image format
/usr/bin/compiz.real (core) - Warn: No GLXFBConfig for depth 32
/usr/bin/compiz.real (wall) - Error: Couldn't create cairo context for switcher
/usr/bin/compiz.real (core) - Warn: No GLXFBConfig for depth 32
/usr/bin/compiz.real (wall) - Error: Couldn't create cairo context for switcher
/usr/bin/compiz.real (core) - Warn: No GLXFBConfig for depth 32
/usr/bin/compiz.real (wall) - Error: Couldn't create cairo context for switcher
/usr/bin/compiz.real (core) - Warn: No GLXFBConfig for depth 32
/usr/bin/compiz.real (wall) - Error: Couldn't create cairo context for switcher
^C/usr/bin/compiz.real (core) - Warn: No GLXFBConfig for depth 32
/usr/bin/compiz.real (resizeinfo) - Warn: Bind Pixmap to Texture failure
/usr/bin/compiz.real (core) - Warn: No GLXFBConfig for depth 32
/usr/bin/compiz.real (resizeinfo) - Warn: Bind Pixmap to Texture failure
/usr/bin/compiz.real (core) - Warn: No GLXFBConfig for depth 32
/usr/bin/compiz.real (core) - Info: Couldn't bind redirected window 0x1600046 to texture

Attempted to unregister path (path[0] = org path[1] = freedesktop) which isn't registered
Attempted to unregister path (path[0] = org path[1] = freedesktop) which isn't registered
Attempted to unregister path (path[0] = org path[1] = freedesktop) which isn't registered

Related branches

Hey, if you start compiz in a terminal, you may see "failed to create drawable" messages. If this is the case, you are experiencing the same issue I am, which I described in "CreateDrawable failing with old DRI" on the xorg mailing list. I have been unable to isolate the underlying cause of this and have yet to hear back from Kristian or the list. Superficially, it looked like mesa commit 23635510e3333ea8056311afa741c5e6d7c9ec15 might fix the issue, but no such luck.

(In reply to comment #1)
> Hey, if you start compiz in a terminal, you may see "failed to create drawable"

I can see this message too and the screen is black.

> messages. If this is the case, you are experiencing the same issue I am, which
> I described in "CreateDrawable failing with old DRI" on the xorg mailing list.
> I have been unable to isolate the underlying cause of this and have yet to hear
> back from Kristian or the list. Superficially, it looked like mesa commit
> 23635510e3333ea8056311afa741c5e6d7c9ec15 might fix the issue, but no such luck.
Yes, The commit does not work for me.

Are you using the intel-batchbuffer branch? I seem to recall getting a black screen and similar (but not identical) messages when DRI2 was in use.

(In reply to comment #2)
> (In reply to comment #1)
> > Hey, if you start compiz in a terminal, you may see "failed to create drawable"
>
> I can see this message too and the screen is black.
>
> > messages. If this is the case, you are experiencing the same issue I am, which
> > I described in "CreateDrawable failing with old DRI" on the xorg mailing list.
> > I have been unable to isolate the underlying cause of this and have yet to hear
> > back from Kristian or the list. Superficially, it looked like mesa commit
> > 23635510e3333ea8056311afa741c5e6d7c9ec15 might fix the issue, but no such luck.
> Yes, The commit does not work for me.
>

This message appears in mesa's glx_pbuffer.c and was introduced by Kristian's commit e82dd8c6e1fa2fff5b960de26961080ba5e9651d (DRI interface changes and DRI2 direct rendering support). It appears to be thrown because drawable != req->glxwindow (glx_pbuffer.c:366) when that comparison in driCreateDrawable (dri_glx.c:1088) failed. The comparison is apparently checking for "GLX 1.3+ drawable constructors," which the old DRI can't handle. Unfortunately, the glxwindow and drawable somehow aren't being initialized with similar values, hence the failing check. Hope this saves someone a little work.

Is compiz trying to use direct rendering? That has never worked with the 'old' DRI. Does it work if you set LIBGL_ALWAYS_INDIRECT=1?

You're absolutely right, that was the issue (at least why the screen was white). I had set that in my .bashrc which I recently deleted. Setting LIBGL_ALWAYS_INDIRECT gives a black screen and more or less freezes X (Ctrl+C doesn't kill compiz, switching to a VT and killing locks up the machine, expectedly). More details in an hour when I get out of class and find a machine to remote in from.

I am thoroughly confused. It seems that over indirect rendering compiz runs fine but fails to map any windows (they are black). Strangely, it gives no errors, however. The cube plugin works as expected (end-caps, background and all) so it seems the issue is probably in texture-from-pixmap or the related machinery. I'm honestly at a loss as to how to approach this problem.

As I said before, compiz produces nothing evenly slightly resembling an error. After initializing, gdb verified that compiz is sitting in its event loop which is further supported by the fact that compiz behaves as it should, albeit with a black desktop. I have no problem looking into this problem deeper, but I need some input as to where the bug could be occurring or how to localize it further. Any ideas?

(In reply to comment #5)
> Is compiz trying to use direct rendering? That has never worked with the 'old'
> DRI. Does it work if you set LIBGL_ALWAYS_INDIRECT=1?

I set LIBGL_ALWAYS_INDIRECT=1, then startx, desktop is up and display is correct, but the windows has no window manager(no title bar, no border), although the compiz is running:

root@nian-dev:~# ps -ef |grep compiz
root 6303 6241 0 09:42 pts/0 00:00:00 /usr/bin/compiz --sm-client-id default0
root 6455 6205 0 09:43 pts/0 00:00:00 grep compiz

I use the master branch of xf86-video-intel.

(In reply to comment #7)
> It seems that over indirect rendering compiz runs fine

So, I suspect that GLX_EXT_texture_from_pixmap is incorrectly being advertised with DRI1.

> but fails to map any windows (they are black).

Is AIGLX fully initialized?

(In reply to comment #8)
> I set LIBGL_ALWAYS_INDIRECT=1, then startx, desktop is up and display is
> correct, but the windows has no window manager(no title bar, no border),
> although the compiz is running:

You probably aren't loading the decoration plugin and/or a decoration manager.

Created an attachment (id=15926)
X log from non-working configuration

I

(In reply to comment #9)
> (In reply to comment #7)
> > It seems that over indirect rendering compiz runs fine
>
> So, I suspect that GLX_EXT_texture_from_pixmap is incorrectly being advertised
> with DRI1.

Interesting. glxinfo lists it,
server glx extensions:
    GLX_ARB_multisample, GLX_EXT_import_context, GLX_EXT_texture_from_pixmap,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_copy_sub_buffer,

Perhaps this is one of the issues.

>
> > but fails to map any windows (they are black).
>
> Is AIGLX fully initialized?
>
I just attached a log. Quote:

(II) AIGLX: Screen 0 is not DRI2 capable
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 10, (OK)
drmOpenByBusid: Searching for BusID pci:0000:00:02.0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 10, (OK)
drmOpenByBusid: drmOpenMinor returns 10
drmOpenByBusid: drmGetBusid reports pci:0000:00:02.0
(II) AIGLX: enabled GLX_MESA_copy_sub_buffer
(II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
(II) AIGLX: enabled GLX_texture_from_pixmap with driver support
(II) AIGLX: Loaded and initialized /usr/lib/dri/i965_dri.so

Am I correct in assuming that is AIGLX not supposed to be enabling texture_from_pixmap?

> (In reply to comment #8)
> > I set LIBGL_ALWAYS_INDIRECT=1, then startx, desktop is up and display is
> > correct, but the windows has no window manager(no title bar, no border),
> > although the compiz is running:
>
> You probably aren't loading the decoration plugin and/or a decoration manager.
>

(In reply to comment #11)
> > So, I suspect that GLX_EXT_texture_from_pixmap is incorrectly being advertised
> > with DRI1.
>
> Interesting. glxinfo lists it,
> server glx extensions:
> GLX_ARB_multisample, GLX_EXT_import_context, GLX_EXT_texture_from_pixmap,

It's expected to be listed in the server and client extensions. What matters is the 'GLX extensions:' string.

> (II) AIGLX: enabled GLX_texture_from_pixmap with driver support
> (II) AIGLX: Loaded and initialized /usr/lib/dri/i965_dri.so
>
> Am I correct in assuming that is AIGLX not supposed to be enabling
> texture_from_pixmap?

No, it's supported with indirect rendering.

Created an attachment (id=15927)
glxinfo output

(In reply to comment #12)
> It's expected to be listed in the server and client extensions. What matters is
> the 'GLX extensions:' string.
Just attached the output of glxinfo and it appears to be listed in the GLX extensions string as well. Interesting.
>
> No, it's supported with indirect rendering.
>
Alright.

That log looks good to me, at least my one looks pretty similar. And at the moment I do not expect that behaviour.

(In reply to comment #15)
> That log looks good to me, at least my one looks pretty similar. And at the
> moment I do not expect that behaviour.
>

Well, this is most unfortunate. Kristian, any suggestions as how to approach isolating this issue? Do you know of any likely failure points that wouldn't throw an error?

It seems as though the only issue here was that indirect rendering wasn't being used. Marking NOTABUG. There is another bug concerning actual breakage of texture_from_pixmap (which was the problem I was referring to) at #14441.

GLX_EXT_texture_from_pixmap being advertised without LIBGL_ALWAYS_INDIRECT=1 with DRI1 is definitely a bug and a regression.

Oh, uhhhh, ooops. Really sorry about that, I apparently am talking out of my a**. My bad.

*** Bug 16444 has been marked as a duplicate of this bug. ***

Still a bug with mesa master. Ubuntu Intrepid will soon be updated to the latest packages, so hopefully this bug gets some attention.

After updates on 5-6th July, this includes a kernal upgrade from 2.6.23.2 to 2.6.23.3, I get white screen on loging in. I have to say blinded by Ctrl f2, metacity --replace, which gives me my desktop...

This is an intel 915gm graphics, And I am running intrepid with all latest updates...

ProblemType: Bug
Architecture: i386
Date: Sun Jul 6 01:23:34 2008
DistroRelease: Ubuntu 8.10
Package: firefox-3.0 3.0+nobinonly-0ubuntu3~fta6
PackageArchitecture: i386
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_IN
 SHELL=/bin/bash
SourcePackage: firefox-3.0
Uname: Linux 2.6.26-3-generic i686
UnreportableReason: This is not a genuine Ubuntu package

Vikrant (vikrant82) on 2008-07-05
description: updated
Vikrant (vikrant82) on 2008-07-05
description: updated
Vikrant (vikrant82) on 2008-07-05
description: updated

I think following updates are the culprits....

libgl1-mesa-dri (7.0.3-3ubuntu1) to 7.1~rc1-0ubuntu1
libgl1-mesa-glx (7.0.3-3ubuntu1) to 7.1~rc1-0ubuntu1
libglu1-mesa (7.0.3-3ubuntu1) to 7.1~rc1-0ubuntu1
mesa-utils (7.0.3-3ubuntu1) to 7.1~rc1-0ubuntu1

I will try to roll back the updates and see if things start to work again....

Vikrant (vikrant82) on 2008-07-06
description: updated

It was them,

I downgraded the packages to _7.0.3~rc2-1ubuntu3_, doing which compiz starts to work again.

libgl1-mesa-dri (7.1~rc1-0ubuntu1) to 7.0.3~rc2-1ubuntu3_i386
libgl1-mesa-glx (7.1~rc1-0ubuntu1) to 7.0.3~rc2-1ubuntu3_i386
libglu1-mesa ( 7.1~rc1-0ubuntu1) to 7.0.3~rc2-1ubuntu3_i386
mesa-utils ( 7.1~rc1-0ubuntu1) to 7.0.3~rc2-1ubuntu3_i386

Hence, the problem lies with mesa packages, "7.1~rc1-0ubuntu1".
Lets wait for a newer version, and hope that fixes the fragile situation :) I have locked the version for now.

Stas Verberkt (legolas) wrote :

With the latest version of these packages my KDE does start but the screen is black, I can see the shadows / background-outlines of windows opened. Disabling composite or downgrading these packages fixes the problem.

syscon-hh (syscon-kono) wrote :

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.10
DISTRIB_CODENAME=intrepid
DISTRIB_DESCRIPTION="Ubuntu intrepid (development branch)"
Architecture: i386
Uname: Linux 2.6.26-3-generic i686
ATI-Radeon 9200

I can confirm these circumstances.

Downgrading these four (4) packages solves the problems vs. respectively.

With these "white-screen" I'm able to rotate my cube by Strg + Alt + left mouse pointer and than the background behind the cube is visible or in other words, the Desktop(s) itself aren't displayed.

Lukas Hejtmanek (xhejtman) wrote :

glxgears are broken as well:

$ glxgears
Error: couldn't get an RGB, Double-buffered visual

Changed in mesa:
status: New → Confirmed
syscon-hh (syscon-kono) wrote :

The new generation of above packages ( now 7.1~rc1-0ubuntu2 ) didn't solve anything.

Lukas Hejtmanek (xhejtman) wrote :

the new xserver-xorg-core (1.4.99) fixes the problem. another problem is that glxgears droped from 1000FPS to 650FPS.

Vikrant (vikrant82) wrote :

With all latest updates, (xserver-core), I am getting GDM crash, with a cute message that says, "Greeter application appears to be crashing. ...." and keeps crashing and keeps crashing...

Any insights here how to resolve this, They were lot of updates, rolling back all of them, wouldn't be a great idea...

Vikrant (vikrant82) wrote :

I somehow got in by enabling, automatic login through shell. This is my gdm.conf.

On compiz front, it is falling again ...

kx@Kx-VMZ:~$ compiz --replace
Checking for Xgl: not present.
No whitelisted driver found
aborting and using fallback: /usr/bin/metacity

glxgears fps is 100 down from 800.

Bryce Harrington (bryce) wrote :

Please attach your /var/log/Xorg.0.log files.

Also note that there is a known issue causing compiz to fail currently on -intel 965 (at least), which are already known upstream and will be solved in time.

Changed in mesa:
status: Confirmed → Incomplete
Vikrant (vikrant82) wrote :

Just now there were two updates:

xserver-xorg-video-intel (2:2.3.2-2ubuntu2)
xserver-xorg-video-i810 (2:2.3.2-2ubuntu2)

which settled up pretty much everything but compiz :)

glxgears is happily back to 800s,
compiz is back to white screen.

gdm greeting application is also greeting happily now :)

However rolling back those four mesa updates pretty much breaks everything now. So no compiz for now.

I am on intel 915, so that's affected as well.

oh (oystein-homelien) wrote :

I'm seeing the same horrendous problems as Vikrand; I updated my intrepid ~30 mins ago and sudddenly X stopped working - I get the greeter application crashing message, and I can't log in.

As suggested by Vikras I can sneak myself in by setting AutomaticLogin in gdm.conf. However, this uses the failsafe X server so is dead slow, and additionally gnome-panel will not start, so my desktop is quite unusable.

I will try to upload my xorg.log of the failing session, but last I tried firefox crashes when my desktop is in this state.

Some perhaps-helpful information:

* BACKTRACE FROM XORG.0.LOG FILE:
(II) intel(0): Setting screen physical size to 246 x 184

Backtrace:
0: X(xf86SigHandler+0x65) [0x47ff25]
1: /lib/libc.so.6 [0x7f1bf11ef120]
2: /usr/lib/xorg/modules//libfb.so(fbSolid+0x290) [0x7f1beed60540]
3: /usr/lib/xorg/modules//libfb.so(fbFill+0x4cc) [0x7f1beed58dbc]
4: /usr/lib/xorg/modules//libfb.so(fbPolyFillRect+0x1c6) [0x7f1beed58fd6]
5: /usr/lib/xorg/modules//libexa.so(ExaCheckPolyFillRect+0x44) [0x7f1beeb41e94]
6: /usr/lib/xorg/modules//libexa.so [0x7f1beeb3d584]
7: X [0x52d5f6]
8: X(CreateDefaultStipple+0xf3) [0x45bf73]
9: X(main+0x305) [0x432de5]
10: /lib/libc.so.6(__libc_start_main+0xe6) [0x7f1bf11da466]
11: X(FontFileCompleteXLFD+0x289) [0x432319]

NOTICE the screen size stuff.

* SEGFAULT FROM GNOME-PANEL STARTED UNDER GDB:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7f1b3675d780 (LWP 23939)]
0x000000000045e96e in panel_multiscreen_width ()

* MESSAGE FROM FIREFOX APPEARING ON MY CONSOLE:
              (firefox:23288): Gdk-CRITICAL **: get_monitor: assertion `monitor_num < screen_x11->n_monitors' failed

.. all in all I suspect this might be xrandr-related?

Hope this can be fixed asap or anyone can find a proper workaround, perhaps the above info helps. PS: I also tried setting "INTEL_BATCH=0" in my environment, and I also commented out the modules in xorg.conf - to no avail.

Is there a repo called intrepid-proposed, or should I just wait for the fixes to appear in intrepid-updates?

Hope this is helpful,
oystein

oh (oystein-homelien) wrote :

Vikrant, what repo did you get the -ubuntu2 packages for video-intel/i810? I use a local mirror and changed to these lines for -updates:

deb http://security.ubuntu.com/ubuntu/ intrepid-updates universe main multiverse restricted
deb-src http://security.ubuntu.com/ubuntu/ intrepid-updates universe main multiverse restricted

but I still don't get the updates you mention.

Changed in mesa:
status: Unknown → Confirmed
Vikrant (vikrant82) wrote :

Hi,

I am using india servers,

deb http://in.archive.ubuntu.com/ubuntu/ intrepid-updates main restricted universe multiverse
deb-src http://in.archive.ubuntu.com/ubuntu/ intrepid-updates restricted main multiverse universe

oh (oystein-homelien) wrote :

I confirm that the packages mentioned fix the problem for me. I can now log in as usual and all is nice (except accelerated 3D, but it did not work before this anyways).

I changed from my local mirror server in sources.list to ftp.ubuntu.com - it had the packages.

Vikrant (vikrant82) wrote :

Also I have pretty much everything enabled in repositories, intrepid-security, intrepid-backports, intrepid-proposed and intrepid-updates

That would be,

deb http://in.archive.ubuntu.com/ubuntu/ intrepid-security main restricted universe multiverse
deb-src http://in.archive.ubuntu.com/ubuntu/ intrepid-security restricted main multiverse universe

deb http://in.archive.ubuntu.com/ubuntu/ intrepid-proposed restricted main multiverse universe
deb-src http://in.archive.ubuntu.com/ubuntu/ intrepid-proposed restricted main multiverse universe

deb http://in.archive.ubuntu.com/ubuntu/ intrepid-backports main restricted universe multiverse
deb-src http://in.archive.ubuntu.com/ubuntu/ intrepid-backports main restricted universe multiverse

deb http://in.archive.ubuntu.com/ubuntu/ intrepid main restricted universe multiverse
deb-src http://in.archive.ubuntu.com/ubuntu/ intrepid restricted main multiverse universe

Did you get those updates? Or I can attach those debs here ?

(In reply to comment #21)
> Still a bug with mesa master. Ubuntu Intrepid will soon be updated to the
> latest packages, so hopefully this bug gets some attention.

Now updated. People are seeing white (this bug), corruption (bug 14441) and black (bug 14441 for advanced users who have additionally self-compiled TTM support).

Created an attachment (id=17597)
proposed patch.. please test this.

Created an attachment (id=17600)
alternate patch fixing this from the other side

I'll let krh pick which one is more correct.

At least the first patch works, thanks!

(In reply to comment #23)
> Created an attachment (id=17597) [details]
> proposed patch.. please test this.

Yeah, this one cool - in fact, I think we should apply both, they both make sense.

Saku Ytti (ubuntu-ip) wrote :

Running 945GM/GMS/GME, 943/940GML (as per lspci) here and after latest upgrade (2:2.3.2-2ubuntu2) I lost higher (including native 1400x) resolutions. 915resolution package (which hacks the BIOS so that higher resolutions can work) conflicts with the new 810 driver, with good reason, since if I run it, X doesn't start at all.

Saku Ytti (ubuntu-ip) wrote :

Rebooting with 915resolution (--force-conflicts) installed and I got my native resolution back. Compiz doesn't work (I get the white screen),
but that's not important to me, native resolution is, as bitmapped fonts look like crap without it (TT/AA fonts look ok, but thats because they
look crap normally:).
I'm pretty sure xserver-xorg-video-intel should not conflict with 915resolution, as evidently it makes no attempt to patch BIOS.

Timo Aaltonen (tjaalton) wrote :

upstream has a fix, but it's not enough to get compiz working (see upstream bug 14441).

Changed in mesa:
importance: Undecided → High
status: Incomplete → In Progress

I've pushed the second fix to glx/dri code.

Changed in mesa:
status: Confirmed → Fix Released
savantelite (savantelite) wrote :

I have this problem too, I have been loading into fail safe mode session just to use the coputer.

RobotII (pete-arthur) wrote :

I am experiencing this too on Intel GM965 using the -intel driver. My desktop is workable by disabling compiz effects, but as I use a number of the accessibility features in compiz, I am hampered from working effectively by this bug.

Any chance of a fix coming before the release of intrepid? This is an honest question btw, not a sarcastic comment.

LinkinXp (linkinxp) wrote :

Sorry for a noob question here in such important place. how I downgrade a package??

Thanks in advanced

And who is working in this bug?

:-D

ASULutzy (ryan-lutz) wrote :

Have the same problem, is a fix in the works? What's the easiest way to go about downgrading to the older packages?

Jeremy Bicha (jbicha) wrote :

In Synaptic, you can downgrade by selecting a package and hitting CTRL+E or Package>Force Version in the menu. However, when I tried downgrading the packages, I couldn't get X working at all. In fact, this problem is mentioned by Vikrant and Suku previously. In other words, don't downgrade the mesa packages because it could break your configuration worse (until you re-upgrade mesa)!

Thanks, we've confirmed and pulled this fix into Ubuntu.

Mariano Stokle (mstokle) wrote :

I confirm this same problem in a HP Compaq nc6400 with Intel 945GM graphics chipset.

Vikrant (vikrant82) wrote :

With latest updates, 7.1~rc3-1ubuntu1, version of mesa packages came, which fixed the compiz issue on Intel 915GM. Glad to have compiz working again. :)

LinkinXp (linkinxp) wrote :

It still happens the same with me I type in console Compiz and i get a black screen with green red dots but mostly black :(

ASULutzy (ryan-lutz) wrote :

The last updates did not fix the problem for me. Now instead of going all white I get a black screen with sparse red and green dots.

ASULutzy (ryan-lutz) wrote :

Here's the output of compiz --replace. Will attach useful logs as well.

ryan@intrepid:~$ compiz --replace
Checking for Xgl: not present.
Detected PCI ID for VGA:
Checking for texture_from_pixmap: not present.
Trying again with indirect rendering:
Checking for texture_from_pixmap: present.
Checking for non power of two support: present.
Checking for Composite extension: present.
Comparing resolution (1280x800) to maximum 3D texture size (2048): Passed.
Checking for nVidia: not present.
Checking for FBConfig: present.
Checking for Xgl: not present.
/usr/bin/compiz.real (video) - Warn: No 8 bit GLX pixmap format, disabling YV12 image format
^CAttempted to unregister path (path[0] = org path[1] = freedesktop) which isn't registered
Attempted to unregister path (path[0] = org path[1] = freedesktop) which isn't registered
Attempted to unregister path (path[0] = org path[1] = freedesktop) which isn't registered

ASULutzy (ryan-lutz) wrote :
ASULutzy (ryan-lutz) wrote :

Sorry for the triple post, my windowing system is hosed up from running compiz --replace

LinkinXp (linkinxp) wrote :

Yes I am getting the same output as ASULutzy

savantelite (savantelite) wrote :

last update seemed to fix my problem

Jeremy Bicha (jbicha) wrote :

I agree that the rc3-1ubuntu1 update fixed the issue for me: Intel 915GM 32 bit Ubuntu .

Nicolò Chieffo (yelo3) wrote :

for 965 this is not fixed

LinkinXp (linkinxp) wrote :

I have an Dell 1525 and it is not fixed with a Intel 965.

Mariano Stokle (mstokle) wrote :

The latests upgrades did the trick for me (HP Compaq nc6400 with Intel 945GM graphics). The only thing I have to do is to start the computer using the recovery mode, choose fix the x server and then started OK. It started without compiz enabled, but when I enabled it everything worked fine.

LinkinXp (linkinxp) wrote :

I will try it tonight I'm at work now, but I think I did that cause it was BLACK with a lot of weird colors , but anyway thanks for the hint I'll check.

ASULutzy (ryan-lutz) wrote :

Even after the most recent updates (not the ones from last night, but from today) the same problem is still present on 965. compiz --replace makes the screen go black with a few sparse pixels of other colors. I tried restarting in recovery and choosing fix x server, but that didn't fix the problem (I didn't really expect it to.)

ASULutzy (ryan-lutz) wrote :

Specifically my card as reported by lspci is: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)

But maybe we should open another bug, because this bug is about a
screen that becomes white, and not black and garbled as in our case...

ASULutzy (ryan-lutz) wrote :

Has another bug been opened, or are we sticking with this one?
I'd think the two half to be related?

ASULutzy (ryan-lutz) wrote :

have to be related*

Mathieu Pellerin (nirvn-asia) wrote :

The black corrupted screen has been identified by the mesa team; you can follow status of bug at https://bugs.freedesktop.org/show_bug.cgi?id=14441 .

Omid Mottaghi (omidmottaghi) wrote :

Compiz is not working here with latest intrepid upgrades too.
I have intel driver + mesa 7.1~rc3 + compiz 0.7.7

the compiz --replace output is:

Checking for Xgl: not present.
Detected PCI ID for VGA:
Checking for texture_from_pixmap: not present.
Trying again with indirect rendering:
Checking for texture_from_pixmap: present.
Checking for non power of two support: present.
Checking for Composite extension: present.
Comparing resolution (1280x800) to maximum 3D texture size (2048): Passed.
Checking for nVidia: not present.
Checking for FBConfig: present.
Checking for Xgl: not present.
/usr/bin/compiz.real (core) - Error: Could not acquire compositing manager selection on screen 0 display ":0.0"
/usr/bin/compiz.real (core) - Fatal: No manageable screens found on display :0.0

Chris Halse Rogers (raof) wrote :

@Omid Mottaghi:
Your issue is different, and I'd guess you have Metacity's compositor enabled. My understanding is that Metacity fails to properly release it's hold on Composite when being replaced; thus, Compiz can't gain the composite manager selection, and cannot continue.

Simply disabling Metacity's composite manager should allow you to get Compiz working (or, at least, allow you to hit real bugs in Compiz/mesa/X :))

Omid Mottaghi (omidmottaghi) wrote :

Thanks Chris, you are right :) it was fixed :)

LinkinXp (linkinxp) wrote :

On Sun, Jul 20, 2008 at 9:30 PM, Chris Halse Rogers
<email address hidden> wrote:
> @Omid Mottaghi:
> Your issue is different, and I'd guess you have Metacity's compositor enabled. My understanding is that Metacity fails to properly release it's hold on Composite when being replaced; thus, Compiz can't gain the composite manager selection, and cannot continue.
>
> Simply disabling Metacity's composite manager should allow you to get
> Compiz working (or, at least, allow you to hit real bugs in
> Compiz/mesa/X :))

Hello and sorry for email you to your personal email, but I was
wondering how you disable metacity? and enable Compiz because I have a
Dell Inspiron 1525 with a Intel 965 and it doesn't work.

Thanks in advanced

LinkinXP

Mariano Stokle (mstokle) wrote :

I guess you have to write compiz --replace in a console. I am not sure
how to do this change permanently.

Regards,

On 7/21/08, LinkinXp <email address hidden> wrote:
> On Sun, Jul 20, 2008 at 9:30 PM, Chris Halse Rogers
> <email address hidden> wrote:
>> @Omid Mottaghi:
>> Your issue is different, and I'd guess you have Metacity's compositor
>> enabled. My understanding is that Metacity fails to properly release it's
>> hold on Composite when being replaced; thus, Compiz can't gain the
>> composite manager selection, and cannot continue.
>>
>> Simply disabling Metacity's composite manager should allow you to get
>> Compiz working (or, at least, allow you to hit real bugs in
>> Compiz/mesa/X :))
>
>
> Hello and sorry for email you to your personal email, but I was
> wondering how you disable metacity? and enable Compiz because I have a
> Dell Inspiron 1525 with a Intel 965 and it doesn't work.
>
>
> Thanks in advanced
>
> LinkinXP
>
> --
> Intrepid, on latest updates (mesa updates - 7.1~rc1-0ubuntu1), compiz no
> longer works and gives white screen on login
> https://bugs.launchpad.net/bugs/245888
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Sent from Gmail for mobile | mobile.google.com

Mariano Stokle

LinkinXp (linkinxp) wrote :

That does not work I get the same screen Black with Colors.

Thanks in advanced

*** Bug 16821 has been marked as a duplicate of this bug. ***

Kaktuspalme (martin-buerge) wrote :

I builded a new i965_dri.so from the mesa git tree.

Now it works with compiz.

It seems they have integrated some patches.
http://gitweb.freedesktop.org/?p=mesa/mesa.git;a=summary

Sorry for my bad english.

Kaktuspalme (martin-buerge) wrote :

Hello, my connection is too slow to upload and i go to a location where i unfortunately have no internet connection.
I've got x86_64. I'm sure the developers will shortly release an updated mesa(no warranty, i'm no developer)

But if you like you can build your own. Unfortunately i've no time to describe how to compile it.

I'm shure my .so has a bad quality, my .so file size is very large when i compare it with the file from ubuntu.

Maybe i can write how to do it tomorrow when i'm back. ;)

Sorry

Robert McMeekin (rrm3) wrote :

I am no longer having a problem with the latest updates, is it fixed for anyone else?

Tom Jaeger (thjaeger) wrote :

I can confirm that the attached patch, which is the patch from bugzilla with some minor adjustments package, fixes the black screen problem.

Tom Jaeger (thjaeger) wrote :

An updated libgl1-mesa-dri can be created as follows:

sudo apt-get build-dep libgl1-mesa-dri
apt-get source libgl1-mesa-dri
cd mesa<TAB>
patch -p1 < /path/to/test3.patch
dpkg-buildpackage -us -uc -j2

I've just attached the i965_dri.so file since the resulting package is rather large.

For me, the problem has been solved (especially the one described in duplicate #247974).

@ Andreas Schildbach

For me also... now it's all right! No more blank - and after black - screen... ;)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mesa - 7.1~rc3-1ubuntu2

---------------
mesa (7.1~rc3-1ubuntu2) intrepid; urgency=low

  * 102_fix-fdo-14441.diff: fix tfp on i965. (LP: #245888)

 -- Timo Aaltonen <email address hidden> Fri, 01 Aug 2008 16:08:01 +0300

Changed in mesa:
status: In Progress → Fix Released
Andreas Gustafsson (olangu) wrote :

The bug still exist when logging in with a second user. (Both users using compiz)

dj3 (dim-jakobi) wrote :

+1 on Ubuntu 8.10 Alpha 4

(Desktop CD, downloaded on 14.08.2008):

Compiz white screen of death after login.

I have Radeon HD2400 on nForce5.

hardhu (qzerty) wrote :

After today upgrade in intrepid, kde 4.1 desktop with composite effects enabled was not working (black screen); downgrading libgl1-mesa-glx , libgl1-mesa-dri and libglu1-mesa to older versions (~rc3-1ubuntu4) fixed the problem.

Olivier Cortès (olive) wrote :

Here on up-to-date Intrepid, Intel X4500MHD (on a Sony Vaio BZ11XN), everything works fine again.
Yesterday I encountered the bug and compiz stopped working, launched metacity automatically.
Everytime I wanted to run compiz, it complained :

/usr/bin/compiz.real (core) - Fatal: Root visual is not a GL visual
/usr/bin/compiz.real (core) - Error: Failed to manage screen: 0
/usr/bin/compiz.real (core) - Fatal: No manageable screens found on display :0.0

Searching through launchpad I came across the present page.
I disabled metacity compositor and compiz is back and working fine.

Alberto (elba) wrote :

I am afraid the fix does not work for all the machines. Before writing this, I posted a question, and MarcoBra eventually advised me to fill a new bug report or to post here -- I think a new bug report would not be appropriate.
see: https://answers.launchpad.net/ubuntu/+question/45103
Problem: on several occasions (e.g. if I type "glxinfo | grep direct"), I get the error message (or warning):
"Failed to initialize TTM buffer manager. Falling back to classic."
I never got it under Hardy. "Compiz.real" outputs several error messages and leaves the screen "stuck" -- I mean, the windows become unresponsive, and I get back only by choosing an option from System/Preferences/Appearance/Visual effects. Btw, no radio button is selected by default in that menu.
I have Intrepid alpha5, updated, upgraded and distro-upgraded on Sat Sep 13.
Details from lshw -C display, lspci and xconf.org are attached to question #45103.
Briefly, my gr. card is Intel 943GML.
The interesting thing is that I installed Fedora 9. As soon as the install was done, I type "glxinfo" in a Terminal and got the error "Failed to initialize TTM buffer manager. Falling back to classic." But I did a complete update and upgrade (which took several hours): after that, the error message _disappeared_.
[Fedora 9] uname -r
2.6.25.14-108.fc9.i686.
Therefore, I guess there is a real issue that has still to be solved in Intrepid.
One more detail that might be of some help for a (possible) debug. My display card is marked as "unclaimed". If I try to install a driver (via gksu displayconfig etc.) the only available driver is the i810 (which gives a lot of trouble: I ended by resetting the xorg.conf and keeping the unclaimed display). Fedora suggests another driver by default: that is, an "experimental driver for Intel integrated chipsets", which is explicitly tailored for the 943GML (as well as for other Intel integrated cards). My guess is that this driver, or a similar one, would improve the hardware compatibility between Intrepid and machines mounting the 943GML.
This might be a nice case of cooperation between distros :-)

Id2ndR (id2ndr) wrote :

For those who still have a bug, it should be a different one that the bug fixed here. You can maybe subscribe to bug #262529.

Changed in mesa:
importance: Unknown → Medium
Changed in mesa:
importance: Medium → Unknown
Changed in mesa:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.