Graphical glitches with Mesa 21.0.3 on AMD Radeon RX 5600 XT

Bug #1934783 reported by Mateusz Stachowski
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mesa (Ubuntu)
Undecided
Unassigned
Focal
Undecided
Timo Aaltonen
Hirsute
Undecided
Unassigned

Bug Description

[Impact]
The new upstream version 21.0.3 has a regression on radeonsi (amdgpu), which shows as graphical corruption on the desktop apps with certain hardware.

The fix is to add a commit from upstream staging/21.0 -branch, which never got released as 21.0.4.

[Test case]
Install the update, use desktop apps, see that it works correctly now.

[Where things could go wrong]
The fix adds a single line for an earlier commit that was incomplete. In theory it might regress some other amd hw, but this is highly unlikely.

--

Since the update to Mesa 21.0.3 I have graphical glitches in desktop: Unity, Gnome Shell both sessions (X.org and Wayland).

Also most of the programs have glitches. However Firefox seems unaffected.

CPU:
  Info: 6-Core AMD Ryzen 5 3600 [MT MCP] speed: 3916 MHz
  min/max: 2200/3600 MHz
Graphics:
  Device-1: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT]
  driver: amdgpu v: kernel
  Display: x11 server: X.Org 1.20.11 driver: loaded: amdgpu,ati
  unloaded: fbdev,modesetting,radeon,vesa resolution: 1920x1080~60Hz
  OpenGL: renderer: AMD Radeon RX 5600 XT (NAVI10 DRM 3.35.0
  5.4.0-79-generic LLVM 12.0.0)
  v: 4.6 Mesa 21.0.3

Revision history for this message
Mateusz Stachowski (stachowski-mateusz) wrote :
Revision history for this message
Timo Aaltonen (tjaalton) wrote :

please give the latest focal live image a go:

http://cdimages.ubuntu.com/focal/daily-live/current/

since impish live image worked fine according to bug 1925320, I'm hoping this one is fine too

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

hmm so it was impish which was fine, test hirsute too :)

Revision history for this message
Mateusz Stachowski (stachowski-mateusz) wrote :

I've checked the latest focal live image and it has the exact same glitches as my install.

Revision history for this message
Mateusz Stachowski (stachowski-mateusz) wrote :

Hirsute live image works without problems.

That has mesa versioned as 21.0.1. So it looks like the problem is in 21.0.3

Revision history for this message
Mateusz Stachowski (stachowski-mateusz) wrote :

I've found that other people with RX 5600 XT had problems with this version of mesa.

https://bugs.archlinux.org/task/70554

https://gitlab.freedesktop.org/mesa/mesa/-/issues/4691

There is a new release of mesa (21.0.3-2) that fixes the problem for those users.

Hope that you upload it to focal-proposed.

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

yes that looks to be the one.. I've pushed the fix for hirsute here:

https://launchpad.net/~canonical-x/+archive/ubuntu/x-staging

please test, and I'll backport it to focal too

Revision history for this message
Mateusz Stachowski (stachowski-mateusz) wrote :

But I didn't had problems with hirsute LiveCD.

And my install is focal.

I've tried the ppa with release changed to hirsute but focal can't be upgraded due to conflicts.

Revision history for this message
Mateusz Stachowski (stachowski-mateusz) wrote (last edit ):

I used the hirsute LiveCD again and it has mesa 21.0.1.

I refreshed apt but there wasn't any update of mesa. So I enabled hirsute-proposed and upgraded mesa to 21.0.3.

Then I logged out and straight away there were glitches on the login screen. I've logged in and confirmed that Gnome Shell and programs now also have graphical glitches.

Then I used the ppa and it solved the problem. So I confirm that the fix works.

Timo Aaltonen (tjaalton)
description: updated
Changed in mesa (Ubuntu Focal):
assignee: nobody → Timo Aaltonen (tjaalton)
status: New → In Progress
Changed in mesa (Ubuntu):
status: New → Fix Released
Revision history for this message
Łukasz Zemczak (sil2100) wrote : Please test proposed package

Hello Mateusz, or anyone else affected,

Accepted mesa into hirsute-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mesa/21.0.3-0ubuntu0.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-hirsute to verification-done-hirsute. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-hirsute. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in mesa (Ubuntu Hirsute):
status: New → Fix Committed
tags: added: verification-needed verification-needed-hirsute
Revision history for this message
Łukasz Zemczak (sil2100) wrote :

Hello Mateusz, or anyone else affected,

Accepted mesa into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mesa/21.0.3-0ubuntu0.2~20.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in mesa (Ubuntu Focal):
status: In Progress → Fix Committed
tags: added: verification-needed-focal
tags: added: verification-done-focal
removed: verification-needed-focal
tags: added: verification-done-hirsute
removed: verification-needed-hirsute
Mathew Hodson (mhodson)
tags: removed: verification-needed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mesa - 21.0.3-0ubuntu0.2

---------------
mesa (21.0.3-0ubuntu0.2) hirsute; urgency=medium

  * amd-add-missing-line-from-backport.diff: Fix a regression with
    radeonsi caused by a bad backport. (LP: #1934783)

mesa (21.0.3-0ubuntu0.1) hirsute; urgency=medium

  * New upstream release. (LP: #1925434)
    - drisw-move-zink-down.diff dropped, upstream
  * Migrate to llvm-12. (LP: #1932311)
  * iris-avoid-abort-if-enomem.diff: Don't abort when out of memory.
    (LP: #1918855)

 -- Timo Aaltonen <email address hidden> Mon, 19 Jul 2021 22:26:12 +0300

Changed in mesa (Ubuntu Hirsute):
status: Fix Committed → Fix Released
Revision history for this message
Łukasz Zemczak (sil2100) wrote : Update Released

The verification of the Stable Release Update for mesa has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mesa - 21.0.3-0ubuntu0.2~20.04.1

---------------
mesa (21.0.3-0ubuntu0.2~20.04.1) focal; urgency=medium

  * Backport to focal. (LP: #1925320)
  * control, rules: Use gcc10 on ppc64el to fix the build.

mesa (21.0.3-0ubuntu0.2) hirsute; urgency=medium

  * amd-add-missing-line-from-backport.diff: Fix a regression with
    radeonsi caused by a bad backport. (LP: #1934783)

 -- Timo Aaltonen <email address hidden> Tue, 25 May 2021 09:51:53 +0300

Changed in mesa (Ubuntu Focal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.