Xorg crashed with SIGABRT when under memory pressure

Bug #1918855 reported by Kai-Chuan Hsieh
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OEM Priority Project
Critical
jeremyszu
mesa (Ubuntu)
Medium
Timo Aaltonen
Focal
Medium
Timo Aaltonen
Hirsute
Medium
Timo Aaltonen

Bug Description

== SRU Justification ==
[Impact]
When the system is under memory pressure, the entire desktop session may crash.

[Fix]
Commit f9d8d9acbb6a620684fb4dac4affe25816587d92 ("iris: Avoid abort() if kernel can't allocate memory")

[Test]
Run memory stress and the session crashed in less than 5 minutes.
With the fix applied, run memory stress for 24 hours and the desktop session is still alive.

[Where problems could occur]
Doing a reset might make the system even more sluggish when under memory pressure.

== Original bug report ==
I run checkbox job com.canonical.certification::memory/memory_stress_ng on focal, and the xserver stops unexpectedly with the following stacktrace:

/usr/lib/gdm3/gdm-x-session[1425]: (EE) 0: /usr/lib/xorg/Xorg (OsLookupColor+0x13c) [0x5619f3a4d59c]
/usr/lib/gdm3/gdm-x-session[1425]: (EE) 1: /lib/x86_64-linux-gnu/libpthread.so.0 (funlockfile+0x60) [0x7fae4786741f]
/usr/lib/gdm3/gdm-x-session[1425]: (EE) 2: /lib/x86_64-linux-gnu/libc.so.6 (gsignal+0xcb) [0x7fae476a418b]
/usr/lib/gdm3/gdm-x-session[1425]: (EE) 3: /lib/x86_64-linux-gnu/libc.so.6 (abort+0x12b) [0x7fae47683859]
/usr/lib/gdm3/gdm-x-session[1425]: (EE) unw_get_proc_name failed: no unwind info found [-10]
/usr/lib/gdm3/gdm-x-session[1425]: (EE) 4: /usr/lib/x86_64-linux-gnu/dri/iris_dri.so (?+0x0) [0x7fae457d7aec]
/usr/lib/gdm3/gdm-x-session[1425]: (EE) 5: /usr/lib/x86_64-linux-gnu/dri/iris_dri.so (nouveau_drm_screen_create+0x25c8ec) [0x7fae46529c9c]
/usr/lib/gdm3/gdm-x-session[1425]: (EE) 6: /usr/lib/x86_64-linux-gnu/dri/iris_dri.so (__driDriverGetExtensions_zink+0x2561d) [0x7fae4582c74d]
/usr/lib/gdm3/gdm-x-session[1425]: (EE) 7: /usr/lib/xorg/modules/libglamoregl.so (glamor_destroy_pixmap+0x150) [0x7fae47007480]
/usr/lib/gdm3/gdm-x-session[1425]: (EE) unw_get_proc_name failed: no unwind info found [-10]
/usr/lib/gdm3/gdm-x-session[1425]: (EE) 8: /usr/lib/xorg/modules/drivers/modesetting_drv.so (?+0x0) [0x7fae47040a30]
/usr/lib/gdm3/gdm-x-session[1425]: (EE) 9: /usr/lib/xorg/Xorg (BlockHandler+0xa5) [0x5619f38f0995]
/usr/lib/gdm3/gdm-x-session[1425]: (EE) 10: /usr/lib/xorg/Xorg (WaitForSomething+0x122) [0x5619f3a46c12]
/usr/lib/gdm3/gdm-x-session[1425]: (EE) 11: /usr/lib/xorg/Xorg (SendErrorToClient+0x117) [0x5619f38ebcf7]
/usr/lib/gdm3/gdm-x-session[1425]: (EE) 12: /usr/lib/xorg/Xorg (InitFonts+0x3b4) [0x5619f38effc4]
/usr/lib/gdm3/gdm-x-session[1425]: (EE) 13: /lib/x86_64-linux-gnu/libc.so.6 (__libc_start_main+0xf3) [0x7fae476850b3]
/usr/lib/gdm3/gdm-x-session[1425]: (EE) 14: /usr/lib/xorg/Xorg (_start+0x2e) [0x5619f38d9a2e]

More info:
I searched the Internet and got a bug with the same stacktrace:
https://gitlab.freedesktop.org/mesa/mesa/-/issues/3468
https://gitlab.freedesktop.org/mesa/mesa/-/issues/2859

Revision history for this message
Kai-Chuan Hsieh (kchsieh) wrote :

I follow the upstream bug to install obiaf ppa's mesa lib and run the test for two times, then I can get pass successfully for both run. I plan to run the test three times to make sure the edge mesa lib can really solve the problem, because the issue seems happens randomly.

tags: added: oem-priority originate-from-1917692 somerville
description: updated
description: updated
Revision history for this message
Kai-Chuan Hsieh (kchsieh) wrote :

After two times pass for using mesa lib in ppa:oibaf/graphics-drivers, I reproduce the x server stop error with different stacktrace:

Mar 12 12:43:12 stress-ng: memory (MB): total 15729.63, free 152.17, shared 43.86, buffer 0.36, swap 2048.00, free swap 0.01
Mar 12 12:43:12 /usr/lib/gdm3/gdm-x-session[1949]: (EE)
Mar 12 12:43:12 /usr/lib/gdm3/gdm-x-session[1949]: (EE) Backtrace:
Mar 12 12:43:12 /usr/lib/gdm3/gdm-x-session[1949]: (EE) 0: /usr/lib/xorg/Xorg (OsLookupColor+0x13c) [0x55d66e90159c]
Mar 12 12:43:12 /usr/lib/gdm3/gdm-x-session[1949]: (EE) 1: /lib/x86_64-linux-gnu/libpthread.so.0 (funlockfile+0x60) [0x7f5f95cc941f]
Mar 12 12:43:12 /usr/lib/gdm3/gdm-x-session[1949]: (EE) 2: /lib/x86_64-linux-gnu/libc.so.6 (gsignal+0xcb) [0x7f5f95b0618b]
Mar 12 12:43:12 /usr/lib/gdm3/gdm-x-session[1949]: (EE) 3: /lib/x86_64-linux-gnu/libc.so.6 (abort+0x12b) [0x7f5f95ae5859]
Mar 12 12:43:12 /usr/lib/gdm3/gdm-x-session[1949]: (EE) unw_get_proc_name failed: no unwind info found [-10]
Mar 12 12:43:12 /usr/lib/gdm3/gdm-x-session[1949]: (EE) 4: /usr/lib/x86_64-linux-gnu/dri/iris_dri.so (?+0x0) [0x7f5f939fd665]
Mar 12 12:43:12 /usr/lib/gdm3/gdm-x-session[1949]: (EE) 5: /usr/lib/x86_64-linux-gnu/dri/iris_dri.so (nouveau_drm_screen_create+0x29a098) [0x7f5f948c5d08]
Mar 12 12:43:12 /usr/lib/gdm3/gdm-x-session[1949]: (EE) 6: /usr/lib/x86_64-linux-gnu/dri/iris_dri.so (__driDriverGetExtensions_zink+0x7cf0d) [0x7f5f93b0214d]
Mar 12 12:43:12 /usr/lib/gdm3/gdm-x-session[1949]: (EE) 7: /usr/lib/xorg/Xorg (present_register_complete_notify+0x673) [0x55d66e87dcf3]
Mar 12 12:43:12 /usr/lib/gdm3/gdm-x-session[1949]: (EE) 8: /usr/lib/xorg/Xorg (present_register_complete_notify+0x1fd9) [0x55d66e880ee9]
Mar 12 12:43:12 /usr/lib/gdm3/gdm-x-session[1949]: (EE) 9: /usr/lib/xorg/Xorg (present_register_complete_notify+0x809) [0x55d66e87e069]
Mar 12 12:43:12 /usr/lib/gdm3/gdm-x-session[1949]: (EE) 10: /usr/lib/xorg/Xorg (present_register_complete_notify+0x845) [0x55d66e87e105]
Mar 12 12:43:12 /usr/lib/gdm3/gdm-x-session[1949]: (EE) 11: /usr/lib/xorg/Xorg (TimerSet+0x180) [0x55d66e8fabd0]
Mar 12 12:43:12 /usr/lib/gdm3/gdm-x-session[1949]: (EE) 12: /usr/lib/xorg/Xorg (TimerSet+0x1e8) [0x55d66e8fac88]
Mar 12 12:43:12 /usr/lib/gdm3/gdm-x-session[1949]: (EE) 13: /usr/lib/xorg/Xorg (WaitForSomething+0x235) [0x55d66e8fad25]
Mar 12 12:43:12 /usr/lib/gdm3/gdm-x-session[1949]: (EE) 14: /usr/lib/xorg/Xorg (SendErrorToClient+0x117) [0x55d66e79fcf7]
Mar 12 12:43:12 /usr/lib/gdm3/gdm-x-session[1949]: (EE) 15: /usr/lib/xorg/Xorg (InitFonts+0x3b4) [0x55d66e7a3fc4]
Mar 12 12:43:12 /usr/lib/gdm3/gdm-x-session[1949]: (EE) 16: /lib/x86_64-linux-gnu/libc.so.6 (__libc_start_main+0xf3) [0x7f5f95ae70b3]
Mar 12 12:43:12 /usr/lib/gdm3/gdm-x-session[1949]: (EE) 17: /usr/lib/xorg/Xorg (_start+0x2e) [0x55d66e78da2e]
Mar 12 12:43:12 /usr/lib/gdm3/gdm-x-session[1949]: (EE)
Mar 12 12:43:12 /usr/lib/gdm3/gdm-x-session[1949]: (EE)
Mar 12 12:43:12 /usr/lib/gdm3/gdm-x-session[1949]: Fatal server error:
Mar 12 12:43:12 /usr/lib/gdm3/gdm-x-session[1949]: (EE) Caught signal 6 (Aborted). Server aborting

The detail log is in lp:1917692.

Rex Tsai (chihchun)
Changed in oem-priority:
importance: Undecided → High
Timo Aaltonen (tjaalton)
Changed in mesa (Ubuntu):
assignee: nobody → Timo Aaltonen (tjaalton)
Revision history for this message
Timo Aaltonen (tjaalton) wrote :

check if https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/8861 helps

or wait until I'm able to backport it..

Revision history for this message
Kai-Chuan Hsieh (kchsieh) wrote :

@tjaalton

Thanks for your comment.

I build a test build in my ppa https://launchpad.net/~kchsieh/+archive/ubuntu/verification
The debdiff is attached. I'll try to verify it with the hardware in lp:1917692.

I don't know if I apply the patch correctly if you see anything wrong, please correct me.

Thanks,

Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "mesa_20.2.6-0ubuntu0.20.04.2.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Mathew Hodson (mhodson)
Changed in mesa (Ubuntu):
importance: Undecided → Medium
Revision history for this message
Kai-Chuan Hsieh (kchsieh) wrote :

I try memory stress test with my ppa in #4, the issue is still reproduced.

Revision history for this message
You-Sheng Yang (vicamo) wrote :

https://gitlab.freedesktop.org/mesa/mesa/-/issues/4275#note_796719:
```
   if (ret < 0) {
#ifdef DEBUG
      const bool color = INTEL_DEBUG & DEBUG_COLOR;
      fprintf(stderr, "%siris: Failed to submit batchbuffer: %-80s%s\n",
              color ? "\e[1;41m" : "", strerror(-ret), color ? "\e[0m" : "");
#endif
      abort();
   }
```
which means `submit_batch` failed, which means `DRM_IOCTL_I915_GEM_EXECBUFFER2` failed.

(keep a note here)

Revision history for this message
Andy Chi (andch) wrote :

I can reproduce this issue on hirsute.
Information below is the mesa version.

libegl-mesa0:amd64 21.0.1-2
libgbm1:amd64 21.0.1-2
libgl1-mesa-dri:amd64 21.0.1-2
libglapi-mesa:amd64 21.0.1-2
libglx-mesa0:amd64 21.0.1-2
libxatracker2:amd64 21.0.1-2
mesa-vulkan-drivers:amd64 21.0.1-2

Revision history for this message
Andy Chi (andch) wrote :

Version of mesa on oibaf ppa
21.2~git2104200600.4a384f~oibaf~h
(note)

Changed in oem-priority:
assignee: nobody → Andy Chi (andch)
status: New → In Progress
Revision history for this message
Timo Aaltonen (tjaalton) wrote :

#7 would suggest it's a kernel bug, so maybe test drm-tip to see if it helps

Revision history for this message
You-Sheng Yang (vicamo) wrote : Re: Xorg xserver got signal 6 to abort

Attach also dmesg from drm-tip today, version 5.12.0-051200rc8drmtip20210422-generic on RKL SDP installed Focal. Also using linux-firmware from upstream master HEAD.

Revision history for this message
Andy Chi (andch) wrote :

Reproduce with kernel cod/tip/drm-tip/2021-04-22 Mainline on hirsute.

Revision history for this message
You-Sheng Yang (vicamo) wrote :

Re-attach full dmesg log with this issue reproduced on RKL SDP (202102-28687) running 5.12-rc8.

Revision history for this message
Andy Chi (andch) wrote :

Test pass with newer mesa version from oibaf ppa.

libegl-mesa0:amd64 21.2~git2104200600.4a384f~oibaf~h
libgbm1:amd64 21.2~git2104200600.4a384f~oibaf~h
libgl1-mesa-dri:amd64 21.2~git2104200600.4a384f~oibaf~h
libglapi-mesa:amd64 21.2~git2104200600.4a384f~oibaf~h
libglx-mesa0:amd64 21.2~git2104200600.4a384f~oibaf~h
libxatracker2:amd64 21.2~git2104200600.4a384f~oibaf~h
mesa-vulkan-drivers:amd64 21.2~git2104200600.4a384f~oibaf~h

Revision history for this message
Kai-Chuan Hsieh (kchsieh) wrote :

Summarize the bug status:

1. The issue is reproduced on focal/hirsute.
2. The latest mesa library from ppa:oibaf/graphics-drivers, can lower the reproduce rate on focal/hirsute, it is 100/100 reproducible originally.

Conclusion:
We don't have identified solution at this moment.

Changed in oem-priority:
importance: High → Critical
Revision history for this message
You-Sheng Yang (vicamo) wrote :
description: updated
jeremyszu (os369510)
tags: added: originate-from-1929152 stella
Revision history for this message
jeremyszu (os369510) wrote :
Download full text (3.2 KiB)

```
Mar 3 18:07:02 kernel: [ 4935.420223] gnome-shell invoked oom-killer: gfp_mask=0x100cca(GFP_HIGHUSER_MOVABLE), order=0, oom_score_adj=0
Mar 3 18:07:16 kernel: [ 4949.440656] gnome-shell invoked oom-killer: gfp_mask=0x100cca(GFP_HIGHUSER_MOVABLE), order=0, oom_score_adj=0
Mar 3 18:08:11 kernel: [ 5004.462545] gnome-shell invoked oom-killer: gfp_mask=0x100cca(GFP_HIGHUSER_MOVABLE), order=0, oom_score_adj=0
Mar 3 18:09:14 kernel: [ 5066.643244] gnome-shell invoked oom-killer: gfp_mask=0x100cca(GFP_HIGHUSER_MOVABLE), order=0, oom_score_adj=0
Mar 3 18:09:34 kernel: [ 5087.214632] gnome-shell invoked oom-killer: gfp_mask=0x100cca(GFP_HIGHUSER_MOVABLE), order=0, oom_score_adj=0
Mar 3 19:40:26 kernel: [10538.987863] gnome-terminal- invoked oom-killer: gfp_mask=0x100cca(GFP_HIGHUSER_MOVABLE), order=0, oom_score_adj=0
Mar 3 19:40:28 kernel: [10541.043501] gnome-terminal- invoked oom-killer: gfp_mask=0x100cca(GFP_HIGHUSER_MOVABLE), order=0, oom_score_adj=0
Mar 3 19:40:45 kernel: [10558.082088] gnome-shell invoked oom-killer: gfp_mask=0x100cca(GFP_HIGHUSER_MOVABLE), order=0, oom_score_adj=0
Mar 3 19:40:49 kernel: [10562.058290] gnome-shell invoked oom-killer: gfp_mask=0x100cca(GFP_HIGHUSER_MOVABLE), order=0, oom_score_adj=0
Mar 3 19:41:14 kernel: [10586.699020] gnome-shell invoked oom-killer: gfp_mask=0x100cca(GFP_HIGHUSER_MOVABLE), order=0, oom_score_adj=0
Mar 3 19:41:35 kernel: [10608.175575] gnome-shell invoked oom-killer: gfp_mask=0x0(), order=0, oom_score_adj=0
Mar 3 19:41:55 kernel: [10627.942562] gnome-shell invoked oom-killer: gfp_mask=0x100cca(GFP_HIGHUSER_MOVABLE), order=0, oom_score_adj=0
Mar 3 19:41:55 kernel: [10628.294303] gnome-shell invoked oom-killer: gfp_mask=0x100cca(GFP_HIGHUSER_MOVABLE), order=0, oom_score_adj=0
Mar 3 19:42:12 kernel: [10645.292252] gnome-shell invoked oom-killer: gfp_mask=0x100cca(GFP_HIGHUSER_MOVABLE), order=0, oom_score_adj=0
Mar 3 19:42:43 kernel: [10675.670335] gnome-shell invoked oom-killer: gfp_mask=0x100cca(GFP_HIGHUSER_MOVABLE), order=0, oom_score_adj=0
Mar 3 19:43:06 gnome-shell[1691]: GNOME Shell crashed with signal 6
Mar 3 19:43:15 kernel: [10708.155220] gnome-shell invoked oom-killer: gfp_mask=0x100cca(GFP_HIGHUSER_MOVABLE), order=0, oom_score_adj=0
Mar 3 19:43:31 kernel: [10724.420148] gnome-shell invoked oom-killer: gfp_mask=0x100cca(GFP_HIGHUSER_MOVABLE), order=0, oom_score_adj=0
Mar 3 19:43:32 kernel: [10725.336522] gnome-shell invoked oom-killer: gfp_mask=0x100cca(GFP_HIGHUSER_MOVABLE), order=0, oom_score_adj=0
Mar 3 19:43:36 kernel: [10729.101114] gnome-shell invoked oom-killer: gfp_mask=0x100cca(GFP_HIGHUSER_MOVABLE), order=0, oom_score_adj=0
Mar 3 19:43:44 kernel: [10737.358855] gnome-shell invoked oom-killer: gfp_mask=0x100cca(GFP_HIGHUSER_MOVABLE), order=0, oom_score_adj=0
Mar 3 19:44:09 kernel: [10761.733283] gnome-shell invoked oom-killer: gfp_mask=0x100cca(GFP_HIGHUSER_MOVABLE), order=0, oom_score_adj=0
Mar 3 19:44:31 kernel: [10783.687545] pool-gnome-shel invoked oom-killer: gfp_mask=0x100cca(GFP_HIGHUSER_MOVABLE), order=0, oom_score_adj=0
Mar 3 19:45:23 /usr/lib/gdm3/gdm-x-session[1425]: (EE) Caught signal 6 (Aborted). Server aborting
```

Does not make sense to me, I don't think it's ...

Read more...

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

I was able to reproduce it on my RKL, but the reason was bad RAM. After swapping it to another otherwise identical set, it works fine.

The reproducer here was running 'stress-ng --stack 0'

Revision history for this message
jeremyszu (os369510) wrote :

@Timo,

I guess you could get passed if adding "--oomable"

Revision history for this message
Kai-Heng Feng (kaihengfeng) wrote :
description: updated
jeremyszu (os369510)
tags: added: originate-from-1932285
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mesa - 21.1.2-1

---------------
mesa (21.1.2-1) experimental; urgency=medium

  * New upstream release.
  * iris-avoid-abort-if-enomem.diff: Don't abort when out of memory.
    (LP: #1918855)

 -- Timo Aaltonen <email address hidden> Fri, 18 Jun 2021 14:33:09 +0300

Changed in mesa (Ubuntu):
status: New → Fix Released
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Is this the same issue as bug 1871959?

Revision history for this message
Kai-Heng Feng (kaihengfeng) wrote :

I think it's another bug. The log from original bug report shows that the system has 32G ram, so the abort() is less likely triggered by OOM.

Iain Lane (laney)
Changed in mesa (Ubuntu Focal):
assignee: nobody → Timo Aaltonen (tjaalton)
Changed in mesa (Ubuntu Hirsute):
assignee: nobody → Timo Aaltonen (tjaalton)
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Sounds like the upstream bug:

  https://gitlab.freedesktop.org/mesa/mesa/-/issues/2859

needs to be unlinked from this bug. It's still open and already linked to bug 1871959 instead.

no longer affects: mesa
Alex Tu (alextu)
Changed in oem-priority:
assignee: Andy Chi (andch) → jeremyszu (os369510)
Mathew Hodson (mhodson)
Changed in mesa (Ubuntu Focal):
importance: Undecided → Medium
Changed in mesa (Ubuntu Hirsute):
importance: Undecided → Medium
Mathew Hodson (mhodson)
affects: plainbox-provider-checkbox → ubuntu-translations
no longer affects: ubuntu-translations
Revision history for this message
Łukasz Zemczak (sil2100) wrote : Please test proposed package

Hello Kai-Chuan, or anyone else affected,

Accepted mesa into hirsute-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mesa/21.0.3-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-hirsute to verification-done-hirsute. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-hirsute. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in mesa (Ubuntu Hirsute):
status: New → Fix Committed
tags: added: verification-needed verification-needed-hirsute
jeremyszu (os369510)
Changed in oem-priority:
status: In Progress → Triaged
Revision history for this message
Kai-Heng Feng (kaihengfeng) wrote : Re: Xorg xserver got signal 6 to abort

I enable -proposed and do a dist-upgrade, then reboot and run stress-ng:
$ stress-ng --stack 0 --timeout 300
stress-ng: info: [2493] dispatching hogs: 16 stack
stress-ng: info: [2493] successful run completed in 300.63s (5 mins, 0.63 secs)

And the desktop session is still alive.

tags: added: verification-done verification-done-hirsute
removed: verification-needed verification-needed-hirsute
Revision history for this message
Timo Aaltonen (tjaalton) wrote :

focal update is available too

tags: added: verification-needed-focal
Changed in mesa (Ubuntu Focal):
status: New → Fix Committed
Revision history for this message
Kai-Heng Feng (kaihengfeng) wrote :

I enable -proposed and do a dist-upgrade, made sure 21.0.3-0ubuntu0.1~20.04.1 is installed, then reboot and run stress-ng:

$ stress-ng --stack 0 --timeout 300
stress-ng: info: [1782] dispatching hogs: 16 stack
stress-ng: info: [1782] successful run completed in 300.47s (5 mins, 0.47 secs)

The desktop session didn't crash so it's still alive.

tags: added: verification-done-focal
removed: verification-needed-focal
Revision history for this message
Łukasz Zemczak (sil2100) wrote : Please test proposed package

Hello Kai-Chuan, or anyone else affected,

Accepted mesa into hirsute-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mesa/21.0.3-0ubuntu0.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-hirsute to verification-done-hirsute. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-hirsute. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed verification-needed-hirsute
removed: verification-done verification-done-hirsute
Revision history for this message
Andy Chi (andch) wrote : Re: Xorg xserver got signal 6 to abort

I enable -proposed and do a dist-upgrade, made sure 21.0.3-0ubuntu0.2 is installed, then reboot and run stress-ng:

$ stress-ng --stack 0 --timeout 300
stress-ng: info: [1936] dispatching hogs: 8 stack
stress-ng: info: [1936] successful run completed in 300.88s (5 mins, 0.88 secs)

The desktop session didn't crash so it's still alive.

Andy Chi (andch)
tags: added: verification-done verification-done-hirsute
removed: verification-needed verification-needed-hirsute
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

I've tried to give this bug a more unique title to distinguish it from the other SIGABRTs:

  https://bugs.launchpad.net/ubuntu/+source/xorg-server?field.searchtext=SIGABRT

Also note the stack trace in the Bug Description is not unique. It should probably be deleted. Only stack traces with debug symbols are useful with Xorg.

summary: - Xorg xserver got signal 6 to abort
+ Xorg crashed with SIGABRT when under memory pressure
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mesa - 21.0.3-0ubuntu0.2

---------------
mesa (21.0.3-0ubuntu0.2) hirsute; urgency=medium

  * amd-add-missing-line-from-backport.diff: Fix a regression with
    radeonsi caused by a bad backport. (LP: #1934783)

mesa (21.0.3-0ubuntu0.1) hirsute; urgency=medium

  * New upstream release. (LP: #1925434)
    - drisw-move-zink-down.diff dropped, upstream
  * Migrate to llvm-12. (LP: #1932311)
  * iris-avoid-abort-if-enomem.diff: Don't abort when out of memory.
    (LP: #1918855)

 -- Timo Aaltonen <email address hidden> Mon, 19 Jul 2021 22:26:12 +0300

Changed in mesa (Ubuntu Hirsute):
status: Fix Committed → Fix Released
Revision history for this message
Łukasz Zemczak (sil2100) wrote : Update Released

The verification of the Stable Release Update for mesa has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mesa - 21.0.3-0ubuntu0.2~20.04.1

---------------
mesa (21.0.3-0ubuntu0.2~20.04.1) focal; urgency=medium

  * Backport to focal. (LP: #1925320)
  * control, rules: Use gcc10 on ppc64el to fix the build.

mesa (21.0.3-0ubuntu0.2) hirsute; urgency=medium

  * amd-add-missing-line-from-backport.diff: Fix a regression with
    radeonsi caused by a bad backport. (LP: #1934783)

 -- Timo Aaltonen <email address hidden> Tue, 25 May 2021 09:51:53 +0300

Changed in mesa (Ubuntu Focal):
status: Fix Committed → Fix Released
Revision history for this message
Cyrus Lien (cyruslien) wrote :

@Timo,

In bionic mesa (20.0.8-0ubuntu1~18.04.1) it prefer i965 by default over iris.
rules: confflags_GALLIUM += -Dprefer-iris=false

Is it available to enable iris by default in bionic?

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

that would require a newer libepoxy

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

this bug was about iris, if you have some other issue that *requires iris*, then file a new one

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Also remember you can test iris using environment MESA_LOADER_DRIVER_OVERRIDE=iris

Revision history for this message
Cyrus Lien (cyruslien) wrote :

I encountered exactly same issue as this bug on bionic so I would like to leverage iris fix (iris-avoid-abort-if-enomem.diff) but bionic mesa prefer i965 by default over iris.
Do I need to file a new one on mesa/i965 driver?

Aug 3 03:12:39 u-Vostro /usr/lib/gdm3/gdm-x-session[1864]: (EE) glamor0: GL error: GL_OUT_OF_MEMORY in glTexImage2D
Aug 3 03:12:50 u-Vostro /usr/lib/gdm3/gdm-x-session[1864]: (EE)
Aug 3 03:12:50 u-Vostro /usr/lib/gdm3/gdm-x-session[1864]: (EE) Backtrace:
Aug 3 03:12:54 u-Vostro /usr/lib/gdm3/gdm-x-session[1864]: (EE) 0: /usr/lib/xorg/Xorg (?+0x0) [0x556430b27080]
Aug 3 03:12:54 u-Vostro /usr/lib/gdm3/gdm-x-session[1864]: (EE) 1: /lib/x86_64-linux-gnu/libpthread.so.0 (?+0x0) [0x7f7778ae697f]
Aug 3 03:12:56 u-Vostro /usr/lib/gdm3/gdm-x-session[1864]: (EE) 2: /usr/lib/x86_64-linux-gnu/dri/i965_dri.so (?+0x0) [0x7f7773960a70]
Aug 3 03:12:56 u-Vostro /usr/lib/gdm3/gdm-x-session[1864]: (EE) 3: /usr/lib/x86_64-linux-gnu/dri/i965_dri.so (?+0x0) [0x7f7773960d10]
Aug 3 03:12:56 u-Vostro /usr/lib/gdm3/gdm-x-session[1864]: (EE) 4: /usr/lib/x86_64-linux-gnu/dri/i965_dri.so (?+0x0) [0x7f7773960de0]

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Although that stack trace is not useful the GL_OUT_OF_MEMORY does kind of give it away that it's the same kind of issue as this. I would say it makes sense to do a different fix for i965 but keep using this same bug ID.

Revision history for this message
Cyrus Lien (cyruslien) wrote :

@Daniel @Timo,
I fund the root cause of my X crash issue, which is not same as this bug.
Please ignore my comments and thanks for your response.

jeremyszu (os369510)
Changed in oem-priority:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers