FFE: new upstream release 21.0 and migrate to llvm 12

Bug #1917763 reported by Timo Aaltonen
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mesa (Ubuntu)
Medium
Timo Aaltonen
Focal
Undecided
Unassigned
Hirsute
Undecided
Unassigned

Bug Description

Mesa 21.0.0 will be released soon, and we still want it in 21.04. It's been in Debian experimental since rc1. The packaging also migrates it to use llvm 12.

The risks involve graphical issues or even crashes when running more intense OpenGL/Vulkan apps like games. Running a desktop is a simple use-case and should work fine across the board. Upstream gitlab has a fairly extensive CI for various drivers, while Intel tests on their own CI. This means that any showstoppers should be shaken out already.

We will be able to pull maybe two point-releases before hirsute is frozen, and then push more as an SRU.

I've tested 21.0.0-rc's on Intel and AMD (RX 5700) and the latter too with some games, all good.

packages for hirsute are available on ppa:canonical-x/x-staging

Timo Aaltonen (tjaalton)
Changed in mesa (Ubuntu):
assignee: nobody → Timo Aaltonen (tjaalton)
status: New → In Progress
Timo Aaltonen (tjaalton)
Changed in mesa (Ubuntu):
status: In Progress → New
Revision history for this message
Timo Aaltonen (tjaalton) wrote :

Note that migrating to llvm 12 can be done later, and use llvm 11 for now until 12.0 is released (is at rc3 now).

Revision history for this message
Iain Lane (laney) wrote :

ACK, go for it (with 11 for now, I agree that switching to an RC compiler feels dodgy)

Changed in mesa (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mesa - 21.0.0-1

---------------
mesa (21.0.0-1) experimental; urgency=medium

  * New upstream release. (LP: #1917763)
  * control: Add directx-headers-dev to build-depends for amd64 and arm64
    on Linux, which is what WSL2 currently supports.

 -- Timo Aaltonen <email address hidden> Mon, 15 Mar 2021 19:22:33 +0200

Changed in mesa (Ubuntu):
status: Triaged → Fix Released
Timo Aaltonen (tjaalton)
Changed in mesa (Ubuntu Hirsute):
status: New → Invalid
Changed in mesa (Ubuntu Focal):
status: New → Invalid
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mesa - 21.0.3-0ubuntu0.2~20.04.1

---------------
mesa (21.0.3-0ubuntu0.2~20.04.1) focal; urgency=medium

  * Backport to focal. (LP: #1925320)
  * control, rules: Use gcc10 on ppc64el to fix the build.

mesa (21.0.3-0ubuntu0.2) hirsute; urgency=medium

  * amd-add-missing-line-from-backport.diff: Fix a regression with
    radeonsi caused by a bad backport. (LP: #1934783)

 -- Timo Aaltonen <email address hidden> Tue, 25 May 2021 09:51:53 +0300

Changed in mesa (Ubuntu Focal):
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers