GoogleEarth leads into "drmWaitVBlank returned -1" error

Bug #186764 reported by dorpm on 2008-01-28
6
Affects Status Importance Assigned to Milestone
Mesa
Fix Released
Medium
mesa (Ubuntu)
Medium
Timo Aaltonen

Bug Description

On my system (kubuntu 7.10 with an Radeon 9800 PRO using the open source ati driver) GoogleEarth reports "do_wait: drmWaitVBlank returned -1, IRQs don't seem to be working correctly.
Try running with LIBGL_THROTTLE_REFRESH and LIBL_SYNC_REFRESH unset."

xrandr --verbose tells me:
Screen 0: minimum 320 x 200, current 1280 x 1024, maximum 1280 x 1200
VGA-0 disconnected (normal left inverted right)
        Identifier: 0x4c
        Timestamp: -1042719901
        Subpixel: no subpixels
        Clones:
        CRTCs: 0 1
        load_detection: 1 (0x00000001) range: (0,1)
DVI-0 connected 1280x1024+0+0 (0x4f) normal (normal left inverted right) 376mm x 301mm
        Identifier: 0x4d
        Timestamp: -1042719901
        Subpixel: horizontal rgb
        Clones:
        CRTC: 0
        CRTCs: 0 1
        EDID_DATA:
                00ffffffffffff0009d10177ac050000
                0b11010380261e78eaa2a5a3574c9d25
                115054bdef80714f81908180818c454f
                614001010101302a009851002a403070
                1300782d1100001ed50980a0205e6310
                10605208782d1100001a000000fd0038
                4c1f530e000a202020202020000000fc
                0042656e51204650393347530a0a00bb
                dvi_monitor_type: auto
                scaler: off
                tmds_pll: bios
        load_detection: 0 (0x00000000) range: (0,1)
  1280x1024 (0x4f) 108.0MHz +HSync +VSync
        h: width 1280 start 1328 end 1440 total 1688 skew 0 clock 64.0KHz
        v: height 1024 start 1025 end 1028 total 1066 clock 60.0Hz
  1280x1024 (0x50) 140.8MHz -HSync +VSync
        h: width 1280 start 1368 end 1504 total 1728 skew 0 clock 81.5KHz
        v: height 1024 start 1027 end 1034 total 1072 clock 76.0Hz
  1280x1024 (0x51) 135.0MHz +HSync +VSync
        h: width 1280 start 1296 end 1440 total 1688 skew 0 clock 80.0KHz
        v: height 1024 start 1025 end 1028 total 1066 clock 75.0Hz
  1280x1024 (0x52) 133.0MHz -HSync +VSync
        h: width 1280 start 1368 end 1504 total 1728 skew 0 clock 77.0KHz
        v: height 1024 start 1027 end 1034 total 1070 clock 71.9Hz
  1280x1024 (0x53) 109.0MHz -HSync +VSync
        h: width 1280 start 1368 end 1496 total 1712 skew 0 clock 63.7KHz
        v: height 1024 start 1027 end 1034 total 1063 clock 59.9Hz
  1152x864 (0x54) 108.0MHz +HSync +VSync
        h: width 1152 start 1216 end 1344 total 1600 skew 0 clock 67.5KHz
        v: height 864 start 865 end 868 total 900 clock 75.0Hz
  1152x864 (0x55) 104.0MHz -HSync +VSync
        h: width 1152 start 1224 end 1344 total 1536 skew 0 clock 67.7KHz
        v: height 864 start 867 end 871 total 905 clock 74.8Hz
  1024x768 (0x56) 78.8MHz +HSync +VSync
        h: width 1024 start 1040 end 1136 total 1312 skew 0 clock 60.1KHz
        v: height 768 start 769 end 772 total 800 clock 75.1Hz
  1024x768 (0x57) 75.0MHz -HSync -VSync
        h: width 1024 start 1048 end 1184 total 1328 skew 0 clock 56.5KHz
        v: height 768 start 771 end 777 total 806 clock 70.1Hz
  1024x768 (0x58) 65.0MHz -HSync -VSync
        h: width 1024 start 1048 end 1184 total 1344 skew 0 clock 48.4KHz
        v: height 768 start 771 end 777 total 806 clock 60.0Hz
  1024x768 (0x59) 63.5MHz -HSync +VSync
        h: width 1024 start 1072 end 1176 total 1328 skew 0 clock 47.8KHz
        v: height 768 start 771 end 775 total 798 clock 59.9Hz
  832x624 (0x5a) 57.3MHz -HSync -VSync
        h: width 832 start 864 end 928 total 1152 skew 0 clock 49.7KHz
        v: height 624 start 625 end 628 total 667 clock 74.6Hz
  800x600 (0x5b) 50.0MHz +HSync +VSync
        h: width 800 start 856 end 976 total 1040 skew 0 clock 48.1KHz
        v: height 600 start 637 end 643 total 666 clock 72.2Hz
  800x600 (0x5c) 49.5MHz +HSync +VSync
        h: width 800 start 816 end 896 total 1056 skew 0 clock 46.9KHz
        v: height 600 start 601 end 604 total 625 clock 75.0Hz
  800x600 (0x5d) 49.0MHz -HSync +VSync
        h: width 800 start 840 end 920 total 1040 skew 0 clock 47.1KHz
        v: height 600 start 603 end 607 total 629 clock 74.9Hz
  800x600 (0x5e) 40.0MHz +HSync +VSync
        h: width 800 start 840 end 968 total 1056 skew 0 clock 37.9KHz
        v: height 600 start 601 end 605 total 628 clock 60.3Hz
  640x480 (0x5f) 31.5MHz -HSync -VSync
        h: width 640 start 656 end 720 total 840 skew 0 clock 37.5KHz
        v: height 480 start 481 end 484 total 500 clock 75.0Hz
  640x480 (0x60) 31.5MHz -HSync -VSync
        h: width 640 start 664 end 704 total 832 skew 0 clock 37.9KHz
        v: height 480 start 489 end 491 total 520 clock 72.8Hz
  640x480 (0x61) 30.2MHz -HSync -VSync
        h: width 640 start 704 end 768 total 864 skew 0 clock 35.0KHz
        v: height 480 start 483 end 486 total 525 clock 66.7Hz
  640x480 (0x62) 25.2MHz -HSync -VSync
        h: width 640 start 656 end 752 total 800 skew 0 clock 31.5KHz
        v: height 480 start 490 end 492 total 525 clock 60.0Hz
  720x400 (0x63) 28.3MHz -HSync +VSync
        h: width 720 start 738 end 846 total 900 skew 0 clock 31.5KHz
        v: height 400 start 412 end 414 total 449 clock 70.1Hz
  640x350 (0x64) 25.2MHz -HSync +VSync
        h: width 640 start 656 end 752 total 800 skew 0 clock 31.5KHz
        v: height 350 start 387 end 389 total 449 clock 70.1Hz
S-video disconnected (normal left inverted right)
        Identifier: 0x4e
        Timestamp: -1042719901
        Subpixel: no subpixels
        Clones:
        CRTCs: 0 1
                tv_standard: pal
        tv_vertical_position: 0 (0x00000000) range: (-5,5)
        tv_horizontal_position: 0 (0x00000000) range: (-5,5)
        tv_horizontal_size: 0 (0x00000000) range: (-5,5)
        load_detection: 0 (0x00000000) range: (0,1)

Attached you´ll find my xorg.conf and the xorg log.

If any more information is needed please let me know.

Florian

Related branches

Please attach (as opposed to paste) the full xorg.conf and Xorg.0.log files and the output of xrandr --verbose. Which version of Mesa are you using?

Created an attachment (id=13584)
xorg.conf

Created an attachment (id=13585)
Xorg.0.log

Created an attachment (id=13586)
xrandr

Bugzilla Upgrade Mass Bug Change

NEEDSINFO state was removed in Bugzilla 3.x, reopening any bugs previously listed as NEEDSINFO.

  - benjsc
    fd.o Wrangler

dorpm (dorpmueller) wrote :
Download full text (6.2 KiB)

On my system (kubuntu 7.10 with an Radeon 9800 PRO using the open source ati driver) GoogleEarth reports "do_wait: drmWaitVBlank returned -1, IRQs don't seem to be working correctly.
Try running with LIBGL_THROTTLE_REFRESH and LIBL_SYNC_REFRESH unset."

xrandr --verbose tells me:
Screen 0: minimum 320 x 200, current 1280 x 1024, maximum 1280 x 1200
VGA-0 disconnected (normal left inverted right)
        Identifier: 0x4c
        Timestamp: -1042719901
        Subpixel: no subpixels
        Clones:
        CRTCs: 0 1
        load_detection: 1 (0x00000001) range: (0,1)
DVI-0 connected 1280x1024+0+0 (0x4f) normal (normal left inverted right) 376mm x 301mm
        Identifier: 0x4d
        Timestamp: -1042719901
        Subpixel: horizontal rgb
        Clones:
        CRTC: 0
        CRTCs: 0 1
        EDID_DATA:
                00ffffffffffff0009d10177ac050000
                0b11010380261e78eaa2a5a3574c9d25
                115054bdef80714f81908180818c454f
                614001010101302a009851002a403070
                1300782d1100001ed50980a0205e6310
                10605208782d1100001a000000fd0038
                4c1f530e000a202020202020000000fc
                0042656e51204650393347530a0a00bb
                dvi_monitor_type: auto
                scaler: off
                tmds_pll: bios
        load_detection: 0 (0x00000000) range: (0,1)
  1280x1024 (0x4f) 108.0MHz +HSync +VSync
        h: width 1280 start 1328 end 1440 total 1688 skew 0 clock 64.0KHz
        v: height 1024 start 1025 end 1028 total 1066 clock 60.0Hz
  1280x1024 (0x50) 140.8MHz -HSync +VSync
        h: width 1280 start 1368 end 1504 total 1728 skew 0 clock 81.5KHz
        v: height 1024 start 1027 end 1034 total 1072 clock 76.0Hz
  1280x1024 (0x51) 135.0MHz +HSync +VSync
        h: width 1280 start 1296 end 1440 total 1688 skew 0 clock 80.0KHz
        v: height 1024 start 1025 end 1028 total 1066 clock 75.0Hz
  1280x1024 (0x52) 133.0MHz -HSync +VSync
        h: width 1280 start 1368 end 1504 total 1728 skew 0 clock 77.0KHz
        v: height 1024 start 1027 end 1034 total 1070 clock 71.9Hz
  1280x1024 (0x53) 109.0MHz -HSync +VSync
        h: width 1280 start 1368 end 1496 total 1712 skew 0 clock 63.7KHz
        v: height 1024 start 1027 end 1034 total 1063 clock 59.9Hz
  1152x864 (0x54) 108.0MHz +HSync +VSync
        h: width 1152 start 1216 end 1344 total 1600 skew 0 clock 67.5KHz
        v: height 864 start 865 end 868 total 900 clock 75.0Hz
  1152x864 (0x55) 104.0MHz -HSync +VSync
        h: width 1152 start 1224 end 1344 total 1536 skew 0 clock 67.7KHz
        v: height 864 start 867 end 871 total 905 clock 74.8Hz
  1024x768 (0x56) 78.8MHz +HSync +VSync
        h: width 1024 start 1040 end 1136 total 1312 skew 0 clock 60.1KHz
        v: height 768 start 769 end 772 total 800 clock 75.1Hz
  1024x768 (0x57) 75.0MHz -HSync -VSync
        h: width 1024 start 1048 end 1184 total 1328 skew 0 clock 56.5KHz
        v: height 768 start 771 end 777 total 806 clock 70.1Hz
 ...

Read more...

dorpm (dorpmueller) wrote :
dorpm (dorpmueller) wrote :
Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage. I have classified this bug as a bug in xorg.

dorpm (dorpmueller) wrote :

Brian, thanks for the hint. I will have a look at the page next time. I was not sure if this error belongs to DRM because of the error message so I left it undecided.

Furthermore I forgot to mention that GE runs unacceptable slow with this error but I found a workaround here: http://bbs.keyhole.com/ubb/showflat.php?Cat=&Board=SupportGELinux&Number=481227&Searchpage=1&Main=471862&Words=+mirsev&topic=&Search=true#Post481227

Florian

Does this also happen if another 3D application (e.g. glxgears) is running when you start Google Earth?

Happens for me too.

mesa 7.0.2/xserver 1.4.0.90/ati git driver from 20080227 (post 1.6.8), kernel 2.6.24

Setting: <option name="vblank_mode" value="0" /> in drirc makes googleeart start (but machine locks up later)

More info, X600 mobile radeon, XAA.

Tried running googleearth while glxgears was already running - no change. Still got
"do_wait: drmWaitVBlank returned -1, IRQs don't seem to be working correctly.
Try running with LIBGL_THROTTLE_REFRESH and LIBL_SYNC_REFRESH unset."

In my case this is like: googlearth &; splash shows; do_wait error is displayed on console and it looks like it never progress - splash is displayed all the time.

After getting some more information on IRC, it looks like this is a Mesa bug related to whatever extension Google Earth uses for sync-to-vblank (sync-to-vblank seems to be generally working, e.g. using the vblank_mode driconf setting). It would be interesting to know if this still happens with the mesa Git master branch.

still happening with 7.0.3~rc2

Laurent Bigonville (bigon) wrote :

Same problem here. GE works quite smootly but takes ages to start

Changed in mesa:
status: New → Confirmed

Fix backported to 7.0 branch, it'll be in the 7.0.3 release.

Changed in mesa:
status: Unknown → Confirmed
Changed in mesa:
status: Confirmed → Fix Released
Laurent Bigonville (bigon) wrote :

Here a patch taken from upstream

Daniel Holbach (dholbach) wrote :

Bryce: does it look OK to you?

Timo Aaltonen (tjaalton) on 2008-03-11
Changed in mesa:
assignee: nobody → tjaalton
importance: Undecided → Medium
milestone: none → ubuntu-8.04-beta
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mesa - 7.0.3~rc2-1ubuntu2

---------------
mesa (7.0.3~rc2-1ubuntu2) hardy; urgency=low

  [ Laurent Bigonville ]
  * debian/patches/105_vblank_fix.patch: Fix "drmWaitVBlank returned -1" error
    (LP: #186764)

  [ Timo Aaltonen ]
  * Add 106_i965_wine_fix.diff from upstream, "Only call
    ProgramStringNotify if program parsing succeeded". (LP: #178292)

 -- Timo Aaltonen <email address hidden> Wed, 12 Mar 2008 12:33:41 +0200

Changed in mesa:
status: Confirmed → Fix Released
Changed in mesa:
importance: Unknown → Medium
Changed in mesa:
importance: Medium → Unknown
Changed in mesa:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.