Add missing pci-id's for Comet Lake (CML)

Bug #1863724 reported by Timo Aaltonen
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mesa (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Timo Aaltonen
Eoan
Undecided
Timo Aaltonen

Bug Description

[Impact]

After rebasing mesa to 19.2.x debian/patches/i965-sync-pciids.diff was updated but some parts of it got accidentally dropped, losing a couple of pci-id's for CML. They need to be restored.

[Test case]

Install the updates on an affected machine, check with glxinfo -B that the proper driver is loaded.

[Regression potential]

none, this just adds pci-id's

Timo Aaltonen (tjaalton)
no longer affects: linux-oem-osp1 (Ubuntu)
description: updated
Changed in mesa (Ubuntu):
status: New → Invalid
Timo Aaltonen (tjaalton)
Changed in mesa (Ubuntu Bionic):
assignee: nobody → Timo Aaltonen (tjaalton)
Changed in mesa (Ubuntu Eoan):
assignee: nobody → Timo Aaltonen (tjaalton)
Revision history for this message
Timo Aaltonen (tjaalton) wrote : Please test proposed package

Hello Timo, or anyone else affected,

Accepted mesa into eoan-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mesa/19.2.8-0ubuntu0~19.10.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-eoan to verification-done-eoan. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-eoan. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in mesa (Ubuntu Eoan):
status: New → Fix Committed
tags: added: verification-needed verification-needed-eoan
Changed in mesa (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed-bionic
Revision history for this message
Timo Aaltonen (tjaalton) wrote :

Hello Timo, or anyone else affected,

Accepted mesa into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mesa/19.2.8-0ubuntu0~18.04.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Revision history for this message
Ubuntu SRU Bot (ubuntu-sru-bot) wrote : Autopkgtest regression report (mesa/19.2.8-0ubuntu0~18.04.3)

All autopkgtests for the newly accepted mesa (19.2.8-0ubuntu0~18.04.3) for bionic have finished running.
The following regressions have been reported in tests triggered by the package:

kwindowsystem/5.44.0-0ubuntu1 (armhf)
freemat/4.2+dfsg1-6 (i386)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/bionic/update_excuses.html#mesa

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Che Cheng (cktenn)
tags: added: verification-done-bionic
removed: verification-needed-bionic
Revision history for this message
Timo Aaltonen (tjaalton) wrote :

and since it's an identical package in eoan which just added three pci-id's, I've marked it verified there too

tags: added: verification-done verification-done-eoan
removed: verification-needed verification-needed-eoan
Revision history for this message
Ubuntu SRU Bot (ubuntu-sru-bot) wrote : Autopkgtest regression report (mesa/19.2.8-0ubuntu0~19.10.3)

All autopkgtests for the newly accepted mesa (19.2.8-0ubuntu0~19.10.3) for eoan have finished running.
The following regressions have been reported in tests triggered by the package:

mutter/unknown (armhf)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/eoan/update_excuses.html#mesa

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Revision history for this message
Łukasz Zemczak (sil2100) wrote : Update Released

The verification of the Stable Release Update for mesa has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mesa - 19.2.8-0ubuntu0~19.10.3

---------------
mesa (19.2.8-0ubuntu0~19.10.3) eoan; urgency=medium

  * i965-sync-pciids.diff: Add back three pci-id's for CML that were
    lost during a rebase. (LP: #1863724)

 -- Timo Aaltonen <email address hidden> Wed, 19 Feb 2020 07:09:44 +0200

Changed in mesa (Ubuntu Eoan):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mesa - 19.2.8-0ubuntu0~18.04.3

---------------
mesa (19.2.8-0ubuntu0~18.04.3) bionic; urgency=medium

  * i965-sync-pciids.diff: Add back three pci-id's for CML that were
    lost during a rebase. (LP: #1863724)

 -- Timo Aaltonen <email address hidden> Wed, 19 Feb 2020 07:09:44 +0200

Changed in mesa (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers