Black screen after updating mesa from 18.2 to 19.0 on i386 Ubuntu 18.04

Bug #1836721 reported by Roman Shipovskij on 2019-07-16
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
mesa (Ubuntu)
Undecided
Unassigned
Bionic
Critical
Timo Aaltonen

Bug Description

Black screen after updating mesa from 18.2 to 19.0 on i386 Ubuntu 18.04.

~# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.04.2 LTS
Release: 18.04
Codename: bionic

~# uname -a
Linux WS 4.15.0-54-generic #58-Ubuntu SMP Mon Jun 24 10:55:12 UTC 2019 i686 i686 i686 GNU/Linux

~# lspci -nn -k -d ::0300
00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:3e90]
 Subsystem: ASUSTeK Computer Inc. Device [1043:8694]
 Kernel driver in use: i915
 Kernel modules: i915

mesa: 19.0.2-1ubuntu1.1~18.04.1

X crashes with message:
 i965: Failed to submit batchbuffer: Invalid argument

The same issue was after updating mesa from 18.0 to 18.2:
https://bugs.launchpad.net/ubuntu/+source/mesa/+bug/1815172

I have tried the same fix and it works for me:
https://launchpadlibrarian.net/410418147/mesa_18.2.8-0ubuntu0~18.10.1_18.2.8-0ubuntu0~18.10.2.diff.gz

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mesa (Ubuntu):
status: New → Confirmed
Timo Aaltonen (tjaalton) wrote :

okay, adding the revert again.. this should've been fixed in the kernel after 18.04.2 but that didn't happen

since we don't support 32bit installs in newer releases, bionic is the only one that will get this

Changed in mesa (Ubuntu Bionic):
assignee: nobody → Timo Aaltonen (tjaalton)
status: New → In Progress
Changed in mesa (Ubuntu):
status: Confirmed → Won't Fix
Timo Aaltonen (tjaalton) wrote :

please test 19.0.8 from ppa:ubuntu-x-swat/updates once it has built

I have just updated from ppa:ubuntu-x-swat/updates, now everything is fine on i386 Ubuntu 18.04

~# apt-cache policy libgl1-mesa-glx
libgl1-mesa-glx:
  Installed: 19.0.8-0ubuntu0~18.04.1
  Candidate: 19.0.8-0ubuntu0~18.04.1
  Version table:
 *** 19.0.8-0ubuntu0~18.04.1 500
        500 http://ppa.launchpad.net/ubuntu-x-swat/updates/ubuntu bionic/main i386 Packages
        100 /var/lib/dpkg/status

Timo Aaltonen (tjaalton) wrote :

cool, the fix is on the SRU queue now, waiting for review

Changed in mesa (Ubuntu Bionic):
importance: Undecided → Critical

Hello Roman, or anyone else affected,

Accepted mesa into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mesa/19.0.2-1ubuntu1.1~18.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in mesa (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic
Timo Aaltonen (tjaalton) wrote :

btw, would be helpful to see if installing linux-image-hwe-edge together with the bad mesa would still work.. so, ppa-purge the ppa, then install the edge kernel, reboot

I have just updated mesa from bionic-proposed and now everything is fine on i386 Ubuntu 18.04:

~# apt-cache policy libgl1-mesa-glx
libgl1-mesa-glx:
  Встановлено: 19.0.2-1ubuntu1.1~18.04.2
  Кандидат: 19.0.2-1ubuntu1.1~18.04.2
  Таблиця версій:
 *** 19.0.2-1ubuntu1.1~18.04.2 500
        500 http://archive.ubuntu.com/ubuntu bionic-proposed/main i386 Packages
        100 /var/lib/dpkg/status

I have also tried different kernels with bad mesa 19.0.2-1ubuntu1.1~18.04.1 from bionic-updates:

linux-generic (4.15.0-54-generic) - problem exists
linux-generic-hwe-18.04 (4.18.0-25-generic) - problem exists
linux-generic-hwe-18.04-edge (5.0.0-20-generic) - everything is fine

With mesa 19.0.2-1ubuntu1.1~18.04.1 from bionic-proposed everything is fine on all these kernels

tags: added: verification-done-bionic
removed: verification-needed
tags: removed: verification-needed-bionic
Timo Aaltonen (tjaalton) wrote :

excellent, thanks for confirming!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mesa - 19.0.2-1ubuntu1.1~18.04.2

---------------
mesa (19.0.2-1ubuntu1.1~18.04.2) bionic; urgency=medium

  * i965-revert-enabling-softpin.diff: Don't enable softpin, causes
    issues on 32bit installs. (LP: #1836721)

 -- Timo Aaltonen <email address hidden> Thu, 18 Jul 2019 18:44:14 +0300

Changed in mesa (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for mesa has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers