i965_drv_video.so doesn't load any more if a Wayland server is present [failed to resolve wl_drm_interface(): /lib/x86_64-linux-gnu/libEGL_mesa.so.0: undefined symbol: wl_drm_interface]

Bug #1813131 reported by Daniel van Vugt on 2019-01-24
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Libva
Fix Released
Unknown
intel-vaapi-driver (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
libva (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
mesa (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned

Bug Description

If a Wayland server is present (anywhere on the system including even the gdm3 login screen) then i965_drv_video.so fails to initialize:

$ vainfo
libva info: VA-API version 1.3.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_1_2
error: failed to resolve wl_drm_interface(): /lib/x86_64-linux-gnu/libEGL_mesa.so.0: undefined symbol: wl_drm_interface
libva error: /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so init failed
libva info: va_openDriver() returns -1
vaInitialize failed with error code -1 (unknown libva error),exit

$ mpv bbb_sunflower_2160p_60fps_normal.mp4
Playing: bbb_sunflower_2160p_60fps_normal.mp4
 (+) Video --vid=1 (*) (h264 3840x2160 60.000fps)
 (+) Audio --aid=1 (*) (mp3 2ch 48000Hz)
     Audio --aid=2 (*) (ac3 6ch 48000Hz)
File tags:
 Artist: Blender Foundation 2008, Janus Bager Kristensen 2013
 Comment: Creative Commons Attribution 3.0 - http://bbb3d.renderfarming.net
 Composer: Sacha Goedegebure
 Genre: Animation
 Title: Big Buck Bunny, Sunflower version
error: failed to resolve wl_drm_interface(): /lib/x86_64-linux-gnu/libEGL_mesa.so.0: undefined symbol: wl_drm_interface
[vaapi] libva: /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so init failed

Meanwhile, it continues to work after you have logged into a Xorg session.

ProblemType: Bug
DistroRelease: Ubuntu 19.04
Package: i965-va-driver 2.2.0-0ubuntu1
ProcVersionSignature: Ubuntu 4.18.0-11.12-generic 4.18.12
Uname: Linux 4.18.0-11-generic x86_64
ApportVersion: 2.20.10-0ubuntu19
Architecture: amd64
Date: Thu Jan 24 16:54:21 2019
InstallationDate: Installed on 2018-12-04 (51 days ago)
InstallationMedia: Ubuntu 19.04 "Disco Dingo" - Alpha amd64 (20181203)
SourcePackage: intel-vaapi-driver
UpgradeStatus: No upgrade log present (probably fresh install)

Daniel van Vugt (vanvugt) wrote :
summary: i965_drv_video.so doesn't load any more if a Wayland server is present
+ [failed to resolve wl_drm_interface(): /lib/x86_64-linux-
+ gnu/libEGL_mesa.so.0: undefined symbol: wl_drm_interface]
Timo Aaltonen (tjaalton) wrote :

it's a bug in the mesa build which is using meson now, it doesn't link with libwayland_drm, not sure why

affects: intel-vaapi-driver (Ubuntu) → mesa (Ubuntu)
Timo Aaltonen (tjaalton) wrote :
affects: mesa (Ubuntu) → intel-vaapi-driver (Ubuntu)
Timo Aaltonen (tjaalton) wrote :

probably needs a newer libva too

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in intel-vaapi-driver (Ubuntu):
status: New → Confirmed
Changed in libva (Ubuntu):
status: New → Confirmed
Sebastian Ramacher (s-ramacher) wrote :

Fixed in 2.4.0-1.

Changed in libva (Ubuntu):
status: Confirmed → Fix Released
Doug McMahon (mc3man) wrote :

Is a newer intel-vaapi-driver package planed?
(- currently in Debian Sid & does fix the issue in a wayland session..

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package intel-vaapi-driver - 2.3.0-0ubuntu1

---------------
intel-vaapi-driver (2.3.0-0ubuntu1) disco; urgency=medium

  * Merge with Debian, remaining changes:
    - use upstream tarball with shader support

 -- Timo Aaltonen <email address hidden> Tue, 12 Mar 2019 14:15:20 +0200

Changed in intel-vaapi-driver (Ubuntu):
status: Confirmed → Fix Released
Daniel van Vugt (vanvugt) wrote :

The bug is still present in i965-va-driver 2.3.0-0ubuntu1 on disco.

Changed in intel-vaapi-driver (Ubuntu):
status: Fix Released → Confirmed
Changed in libva (Ubuntu):
status: Fix Released → Confirmed
Doug McMahon (mc3man) wrote :

The ubuntu package doesn't include needed patch, i.e
0004-Check-the-interface-from-libva-first.patch

Apply that and it'll work fine..

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package intel-vaapi-driver - 2.3.0-0ubuntu2

---------------
intel-vaapi-driver (2.3.0-0ubuntu2) disco; urgency=medium

  * Restore debian/patches, disable all but an upstream commit to fix
    loading on wayland. (LP: #1813131)

 -- Timo Aaltonen <email address hidden> Wed, 13 Mar 2019 09:25:05 +0200

Changed in intel-vaapi-driver (Ubuntu):
status: Confirmed → Fix Released
Changed in libva:
status: Unknown → Fix Released
Changed in libva (Ubuntu):
status: Confirmed → Fix Released
Cameron Gutman (cgutman) wrote :

This bug now affects Bionic (and the core18 snap as a result) after picking up Mesa 19 from Disco in the 18.04.3 HWE release.

$ vainfo
libva info: VA-API version 1.1.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_1_1
error: failed to resolve wl_drm_interface(): /usr/lib/x86_64-linux-gnu/libEGL_mesa.so.0: undefined symbol: wl_drm_interface
libva error: /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so init failed
libva info: va_openDriver() returns -1
vaInitialize failed with error code -1 (unknown libva error),exit

$ glxinfo -B
name of display: :0
display: :0 screen: 0
direct rendering: Yes
Extended renderer info (GLX_MESA_query_renderer):
    Vendor: Intel Open Source Technology Center (0x8086)
    Device: Mesa DRI Intel(R) UHD Graphics 620 (Kabylake GT2) (0x5917)
    Version: 19.0.2
    Accelerated: yes
    Video memory: 3072MB
    Unified memory: yes
    Preferred profile: core (0x1)
    Max core profile version: 4.5
    Max compat profile version: 3.0
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.2
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) UHD Graphics 620 (Kabylake GT2)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 19.0.2
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 3.0 Mesa 19.0.2
OpenGL shading language version string: 1.30
OpenGL context flags: (none)

OpenGL ES profile version string: OpenGL ES 3.2 Mesa 19.0.2
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20

tags: added: bionic regression-update
Changed in mesa (Ubuntu):
status: New → Confirmed
Timo Aaltonen (tjaalton) wrote :

so libva/intel-vaapi-driver needs fixing in bionic now

Changed in mesa (Ubuntu):
status: Confirmed → Invalid
Changed in mesa (Ubuntu Bionic):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.