Mesa 18.2.8 stable release

Bug #1811225 reported by Timo Aaltonen on 2019-01-10
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
mesa (Ubuntu)
Undecided
Timo Aaltonen
Bionic
Undecided
Timo Aaltonen
Cosmic
Undecided
Unassigned

Bug Description

[Impact]
Ubuntu 18.10 shipped with mesa 18.2.2, and deserves to get the last point release of the series. This will also be backported to 18.04 as part of the HWE stack update.

Upstream changes:

18.2.3
- Different patches for the DirectX9 and DRI state trackers.
- Several fixes and workarounds for different games, inlcuding RAGE, Yakuza and The Evil Within, Wolfenstein The Old Blood ARMA 3, or No Mans Sky.
- A bunch of fixes for different drivers, including r600, nouveau, radeonsi, anv, radv, virgl, i965, nvc0 or nv50. Worth to mention a fix for GPU hangs in
Radeonsi.
- State Trackers also get different fixes and corrections.
- Finally, fixes for GLSL and NIR are also in this queue.

18.2.4
- Different fixes for different drivers: freedreno, radeonsi, swr, anv and radv.
- Also there are fixes for ac, gallium, spirv and blorp.

18.2.5
- A patch for nine state tracker that fixes several crashes using nine's
thread_submit feature. There are other patches to other state trackers.
- A couple of patches for Meson build system, as well as for autotools.
- In the drivers side, there are a couple of fixes for RADV, one regarding
subgroups and another regarding conditional rendering. There are also fixes for virgl, r600, and i965.
- Finally, the queue contains a couple of fixes for NIR, Wayland, and other
components.

18.2.6
- Several patches fixing leaks in glsl, winsys and r600.
- Improvements in the scripts that helps in preparing releases.
- Added PCI IDs for Amber Lake and Whiskey Lake.
- Fixes for radv, anv, i965 and vc4 drivers.
- A couple of fixes in NIR backend.
- Finally, several fixes in meson build system.

18.2.7
- Several patches fixing leaks in glsl, winsys and r600.
- Improvements in the scripts that helps in preparing releases.
- Added PCI IDs for Amber Lake and Whiskey Lake.
- Fixes for radv, anv, i965 and vc4 drivers.
- A couple of fixes in NIR backend.
- Finally, several fixes in meson build system.

18.2.8
- Several fixes in Meson build system.
- Also several fixes for st/nine subcomponent.
- Patch for RADV driver that fixes a hang in Yakuza using DXVK.
- There are also fixes for Virgl driver.
- Added PCI IDs for VegaM, Vega20 and Vega10.

[Test Case]
Check on intel/radeon hw that things still work fine.

[Regression potential]
Mesa stable releases are tested by vendor CI systems, this is the last of the series so should be safe to update to.

Timo Aaltonen (tjaalton) on 2019-01-10
Changed in mesa (Ubuntu):
status: New → Fix Released
Timo Aaltonen (tjaalton) on 2019-01-10
description: updated

Hello Timo, or anyone else affected,

Accepted mesa into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mesa/18.2.8-0ubuntu0~18.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in mesa (Ubuntu Cosmic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-cosmic
Will Cooke (willcooke) on 2019-02-05
Changed in mesa (Ubuntu):
assignee: nobody → Timo Aaltonen (tjaalton)
Timo Aaltonen (tjaalton) on 2019-02-05
Changed in mesa (Ubuntu Bionic):
assignee: nobody → Timo Aaltonen (tjaalton)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mesa (Ubuntu Bionic):
status: New → Confirmed
Łukasz Zemczak (sil2100) wrote :

Hello Timo, or anyone else affected,

Accepted mesa into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mesa/18.2.8-0ubuntu0~18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in mesa (Ubuntu Bionic):
status: Confirmed → Fix Committed
tags: added: verification-needed-bionic
Adam Conrad (adconrad) wrote :

Hello Timo, or anyone else affected,

Accepted mesa into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mesa/18.2.8-0ubuntu0~18.10.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Nataraj (incoming-ubuntu) wrote :

Tested mesa 18.2.8 from bionic-proposed and the fix worked for the problem I was having with vlc.

Adam Conrad (adconrad) wrote :

Hello Timo, or anyone else affected,

Accepted mesa into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mesa/18.2.8-0ubuntu0~18.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers