FFE: 18.2.x for cosmic

Bug #1792873 reported by Timo Aaltonen on 2018-09-17
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
mesa (Ubuntu)
Medium
Unassigned

Bug Description

Mesa 18.2.0 was recently released after several delays, but at least it doesn't have any known regressions on Intel hw. We tend to get the latest major version in the devel series ~2 weeks after FF, but since a month has passed now I thought it would be best to file an actual FFE request.

We'd also build it against LLVM 7, which is about to be released. Together these provide support for AMD Vega20 (kernel support still needed) among other things.

New features from mesa upstream reldocs:

OpenGL 4.3 on virgl
OpenGL 4.4 Compatibility profile on radeonsi
OpenGL ES 3.2 on radeonsi and virgl
GL_ARB_ES3_2_compatibility on radeonsi
GL_ARB_fragment_shader_interlock on i965
GL_ARB_sample_locations and GL_NV_sample_locations on nvc0 (GM200+)
GL_ANDROID_extension_pack_es31a on radeonsi.
GL_KHR_texture_compression_astc_ldr on radeonsi
GL_NV_conservative_raster and GL_NV_conservative_raster_dilate on nvc0 (GM200+)
GL_NV_conservative_raster_pre_snap_triangles on nvc0 (GP102+)
multisampled images on nvc0 (GM107+) (now supported on GF100+)

Timo Aaltonen (tjaalton) on 2018-09-17
Changed in mesa (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
tags: added: upgrade-software-version
Sebastien Bacher (seb128) wrote :

+1 from desktop team, we would like to see that update in cosmic

Timo Aaltonen (tjaalton) wrote :

fwiw it's available on ppa:canonical-x/x-staging and I've been running a RC for some weeks now on my laptop without issues.

18.2.1 was released today and I'll push it there soon.

Timo Aaltonen (tjaalton) on 2018-09-24
Changed in mesa (Ubuntu):
status: Triaged → New
Łukasz Zemczak (sil2100) wrote :

I would like to wait with this until the new 18.2.1 version builds. Could you perform some upgrade testing on it and leave a comment about how it went? I'll pick this up tomorrow and we'll decide then.

The LLVM 7 part seems like a separate thing though? Since it still doesn't seem to be available, I guess it would require another FFe/NEW, I suppose? Seems a bit bigger, especially so close to release.

Timo Aaltonen (tjaalton) wrote :

LLVM 7 is the default in cosmic :)

and mesa 18.2.1 is built now, installs fine from the ppa

Łukasz Zemczak (sil2100) wrote :

Duh, I blame the source naming change (previously it was llvm-toolchain-6.0, now it's just -7 instead of -7.0, ugh). Anyway, nevermind me!

I think I'm fine with the changes introduced and the testing so far. It's always better to have a more up-to-date stack. I also confirmed with Adam that we're ok with it. So: approving the FFe.

Changed in mesa (Ubuntu):
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mesa - 18.2.1-1ubuntu1

---------------
mesa (18.2.1-1ubuntu1) cosmic; urgency=medium

  * Merge from Debian experimental. (LP: #1714178, #1792873)
  * glvnd-fix-a-segfault-in-eglgetprocaddess.diff: Dropped, upstream.

mesa (18.2.1-1) experimental; urgency=medium

  * New upstream release.
  * control: Add libd3dadapter9-mesa to -dev depends.
  * control: Fix libd3dadapter9-mesa-dev section, and drop
    shlibs:Depends.

mesa (18.2.0-3) experimental; urgency=medium

  * control, rules: Nine needs llvmpipe, and also makes sense to build it
    only on archs that have wine.

mesa (18.2.0-2) experimental; urgency=medium

  * control: Bump build-dep on libxcb-dri3-dev and libxcb-present-dev to
    1.13. (Closes: #908827)
  * control: Build-depend on x11proto-dev, modify libegl1-mesa-dev and
    libgl1-mesa-dev depends.
  * Migrate to llvm/clang-7.
  * Enable gallium D3D state tracker, thanks Antonio Russo and Andrew
    Cook! (Closes: #863972)
  * rules: Enable v3d on arm. Thanks, Fabio Pedretti!
  * rules: Drop enabling texture float, it's enabled by default now.

mesa (18.2.0-1) experimental; urgency=medium

  * New upstream release.

mesa (18.2.0~rc4-1) experimental; urgency=medium

  * New upstream release candidate.
  * control: Add libxrandr-dev and libwayland-egl-backend-dev to build-
    depends.

mesa (18.1.8-1) unstable; urgency=medium

  * New upstream release.

mesa (18.1.7-1) unstable; urgency=medium

  * New upstream release.
  * libglx-mesa0: Add Breaks: glx-diversions (<< 0.8.4~) (Closes:
    #903929).

mesa (18.1.6-1) unstable; urgency=medium

  * New upstream release.
    - Fixes white screen when running Xfwm4 with compositing
      (Closes: #901789).
  * Drop glvnd-fix-gl-dot-pc.patch, fixed upstream (0c927e8da9e)
    (Closes: #896447).

 -- Timo Aaltonen <email address hidden> Tue, 25 Sep 2018 23:26:15 +0300

Changed in mesa (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers