Applications block on eglswapBuffers due to buggy mesa version

Bug #1774170 reported by Mohamed Sharaf-El-Deen on 2018-05-30
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mesa (Ubuntu)
High
Unassigned
Bionic
High
Unassigned

Bug Description

[Impact]
The mesa version that is available after installing packages has a bug that leads to wayland applications blocking on eglSwapBuffers if egl swap interval is set to Zero.

Ubuntu version: 18.04 LTS
Currently available mesa version for installation: 18.0.0~rc5

Versions where the bug is fixed:
17.3.8, 18.0.2, 18.1.0, or later

[Test case]
More details about the bug, how to reproduce it and the right mesa versions to use in here:
https://bugs.freedesktop.org/show_bug.cgi?id=106719

Would be so good if it is possible to provide one of the mesa versions where the problem does not exist as a package for installation.

Thanks

Output from running:
apt-cache policy libegl-mesa0

libegl-mesa0:
  Installed: 18.0.0~rc5-1ubuntu1
  Candidate: 18.0.0~rc5-1ubuntu1
  Version table:
 *** 18.0.0~rc5-1ubuntu1 500
        500 http://us.archive.ubuntu.com/ubuntu bionic/main amd64 Packages
        100 /var/lib/dpkg/status

[Regression potential]
none known, and we're SRUing 18.0.5 which is the last one of the series so shouldn't have regressions caused by earlier bugfixes..

Timo Aaltonen (tjaalton) on 2018-06-04
Changed in mesa (Ubuntu):
status: New → Fix Released
description: updated

Hello Mohamed, or anyone else affected,

Accepted mesa into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mesa/18.0.5-0ubuntu0~18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in mesa (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic

Problem is fixed. Thanks for your support.
Tested mesa package version: 18.0.5-0ubuntu0~18.04.1

tags: added: verification-done-bionic
removed: verification-needed verification-needed-bionic
Changed in mesa (Ubuntu):
importance: Undecided → High
Changed in mesa (Ubuntu Bionic):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mesa - 18.0.5-0ubuntu0~18.04.1

---------------
mesa (18.0.5-0ubuntu0~18.04.1) bionic; urgency=medium

  * New upstream release. (LP: #1772607)
    - fix wayland apps blocking on eglswapBuffers (LP: #1774170)

 -- Timo Aaltonen <email address hidden> Tue, 22 May 2018 11:31:23 +0300

Changed in mesa (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for mesa has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers