Unable to install mesa-opencl-icd because of unmet dependencies on Xenial

Bug #1743018 reported by Norbert on 2018-01-12
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
mesa (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Timo Aaltonen

Bug Description

Steps to reproduce:
1. Install Ubuntu 16.04 LTS
2. Try to install `mesa-opencl-icd` with

$ sudo apt-get install mesa-opencl-icd
[sudo] password for user:
Reading package lists... Done
Building dependency tree
Reading state information... Done

Expected results:
* mesa-opencl-icd is installed successfully

Actual results:
* got errors as follow

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 mesa-opencl-icd : Depends: libclc-r600 (>= 0.2.0+git20170330-3) but it is not going to be installed
                   Depends: libclc-amdgcn (>= 0.2.0+git20170330-3) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Note: inspired by this AskUbuntu question - https://askubuntu.com/q/995274/66509 .

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: mesa-opencl-icd (not installed)
ProcVersionSignature: Ubuntu 4.4.0-109.132-generic 4.4.98
Uname: Linux 4.4.0-109-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.15
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,mousepoll,move,gnomecompat,wall,regex,place,resize,snap,session,imgpng,vpswitch,grid,unitymtgrabhandles,animation,expo,workarounds,ezoom,staticswitcher,fade,scale,unityshell]
CompositorRunning: None
CurrentDesktop: MATE
Date: Fri Jan 12 21:22:22 2018
DistUpgraded: 2017-04-16 02:19:02,541 DEBUG Running PostInstallScript: './xorg_fix_proprietary.py'
DistroCodename: xenial
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. 3rd Gen Core processor Graphics Controller [1043:2135]
InstallationDate: Installed on 2014-02-07 (1434 days ago)
InstallationMedia: Ubuntu 12.04.4 LTS "Precise Pangolin" - Release amd64 (20140204)
MachineType: ASUSTeK COMPUTER INC. UX32A
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-109-generic root=UUID=1e3c78e2-1a6e-4afe-8249-40fe7fa81a86 ro quiet splash vt.handoff=7
SourcePackage: mesa
UpgradeStatus: Upgraded to xenial on 2017-04-15 (271 days ago)
dmi.bios.date: 02/12/2014
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: UX32A.216
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: UX32A
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK COMPUTER INC.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrUX32A.216:bd02/12/2014:svnASUSTeKCOMPUTERINC.:pnUX32A:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnUX32A:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
dmi.product.name: UX32A
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK COMPUTER INC.
version.compiz: compiz 1:0.9.12.2+16.04.20160823-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.83-1~16.04.1
version.libgl1-mesa-dri: libgl1-mesa-dri 17.2.4-0ubuntu1~16.04.2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 17.2.4-0ubuntu1~16.04.2
version.xserver-xorg-core: xserver-xorg-core 2:1.18.4-0ubuntu0.7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.1-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.7.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20160325-1ubuntu1.2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.12-1build2
xserver.bootTime: Fri Jan 12 20:32:41 2018
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.18.4-0ubuntu0.7
xserver.video_driver: intel

Norbert (nrbrtx) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mesa (Ubuntu):
status: New → Confirmed
Timo Aaltonen (tjaalton) wrote :

affects only xenial, the dependency should be relaxed

Changed in mesa (Ubuntu):
status: Confirmed → Invalid
Changed in mesa (Ubuntu Xenial):
assignee: nobody → Timo Aaltonen (tjaalton)
status: New → In Progress

Hello Norbert, or anyone else affected,

Accepted mesa into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mesa/17.2.4-0ubuntu1~16.04.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in mesa (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-xenial
Pavel Samarin (zuoverture) wrote :

Hello, Timo. I can confirm that mesa-opencl-icd from xenial-proposed installs without problems.

mesa-opencl-icd/xenial-proposed,now 17.2.4-0ubuntu1~16.04.4 amd64 [installed]
  free implementation of the OpenCL API -- ICD runtime

tags: added: verification-done verification-done-xenial
removed: verification-needed verification-needed-xenial
Norbert (nrbrtx) wrote :

I can confirm that it is installing normally.

$ apt-cache policy mesa-opencl-icd
mesa-opencl-icd:
  Installed: 17.2.4-0ubuntu1~16.04.4
  Candidate: 17.2.4-0ubuntu1~16.04.4
  Version table:
 *** 17.2.4-0ubuntu1~16.04.4 500
        500 http://archive.ubuntu.com/ubuntu xenial-proposed/universe amd64 Packages
        100 /var/lib/dpkg/status
     17.2.4-0ubuntu1~16.04.2 500
        500 http://ru.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 Packages
     11.2.0-1ubuntu2 500
        500 http://ru.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages

Thank you, Timo!

tags: added: unmetdeps
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mesa - 17.2.4-0ubuntu1~16.04.4

---------------
mesa (17.2.4-0ubuntu1~16.04.4) xenial; urgency=medium

  * control: Relax mesa-opencl-icd dependency on libclc. (LP: #1743018)

mesa (17.2.4-0ubuntu1~16.04.3) xenial; urgency=medium

  * i965-disable-l3-cache-alloc-for-ext-buffers.diff:
    - Replaced with five backported commits from upstream
      (LP: #1727401, #1735594)

 -- Timo Aaltonen <email address hidden> Sat, 13 Jan 2018 09:06:08 +0200

Changed in mesa (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for mesa has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Stephen (d557charger) wrote :

I am experiencing this same but on 18.04 Bionic Beaver. Could this patch be applied there as well?

Timo Aaltonen (tjaalton) wrote :

that's not possible, you have some other issue

Norbert (nrbrtx) wrote :

64-bit Bionic Beaver with all current updates - `mesa-opencl-icd` installed without problems:

$ apt-cache policy mesa-opencl-icd
mesa-opencl-icd:
  Installed: 17.2.4-0ubuntu2
  Candidate: 17.2.4-0ubuntu2
  Version table:
 *** 17.2.4-0ubuntu2 500
        500 http://ru.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers