New bugfix release 17.2.4

Bug #1727390 reported by Timo Aaltonen on 2017-10-25
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mesa (Ubuntu)
Undecided
Timo Aaltonen
Xenial
Undecided
Unassigned
Artful
Undecided
Unassigned

Bug Description

[Impact]

A new upstream bugfix release is available. Release note diff compared to 17.2.2:

"Mesa 17.2.3 is now available.

In this release we have:

The Vulkan drivers ANV and RADV have multiple small fixes.

The EGL code has improved handling of the new wl_dmabuf codepath.

SWR no longer crashes when checking environment variables.

Other gallium drivers have also seen updates - freedreno, nouveau and
radeonsi. The gallivm module, used by llvmpipe et al. has gained little
endian PPC64 fixes.

The VA and VDPAU state-trackers have seems improvements handling
interlaced videos.

We're using python3 compatible constructs which gives us SCons 3.0
support."

"Mesa 17.2.4 is now available.

In this release we have:

In Mesa Core we have included a change to prevent KOTOR from breaking
when in combination with the ATI fragment shader extension.
Additionally, NIR has also received a correction.

Mesa's state tracker has gotten a patch to avoid leaks in certain
situations like when resizing a window.

Intel drivers have received several fixes. The compiler has gotten a
couple, while anv also received one. i965 got a patch to avoid VA-
API, Beignet and other contexts in the system to break when in
combination with previous versions of Mesa 17.2.x.

AMD's compiler has received a couple of fixes while radv has also
received another couple, including one to avoid a hang due to an
overflow on huge textures.

Broadcom's vc4 has corrected a problem when compiling with Android's
clang.

clover has also seen fixed a problem compiling after a specific clang
revision.

Vulkan's WSI has gotten plugged a memory leak for X11."

[Test case]

Test typical use cases on the most common hw/driver combinations:
intel/i965
nvidia/nouveau
radeon/radeonsi

[Regression potential]

These releases are tested against compliance, bugfix releases in particular have minimal risk of regressing anything major at least.

Timo Aaltonen (tjaalton) on 2017-10-25
summary: - New bugfix release
+ New bugfix release 17.2.3
Timo Aaltonen (tjaalton) on 2017-11-07
summary: - New bugfix release 17.2.3
+ New bugfix release 17.2.4
Timo Aaltonen (tjaalton) on 2017-11-07
description: updated
Timo Aaltonen (tjaalton) on 2017-11-08
Changed in mesa (Ubuntu):
assignee: nobody → Timo Aaltonen (tjaalton)
Luca Tansini (tansini13) on 2017-11-13
Changed in mesa (Ubuntu):
status: New → Fix Released
Boaz Dodin (bdcomp) wrote :

Mesa 17.2.5 released with some additional fixes:
https://www.mesa3d.org/relnotes/17.2.5.html

summary: - New bugfix release 17.2.4
+ New bugfix release 17.2.5
Timo Aaltonen (tjaalton) wrote :

but it's 17.2.4 that was uploaded and what this bug is about

summary: - New bugfix release 17.2.5
+ New bugfix release 17.2.4
Changed in mesa (Ubuntu):
status: Fix Released → In Progress
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers