Installation of libgles1-mesa (12.0.6-0ubuntu0.16.04.1) failed

Bug #1709823 reported by Oliver Wendland on 2017-08-10
60
This bug affects 10 people
Affects Status Importance Assigned to Milestone
mesa (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Timo Aaltonen

Bug Description

[Impact]
Installation of libgles1-mesa (12.0.6-0ubuntu0.16.04.1) on Ubuntu 16.04 LTS failed - it needs the package libglapi-mesa (12.0.6-0buntu0.16.04.1), which does not exist. The current version of libglapi-mesa is 17.0.7-0ubuntu0.16.04.1 (xenial-updates), which does not support the installation of libgles1-mesa.

[Test case]
Try to install the package from
https://01.org/linuxgraphics/downloads/intel-graphics-update-tool-linux-os-v2.0.2

[Regression potential]
none, it just adds a dummy package to fix broken/unnecessary dependencies in 3rd party packages

Oliver Wendland (oleander) wrote :

For further explanation: I need the package libgles1-mesa, because I want to update the graphics driver on my HP Elitebook 8440p. For this purpose, I downloaded the "INTEL GRAPHICS UPDATE TOOL FOR LINUX* OS V2.0.2" from 01.org, which at least requires libgles1-mesa.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mesa (Ubuntu):
status: New → Confirmed
Timo Aaltonen (tjaalton) wrote :

not an issue for other than xenial

Changed in mesa (Ubuntu):
status: Confirmed → Invalid
Changed in mesa (Ubuntu Xenial):
assignee: nobody → Timo Aaltonen (tjaalton)
status: New → Triaged
description: updated
Timo Aaltonen (tjaalton) wrote :

fix uploaded to the queue

Changed in mesa (Ubuntu Xenial):
status: Triaged → In Progress

Hello Oliver, or anyone else affected,

Accepted mesa into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mesa/17.0.7-0ubuntu0.16.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in mesa (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-xenial
Oliver Wendland (oleander) wrote :

The installation of the package libgles1-mesa 17.0.7-0ubuntu0.16.04.2 on my system worked without any issue!!!

Afterwards the "intel-graphics-update-tool-linux-os-v2.0.2" ran successfully as well.

Great work! Many, many thanks for your kind support!!!

tags: added: verification-done-xenial
removed: verification-needed-xenial
Thomas (t.c) wrote :

It seams to me not fixed or again broken:

root@vdr:~# LANG=C apt-get install libgles1-mesa
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgles1-mesa : Depends: libglapi-mesa (= 12.0.6-0ubuntu0.16.04.1) but 17.0.7-0ubuntu0.16.04.1 is to be installed
E: Unable to correct problems, you have held broken packages.

root@vdr:~# LANG=C apt-cache policy libgles1-mesa
libgles1-mesa:
  Installed: (none)
  Candidate: 12.0.6-0ubuntu0.16.04.1
  Version table:
     12.0.6-0ubuntu0.16.04.1 500
        500 http://de.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
     11.2.0-1ubuntu2 500
        500 http://de.archive.ubuntu.com/ubuntu xenial/main amd64 Packages

root@vdr:~# LANG=C apt-cache policy libglapi-mesa
libglapi-mesa:
  Installed: 17.0.7-0ubuntu0.16.04.1
  Candidate: 17.0.7-0ubuntu0.16.04.1
  Version table:
 *** 17.0.7-0ubuntu0.16.04.1 500
        500 http://de.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     11.2.0-1ubuntu2 500
        500 http://de.archive.ubuntu.com/ubuntu xenial/main amd64 Packages

tags: added: verification-needed-xenial
removed: verification-done-xenial
Changed in mesa (Ubuntu Xenial):
status: Fix Committed → Confirmed
Dimitri John Ledkov (xnox) wrote :

Attempted to install libgles1-mesa and it failed.

Enabled proposed and it passed.

Verification done:

# apt install libgles1-mesa
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgles1-mesa : Depends: libglapi-mesa (= 12.0.6-0ubuntu0.16.04.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

# sudo nano /etc/apt/sources.list
# sudo apt update
...
# apt install libgles1-mesa
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following package was automatically installed and is no longer required:
  libfreetype6
Use 'apt autoremove' to remove it.
The following NEW packages will be installed:
  libgles1-mesa
0 upgraded, 1 newly installed, 0 to remove and 30 not upgraded.
Need to get 3310 B of archives.
After this operation, 14.3 kB of additional disk space will be used.
Get:1 http://archive.ubuntu.com/ubuntu xenial-proposed/main amd64 libgles1-mesa all 17.0.7-0ubuntu0.16.04.2 [3310 B]
Fetched 3310 B in 0s (4140 B/s)
YSelecting previously unselected package libgles1-mesa.
(Reading database ... 25532 files and directories currently installed.)
Preparing to unpack .../libgles1-mesa_17.0.7-0ubuntu0.16.04.2_all.deb ...
Unpacking libgles1-mesa (17.0.7-0ubuntu0.16.04.2) ...
Setting up libgles1-mesa (17.0.7-0ubuntu0.16.04.2) ...

tags: added: verification-done verification-done-xenial
removed: verification-needed verification-needed-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mesa - 17.0.7-0ubuntu0.16.04.2

---------------
mesa (17.0.7-0ubuntu0.16.04.2) xenial; urgency=medium

  * control: Add a transitional package for libgles1-mesa. (LP:
    #1709823)

 -- Timo Aaltonen <email address hidden> Fri, 11 Aug 2017 00:51:18 +0300

Changed in mesa (Ubuntu Xenial):
status: Confirmed → Fix Released

The verification of the Stable Release Update for mesa has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers