Mesa 17.0.x stable release

Bug #1686344 reported by Timo Aaltonen on 2017-04-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mesa (Ubuntu)
Undecided
Unassigned
Zesty
Undecided
Unassigned

Bug Description

[Impact]

Mesa stable release for zesty & backport to xenial. Xenial needs newer libdrm from zesty. These are part of the hwe-16.04 stack refresh.

[Test case]

Install, run desktop session, test xonotic.

the important hw drivers to test:
- i965 (Intel)
- radeonsi (AMD)

[Regression potential]

Spec compliance test suites are already run by Intel and others, so feature regressions should not be possible. GLESv1 support has been dropped from the packaging though, but packages that depend on libgles1-mesa have been pushed to proposed to drop the dependency, see bug 1676845 (applies to xenial).

17.0.x has been available for xenial and yakkety users for a while, and so far no-one has complained about driver regressions.

[Other info]

Timo Aaltonen (tjaalton) on 2017-04-26
description: updated
Timo Aaltonen (tjaalton) on 2017-05-03
description: updated
Changed in libdrm (Ubuntu Zesty):
status: New → Invalid
description: updated
Timo Aaltonen (tjaalton) on 2017-05-04
no longer affects: libdrm (Ubuntu)
no longer affects: libdrm (Ubuntu Xenial)
no longer affects: libdrm (Ubuntu Zesty)
no longer affects: mesa (Ubuntu Xenial)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mesa - 17.0.5-0ubuntu1

---------------
mesa (17.0.5-0ubuntu1) artful; urgency=medium

  * New upstream bugfix release. (LP: #1686344)

 -- Timo Aaltonen <email address hidden> Thu, 04 May 2017 20:07:36 +0300

Changed in mesa (Ubuntu):
status: New → Fix Released

Hello Timo, or anyone else affected,

Accepted mesa into zesty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mesa/17.0.6-0ubuntu0.17.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in mesa (Ubuntu Zesty):
status: New → Fix Committed
tags: added: verification-needed
Chris Halse Rogers (raof) wrote :

Hello Timo, or anyone else affected,

Accepted mesa into zesty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mesa/17.0.7-0ubuntu0.17.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Timo Aaltonen (tjaalton) wrote :

tested to be fine on Intel Kabylake GT3 and AMD R7 260X (Bonaire)

As part of a recent change in the Stable Release Update verification policy we would like to inform that for a bug to be considered verified for a given release a verification-done-$RELEASE tag needs to be added to the bug where $RELEASE is the name of the series the package that was tested (e.g. verification-done-xenial). Please note that the global 'verification-done' tag can no longer be used for this purpose.

Thank you!

Bart Willemsen (b-willemsen8) wrote :

I ran this update on my Intel Haswell i7-4700MQ laptop. Tested it with a normal desktop session and didn't encounter any graphics related issues.

Timo Aaltonen (tjaalton) wrote :

marked as verified

also worth noting is that this version is already in xenial as part of the HWE stack update

tags: added: verification-done-zesty
removed: verification-needed
Bart Willemsen (b-willemsen8) wrote :

Thanks, I hope it can be rolled out soon since this release fixes a bug that affected me :)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mesa - 17.0.7-0ubuntu0.17.04.1

---------------
mesa (17.0.7-0ubuntu0.17.04.1) zesty; urgency=medium

  * New upstream bugfix release.
  * d/p/vulkan-mir.patch: Refreshed.

mesa (17.0.5-0ubuntu1) artful; urgency=medium

  * New upstream bugfix release. (LP: #1686344)

mesa (17.0.4-1ubuntu1) artful; urgency=medium

  * Merge from Debian.

mesa (17.0.4-1) experimental; urgency=medium

  * New upstrem release.

 -- Timo Aaltonen <email address hidden> Thu, 08 Jun 2017 10:54:05 +0300

Changed in mesa (Ubuntu Zesty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for mesa has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers