Mesa 12.0.6 - multiple important fixes, stable branch

Bug #1641017 reported by Boaz Dodin on 2016-11-11
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
mesa (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
Yakkety
Undecided
Timo Aaltonen

Bug Description

[Impact]
Mesa 12.0.5 is now available as a point release in the stable branch. Mesa has MRE for these.

The release contains multiple fixes amongst which:
The nouveau vdpau driver performance has been restored. The wayland-egl
module no longer crashes if the user calls eglDestroySurface and
wl_egl_window_destroy in the "wrong" order. libEGL correctly advertises
the EGL platforms available. Multiple fd leaks were addressed, which
could prevent rmmod of devices such as the DisplayLink drivers. Radeonsi
has gained noticeable performance by disabling ReZ. Interop between third
party OpenCL implementations and mesa's libGL/libEGL is back online...
and many more.

Full changelog:
https://lists.freedesktop.org/archives/mesa-dev/2016-November/135027.html

I am particularly interested in the RadeonSI performance boost:
https://lists.freedesktop.org/archives/mesa-dev/2016-October/131759.html
In real-world tests the boost is about 20% (Yay!) :
http://www.phoronix.com/scan.php?page=news_item&px=Mesa-Post-ReZ-Change-Benchmarks

[Test case]
Run the default desktop and maybe a game or two.

This release has been tested on xenial by the certification team on a set of machines, covering:
Intel Haswell
Intel Broadwell
Intel Skylake
AMD Mobility Radeon HD 5430/5450/5470

and they all passed the tests.

Once this is in -proposed, the community will be asked to test it on a wider range of devices.

[Regression potential]
yakkety: the release consists of cherry-picks from master, specifically selected as bugfixes. Regression potential should be low.

xenial: it's a bigger bump for xenial, but since yakkety already ships with this series the risk should be low

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mesa (Ubuntu):
status: New → Confirmed
Changed in mesa (Ubuntu Yakkety):
status: New → Confirmed
Timo Aaltonen (tjaalton) wrote :

zesty is still in limbo, gtk tests fail because of glibc or whatever, mesa is not to blame

description: updated
Timo Aaltonen (tjaalton) wrote :

package up for testing at ppa:tjaalton/test

Changed in mesa (Ubuntu Yakkety):
assignee: nobody → Timo Aaltonen (tjaalton)
Brian Murray (brian-murray) wrote :

The Test Case is rather incomplete for an SRU. Could you add some information about how the changes will be tested and we will ensure there are no regressions?

Thanks!

Changed in mesa (Ubuntu Yakkety):
status: Confirmed → Incomplete

zesty has 12.0.4, and 13.0.2 in proposed, closing

summary: - Mesa 12.0.4 - multiple important fixes, stable branch
+ Mesa 12.0.5 - multiple important fixes, stable branch
description: updated
Changed in mesa (Ubuntu Yakkety):
status: Incomplete → Confirmed
Changed in mesa (Ubuntu):
status: Confirmed → Fix Released
Timo Aaltonen (tjaalton) wrote :

Xenial added as a target, we will be providing unrenamed backports from now on.

description: updated
Boaz Dodin (bdcomp) wrote :

Timo - it looks like the packages been built and tested weeks ago in your ppa.

May I ask what are we waiting for?

As per regression potential, I suggest to release it now for Yakkety, and after several weeks of wider use without new issues, release to Xenial.

Timo Aaltonen (tjaalton) wrote :

I don't see any test results posted here. But I've heard elsewhere that there are some GPU hangs with radeon which is why 12.0.6 is about to be released.

There's not enough time to wait for weeks, 16.04.2 will be released soon (if not a week from now as scheduled) and this is needed there. And the packages have been on the SRU queue for some time now but no-one dared to ack them.

Hello Boaz, or anyone else affected,

Accepted mesa into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mesa/12.0.6-0ubuntu0.16.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in mesa (Ubuntu Yakkety):
status: Confirmed → Fix Committed
tags: added: verification-needed
Changed in mesa (Ubuntu Xenial):
status: New → Fix Committed
Adam Conrad (adconrad) wrote :

Hello Boaz, or anyone else affected,

Accepted mesa into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mesa/12.0.6-0ubuntu0.16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Boaz Dodin (bdcomp) on 2017-01-26
summary: - Mesa 12.0.5 - multiple important fixes, stable branch
+ Mesa 12.0.6 - multiple important fixes, stable branch
Timo Jyrinki (timo-jyrinki) wrote :

Everything seems to work on my Intel Broadwell laptop and a desktop with Radeon 7750 graphics card. With the former I've mostly run normal desktop stuff, heavy WebGL in Firefox + Chromium and some more basic OpenGL apps from the archives. With the latter I've run a variety of Steam games like Gone Home, Team Fortress 2, Bioshock: Infinite, Civilization V.

Timo Aaltonen (tjaalton) on 2017-02-06
tags: added: verification-done
removed: verification-needed
Robie Basak (racb) wrote :

Which package versions were tested? 12.0.6-0ubuntu0.16.04.1? 12.0.6-0ubuntu0.16.10.1? Something else?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mesa - 12.0.6-0ubuntu0.16.04.1

---------------
mesa (12.0.6-0ubuntu0.16.04.1) xenial; urgency=medium

  * New bugfix release. (LP: #1652564, #1652486)
  * Backport to xenial. (LP: #1643789)

mesa (12.0.4-2ubuntu1) zesty; urgency=medium

  * Merge from Debian
    - New upstream bugfix release. (LP: #1641017)
  * dri3-fix-totem-with-libva.diff: Dropped, upstream.

 -- Timo Aaltonen <email address hidden> Fri, 20 Jan 2017 00:22:11 +0200

Changed in mesa (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for mesa has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Boaz Dodin (bdcomp) wrote :

Chris, why the update was released only for Xenial?
Please do the same for Yakkety.

Boaz Dodin (bdcomp) wrote :

Timo/Chris, I am still wondering why it been released only for Xenial?..

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mesa - 12.0.6-0ubuntu0.16.10.1

---------------
mesa (12.0.6-0ubuntu0.16.10.1) yakkety; urgency=medium

  * New bugfix release. (LP: #1652486)
  * Backport to yakkety.

mesa (12.0.4-2ubuntu1) zesty; urgency=medium

  * Merge from Debian
    - New upstream bugfix release. (LP: #1641017)
  * dri3-fix-totem-with-libva.diff: Dropped, upstream.

mesa (12.0.4-2) unstable; urgency=medium

  * Limit new glx symbols to !hurd-any. Should fix FTBFS on hurd.

mesa (12.0.4-1) unstable; urgency=medium

  * New upstream release.
  * not-installed: wglext.h got dropped from the tarball.
  * mesa-common-dev: Remove mesa_glinterop.h, upstream doesn't install
    it anymore.
  * Update symbols of libegl1-mesa and libgl1-mesa-glx.

mesa (12.0.3-3) unstable; urgency=medium

  * Limit libgbm1 dependency to !hurd-any (Closes: #841774). Thanks,
    Samuel Thibault!

mesa (12.0.3-2) unstable; urgency=medium

  * control: Add libtxc-dxtn-s2tc as an alternative in libgl1-mesa-dri's
    Recommends (Closes: #839658).
  * control: Add strictly versioned dependency on libgbm1 to libegl1-
    mesa.

 -- Timo Aaltonen <email address hidden> Wed, 18 Jan 2017 16:41:11 +0200

Changed in mesa (Ubuntu Yakkety):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers