mesa FTBFS due to missing Requires in mirclient

Bug #1503450 reported by Tiago Stürmer Daitx on 2015-10-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mir
Fix Released
High
Tiago Stürmer Daitx
mesa (Ubuntu)
High
Robert Ancell
mir (Ubuntu)
Undecided
Unassigned

Bug Description

mesa currently FTBFS due to a missing mirclient dependency during build time.

Failed build at https://launchpad.net/ubuntu/+source/mesa/11.0.2-1ubuntu2/+build/8082519

Build log:
=======
/bin/bash ../../libtool --tag=CC --mode=compile gcc -DPACKAGE_NAME=\"Mesa\" -DPACKAGE_TARNAME=\"mesa\" -DPACKAGE_VERSION=\"11.0.2\" -DPACKAGE_STRING=\"Mesa\ 11.0.2\" -DPACKAGE_BUGREPORT=\"https://bugs.freedesktop.org/enter_bug.cgi\?product=Mesa\" -DPACKAGE_URL=\"\" -DPACKAGE=\"mesa\" -DVERSION=\"11.0.2\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=\".libs/\" -DYYTEXT_POINTER=1 -DHAVE___BUILTIN_BSWAP32=1 -DHAVE___BUILTIN_BSWAP64=1 -DHAVE___BUILTIN_CLZ=1 -DHAVE___BUILTIN_CLZLL=1 -DHAVE___BUILTIN_CTZ=1 -DHAVE___BUILTIN_EXPECT=1 -DHAVE___BUILTIN_FFS=1 -DHAVE___BUILTIN_FFSLL=1 -DHAVE___BUILTIN_POPCOUNT=1 -DHAVE___BUILTIN_POPCOUNTLL=1 -DHAVE___BUILTIN_UNREACHABLE=1 -DHAVE_FUNC_ATTRIBUTE_CONST=1 -DHAVE_FUNC_ATTRIBUTE_FLATTEN=1 -DHAVE_FUNC_ATTRIBUTE_FORMAT=1 -DHAVE_FUNC_ATTRIBUTE_MALLOC=1 -DHAVE_FUNC_ATTRIBUTE_PACKED=1 -DHAVE_FUNC_ATTRIBUTE_PURE=1 -DHAVE_FUNC_ATTRIBUTE_UNUSED=1 -DHAVE_FUNC_ATTRIBUTE_WARN_UNUSED_RESULT=1 -DHAVE_DLADDR=1 -DHAVE_CLOCK_GETTIME=1 -DHAVE_PTHREAD=1 -I. -I../../../../src/egl -D_FORTIFY_SOURCE=2 -I../../../../include -I../../../../src/egl/main -I../../../../src/gbm/main -I../../../../src -D__STDC_LIMIT_MACROS -D_GNU_SOURCE -DUSE_SSE41 -DNDEBUG -DTEXTURE_FLOAT_ENABLED -DUSE_X86_64_ASM -DHAVE_XLOCALE_H -DHAVE_SYS_SYSCTL_H -DHAVE_STRTOF -DHAVE_MKOSTEMP -DHAVE_DLOPEN -DHAVE_POSIX_MEMALIGN -DHAVE_LIBDRM -DGLX_USE_DRM -DHAVE_LIBUDEV -DGLX_INDIRECT_RENDERING -DGLX_DIRECT_RENDERING -DGLX_USE_TLS -DHAVE_ALIAS -DHAVE_DRI3 -DHAVE_MINCORE -DHAVE_LLVM=0x0306 -DMESA_LLVM_VERSION_PATCH=2 -fvisibility=hidden -I/usr/include/libdrm -D_EGL_NATIVE_PLATFORM=_EGL_PLATFORM_X11 -DHAVE_X11_PLATFORM -DHAVE_WAYLAND_PLATFORM -DHAVE_DRM_PLATFORM -DHAVE_MIR_PLATFORM -I/usr/include/mirplatform -I/usr/include/mircommon -I../../../../src/loader -I../../../../src/egl/drivers/dri2 -I../../../../src/gbm/backends/dri -I../../../../src/egl/wayland/wayland-egl -I../../../../src/egl/wayland/wayland-drm -I../../src/egl/wayland/wayland-drm -DDEFAULT_DRIVER_DIR=\"/usr/lib/x86_64-linux-gnu/dri:\${ORIGIN}/dri:/usr/lib/dri\" -D_EGL_BUILT_IN_DRIVER_DRI2 -g -O2 -fstack-protector-strong -Wformat -Werror=format-security -Wall -Wall -std=c99 -Werror=implicit-function-declaration -Werror=missing-prototypes -fno-strict-aliasing -fno-math-errno -fno-trapping-math -fno-builtin-memcmp -MT main/eglfallbacks.lo -MD -MP -MF $depbase.Tpo -c -o main/eglfallbacks.lo ../../../../src/egl/main/eglfallbacks.c &&\
In file included from ../../../../src/egl/main/egldisplay.c:61:0:
/usr/include/mirplatform/mir_toolkit/mesa/native_display.h:22:38: fatal error: mir_toolkit/client_types.h: No such file or directory
compilation terminated.
make[3]: *** [main/egldisplay.lo] Error 1

Related branches

Tiago Stürmer Daitx (tdaitx) wrote :

This patch forces autoconf to use mirclient in addition to mir-client-platform-mesa-dev

Tiago Stürmer Daitx (tdaitx) wrote :

This patch adds "Requires: mirclient = @MIR_VERSION@" in src/platforms/mesa/mir-client-platform-mesa-dev.pc.in

Changed in mir:
status: New → Triaged
importance: Undecided → High
Changed in mesa (Ubuntu):
status: New → Fix Committed
importance: Undecided → High
assignee: nobody → Robert Ancell (robert-ancell)
Robert Ancell (robert-ancell) wrote :

I've sponsored your mesa change to wily, thanks!

Your branch is not against Mir trunk so it can't be merged into lp:mir. Also, you've put Requires instead of Requires.private in the .pc file. This would causes something using mir-client-platform-mesa to link against libmirclient which is not required as the platform headers just contain structs and defines.

I've made an alternate branch lp:~robert-ancell/mir/mir-client-platform-mesa-dev-depends with these fixes and an additional missing package dependency but feel free to update your branch if you would prefer to merge that.

Robert Ancell (robert-ancell) wrote :

Deleted my merge proposal as discussed on IRC.

Changed in mir:
assignee: nobody → Tiago Stürmer Daitx (tdaitx)
status: Triaged → In Progress
milestone: none → 0.17.0
Robert Ancell (robert-ancell) wrote :

Re-merge proposing as discussed on IRC.

PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:mir at revision None, scheduled for release in mir, milestone 0.17.0

Changed in mir:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mesa - 11.0.2-1ubuntu3

---------------
mesa (11.0.2-1ubuntu3) wily; urgency=medium

  * d/patches/egl-platform-mir.patch: add mirclient dependency (LP: #1503450)

 -- Tiago Stürmer Daitx <email address hidden> Tue, 06 Oct 2015 22:05:12 +0000

Changed in mesa (Ubuntu):
status: Fix Committed → Fix Released
Changed in mir:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (3.2 KiB)

This bug was fixed in the package mir - 0.17.0+15.10.20151008.2-0ubuntu1

---------------
mir (0.17.0+15.10.20151008.2-0ubuntu1) wily; urgency=medium

  [ Alexandros Frantzis ]
  * New upstream release 0.17.0 (https://launchpad.net/mir/+milestone/0.17.0)
    - ABI summary: Only servers and graphics drivers need rebuilding;
      . Mirclient ABI unchanged at 9
      . Mirserver ABI bumped to 35
      . Mircommon ABI unchanged at 5
      . Mirplatform ABI bumped to 11
      . Mirprotobuf ABI bumped to 3
      . Mirplatformgraphics ABI bumped to 6
      . Mirclientplatform ABI unchanged at 3
    - Enhancements:
      . Introduce libmircookie, a simple mechanism for a group of cooperating
        processes to hand out and verify difficult-to-forge timestamps to
        untrusted 3rd parties.
      . More refactorings to support renderers other than GL.
      . Add MirBlob to the client API - a tool for serializing and
        deserializing data.
      . Introduce a libinput based input platform, not yet used by default.
      . Provide a mechanism for the shell to send events on surface
        construction.
      . Provide mir::shell::DisplayConfigurationController allowing shells
        to correctly change the display configuration, notifying clients
        as appropriate.
      . New DSO versioning guide.
      . Send events pertaining to the output a surface is currently on (dpi,
        form factor, scale) to clients.
    - Bug fixes:
      . [enhancement] XMir specific documentation should live in its own
        subsection (LP: #1200114)
      . Nested servers need cursor support (LP: #1289072)
      . Mir cursor is missing/invisible until the client sets it multiple
        times (LP: #1308133)
      . [regression] Fullscreen software surfaces (like Xmir -sw) can crash
        the Mir server (LP: #1493721)
      . [usc] Mir gives up and shuts down due to input with multimonitor qtmir
        (std::exception::what: Failure sending input event) (LP: #1496069)
      . Mouse cursor disappears upon entering the surface area of a nested
        client (LP: #1496849)
      . [android] input is not dispatched when attaching an external monitor
        (LP: #1498045)
      . [android] input coordinates are scaled incorrectly when an external
        display is connected (LP: #1498540)
      . [android] std::exception::what: error during hwc set() when unplugging
        external monitor (LP: #1498550)
      . tests do not compile without precompiled headers (LP: #1498829)
      . [android] std::exception::what: Failed to monitor fd: Operation not
        permitted when unplugging external display in a nested configuration
        (LP: #1499042)
      . Mir suddenly no longer builds since 'mesa (11.0.0-1ubuntu1) wily':
        /usr/include/EGL/eglplatform.h:100:35: fatal error:
        android/native_window.h: No such file or directory (LP: #1499134)
      . [android] various crashes when unplugging external display on a
        nested configuration (LP: #1501927)
      . Cursor becomes visible by itself when an external monitor is connected
        (LP: #1502200)
      . mesa FTBFS due to missing Requires in mirclient (LP: #1503450)

  [ CI Trai...

Read more...

Changed in mir (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers