[i965] intel gm965 compiz dual head issues

Bug #146298 reported by relik
166
This bug affects 16 people
Affects Status Importance Assigned to Milestone
Mesa
Fix Released
Undecided
Unassigned
mesa (Ubuntu)
High
Gerardo Lisboa
Declined for Intrepid by Timo Aaltonen
Declined for Jaunty by Timo Aaltonen
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned
Declined for Intrepid by Timo Aaltonen
Declined for Jaunty by Timo Aaltonen

Bug Description

I have an IBM Thinkpad T61 with the Intel GM965 (X3100). I have a docking station that uses a DVI and a VGA output for dual monitors. I do not use my laptop monitor. I have gotten dual heads to work as clone as well as expand. However, when I put my monitors in extend mode, compiz turns the desktop completely white and everything on my desktop disappears. The 3D Cube still works fine as well as all the other features except my desktop is completely white. Can't change the background etc. I believe I have the issue why this is happening.

If I add the Virtual line of 2560x1024, compiz spits out an error:

Comparing resolution (2560x1024) to maximum 3D texture size (2048): Failed

If I turn my resolution down down to 1024x768, it works fine.

I think Compiz is spitting out the wrong 3D texture size and hoses on it.

If I change my /usr/bin/compiz config, and change the Failed to equal 1 (which is success), compiz works fine except for the odd looking white desktop background. Again, 3D cube works fine, wobbly windows, everything. Except for the desktop. Very strange.

Related branches

Revision history for this message
relik (dkennedy) wrote :

heres my lspci:

0:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 0c)
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
00:19.0 Ethernet controller: Intel Corporation 82566MM Gigabit Network Connection (rev 03)
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Contoller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 3 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 4 (rev 03)
00:1c.4 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 5 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f3)
00:1f.0 ISA bridge: Intel Corporation 82801HBM (ICH8M-E) LPC Interface Controller (rev 03)
00:1f.2 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA IDE Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 03)
02:00.0 Memory controller: Intel Corporation Turbo Memory Controller (rev 01)
03:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN Network Connection (rev 61)
15:00.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev ba)
15:00.1 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 04)
15:00.2 Generic system peripheral [0805]: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 21)
15:00.3 System peripheral: Ricoh Co Ltd R5C843 MMC Host Controller (rev 11)
15:00.4 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 11)
15:00.5 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 11)

Revision history for this message
relik (dkennedy) wrote :

Heres my compiz errors specifically:

user@testbox:~$ compiz --replace
Checking for Xgl: not present.
Detected PCI ID for VGA: 00:02.0 0300: 8086:2a02 (rev 0c) (prog-if 00 [VGA])
Checking for texture_from_pixmap: not present.
Trying again with indirect rendering:
Checking for texture_from_pixmap: present.
Checking for non power of two support: present.
Checking for Composite extension: present.
Comparing resolution (2560x1024) to maximum 3D texture size (2048): Failed.
aborting and using fallback: /usr/bin/metacity

Revision history for this message
David Portwood (dzportwood) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, this compiz package is not from the official Ubuntu repositories, and as such is not supported here. Please report this bug upstream at https://bugs.freedesktop.org/enter_bug.cgi?product=xorg . Thanks!

Revision history for this message
David Portwood (dzportwood) wrote :

I closed the wrong set of bugs, sorry.

Revision history for this message
Travis Watkins (amaranth) wrote :

Your video hardware is not capable of running compiz at this screen resolution.

Revision history for this message
relik (dkennedy) wrote :

Travis, how is that possible when it works 100 percent fine if I install Compiz from hand on Feisty? I have it working right now at 2560.

Revision history for this message
mexlinux (mcanedo) wrote :

I have this problem on Hardy (only official packages),
The dual head with 1024x768 + 1280x800 works only on metacity.
Compiz only works up to 1024x768 + 1024x768
This thread is confusing.... is this a bug or a hardware limit?

Revision history for this message
Travis Watkins (amaranth) wrote :

It is a hardware limit that compiz from upstream does not enforce, we do it via compiz-manager. If you install compiz from upstream (like relik did on feisty) compiz will start but with have rendering problems on the part of the screen that goes over this limit.

Revision history for this message
mexlinux (mcanedo) wrote :

wired....
I'm not completely sure on how to reproduce it, but sometimes compiz works on the dual head, and in fact have rendering problems, but only on the background, The windows, even in that area are properly rendered.
See attachment, also in the attachment there is dump in the console of th xrandr output

Revision history for this message
mexlinux (mcanedo) wrote :

Second scrennshot it to proof that compiz is runing, and also how rendering is viewed.

Revision history for this message
Vitali Kulikou (sabotatore) wrote :

I have the same problem!

Revision history for this message
ajonat (ajonat) wrote :

Hi!
This page http://www.intellinuxgraphics.org/dualhead.html shows the following in a xorg.conf example for configuring dual-head:

# This optional entry specifies the virtual screen resolution to be used.
# If this entry is not present, the virtual screen resolution will be set to
# accommodate all the valid video modes given in the Modes entry.
# There is a known issue that DRI doesn't work on pre-965 if maximum is larger than 2048x2048.
Virtual 2048 2048

So, I don't understand... if it is really a hardware limit, how come the official intel graphics page says it doesn't apply to 965GM and later cards?

Thanks in advance!

Revision history for this message
Travis Watkins (amaranth) wrote :

In that case I'd say it's a driver bug. It either really doesn't support larger than 2048x2048 or does but is reporting that's all it supports. That's what compiz is checking on the bit that fails, what the graphics card claims the limit is versus your current resolution.

Revision history for this message
Travis Watkins (amaranth) wrote :

Actually based on the white background you mention the limit _is_ really there. If it shouldn't be then the driver is supporting less than the hardware.

Revision history for this message
unggnu (unggnu) wrote :

The driver problem might be a dupe of Bug 146859.

Revision history for this message
ajonat (ajonat) wrote :

Travis, you were right, the drivers were the problem.
Here's what I did to make compiz work with larger resolutions (beyond 2048):
First, I did apt-get source xserver-xorg-video-intel and applied the following patch:
http://gitweb.freedesktop.org/?p=xorg/driver/xf86-video-intel.git;a=blobdiff;h=ada3919adf33179ab72aecfdc2e9e48c439f8888;hp=7f798e6c8dfb0a5775cae5d4e6595d8d09b2a251;hb=4f5500abe209b92b39ae1f2d7a1118362ac95034;f=src/i965_render.c
What this does is to enable support for larger resolutions (up to 8192x8192) in the i965 driver, as you can see in the diff:
- if ((w > 0x7ff) || (h > 0x7ff))
+ if ((w > 8192) || (h > 8192))

Then, I applied the following patch in mesa7.0-rc3 (latest in ubuntu hardy):
diff --git a/src/mesa/drivers/dri/i965/brw_context.c b/src/mesa/drivers/dri/i965/brw_c!
index 1601f6d..c06f5da 100644
--- a/src/mesa/drivers/dri/i965/brw_context.c
+++ b/src/mesa/drivers/dri/i965/brw_context.c
@@ -138,10 +138,10 @@ GLboolean brwCreateContext( const __GLcontextModes *mesaVis,
    /* Advertise the full hardware capabilities. The new memory
     * manager should cope much better with overload situations:
     */
- ctx->Const.MaxTextureLevels = 12;
+ ctx->Const.MaxTextureLevels = 13;
    ctx->Const.Max3DTextureLevels = 9;
    ctx->Const.MaxCubeTextureLevels = 12;
- ctx->Const.MaxTextureRectSize = (1<<11);
+ ctx->Const.MaxTextureRectSize = (1<<12);
    ctx->Const.MaxTextureUnits = BRW_MAX_TEX_UNIT;

 /* ctx->Const.MaxNativeVertexProgramTemps = 32; */

Then, I dpkg-buildpackage xserver-xorg-video-intel and mesa7.0rc3 with both patches applied and installed them, and voila! Problem solved.

ajonat@daphne:~$ glxinfo -l | grep GL_MAX_TEXTURE_SIZE
    GL_MAX_TEXTURE_SIZE = 4096

This limit is because mesa can't handle resoutions larger than 4096 but that isn't problem for me as I wanted 2960x1050.
You also have to put the according virtual resolution in xorg.conf for this to work.

References:
http://lists.freedesktop.org/archives/xorg/2008-April/034960.html

Thank you everyone!
Alex.

P.S. any chance to see this patches applied to hardy's latest packages?

Revision history for this message
ajonat (ajonat) wrote :

Now I'm having this bug: https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/149377. I'm going to do a little research and come back posting my findinds.

Revision history for this message
Bryce Harrington (bryce) wrote :

Hi dkennedy,

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with the latest development release of Ubuntu? (ISOs are available from cdimage.ubuntu.com)

If it remains an issue, could you also attach a new /var/log/Xorg.0.log?
Thanks in advance.

The output of lspci -vvnn would also be worth having.

Changed in xserver-xorg-video-intel:
status: New → Incomplete
Revision history for this message
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xserver-xorg-video-intel:
status: Incomplete → Invalid
Revision history for this message
Ramon Casha (rcasha) wrote :

It's actually still there. Any combined resolution beyond 2048 pixels in width disables the eyecandy

Revision history for this message
Ramon Casha (rcasha) wrote :

still present on intrepid

Changed in xserver-xorg-video-intel:
status: Invalid → Confirmed
Revision history for this message
relik (dkennedy) wrote :

Still an issue on intrepid, not fixed. I've since switched to another distro due to the responses I received "its a hardware limitation" and "this is not supported". I've gotten my "hardware limitation" to work successfully on SuSE without a problem.

Revision history for this message
Matthew Woerly (nattgew) wrote :

I have the same issue, compiz dies if it's larger than 2048. My workaround is to put the second screen on top rather than on the side.

Revision history for this message
mexlinux (mcanedo) wrote :

@Nattgew
Your work arraound works here too, Thanks!
Is a bit wired to have that position, but at least works....

Revision history for this message
snuggl (snuggl) wrote :

workaround (to start compiz, not to get rid of the texture limit), start with this if you dont want to edit the wrapper:
SKIP_CHECK=yes compiz --replace&

Problem still exists in Intrepid

Revision history for this message
Chris Jean-Marie (chris-jeanmarie) wrote :

Only the mesa patch is now required in Intrepid. The i965 driver can now handle the larger screens.

Revision history for this message
Tormod Volden (tormodvolden) wrote :

The link to the mesa patch above is broken, it is http://lists.freedesktop.org/archives/xorg/2008-April/034707.html

Revision history for this message
mexlinux (mcanedo) wrote :

I have just installed KDE4.2 Beta 2 and works PERFECT!

So I might "guess" that is not a problem in the driver, but in compiz..... might that be?

Revision history for this message
mexlinux (mcanedo) wrote :

I mean when running kde 4.2 I'm using kwin, instead of compiz.

Revision history for this message
Bryce Harrington (bryce) wrote :

[This is an automatic notice.]

We'd like to forward your bug upstream, however upstream requires
that you first test it against their newer driver code.

To save you the effort of building the driver from source, we've built
packages for the driver and its new dependencies.

So you have a couple options:

 1. Download and test .debs for intrepid, from:
     https://edge.launchpad.net/~intel-gfx-testing/+archive

 -or-

 2. Download and test the Jaunty alpha-2 (or newer) Live CD,
     (which includes a beta of the new xserver 1.6 as well).
     See http://cdimage.ubuntu.com/releases/9.04/ for ISOs

Thanks ahead of time! You can simply reply to this email to report your
findings.

P.S., if you wish to forward your bug upstream yourself, please follow
these directions to do so:
  http://intellinuxgraphics.org/how_to_report_bug.html

Changed in xserver-xorg-video-intel:
status: Confirmed → Incomplete
Revision history for this message
Ramon Casha (rcasha) wrote :

Ok I installed the Intrepid debs. Didn't seem to make any difference to tell you the truth. I'm currently running on dual screens of 1600x1200 and 1600x1024 (xorg.conf has Virtual 3200 1200).

Attempting to enable the visual effects gives "Desktop effects could not be enabled".

Running compiz gives:

Checking for Xgl: not present.
Detected PCI ID for VGA:
Checking for texture_from_pixmap: not present.
Trying again with indirect rendering:
Checking for texture_from_pixmap: present.
Checking for non power of two support: present.
Checking for Composite extension: present.
Comparing resolution (3200x1200) to maximum 3D texture size (2048): Failed.
aborting and using fallback: /usr/bin/metacity

Are there any tests you want me to try or anything?

Revision history for this message
Bryce Harrington (bryce) wrote :

Thanks for testing; this should go upstream. Setting to Triaged for now.

Changed in xserver-xorg-video-intel:
status: Incomplete → Triaged
Revision history for this message
miloos (milooos) wrote :

I spent few hours by solving problem with dual monitor on intel on board 810.
After set 1st monitor left the 2nd and when GUI wrote virtual display size to xorg.conf X doesnt start correctly. (it was looked like 1st row of screen is on whole screen)
I was looking for solution: how to disable direct rendering, but these .debs solved my problem and I have direct rendering enabled.
thank you

Revision history for this message
yagi (valles) wrote :

Here is a precompiled deb file for ubuntu 8.10

     libgl1-mesa-dri_7.2-1ubuntu2_i386.deb
     http://www.mediafire.com/?jwt2zxmx5x1

Revision history for this message
Khashayar Naderehvandi (khashayar) wrote :

This patch from upstream [1], commited 4 hours ago, is very similar to the one in comment 16. It's supposed to bump the texture limit on i965 to 4kx4k. I'm about to test it in a minute on Jaunty, where it's the only change required to solve this issue. If it works, I suggest it should be cherry picked and applied on Jaunty's mesa.

[1] http://cgit.freedesktop.org/mesa/mesa/commit/?id=954dfba12986f578f2d8461818f9e9ac1f8f2b41

Revision history for this message
Khashayar Naderehvandi (khashayar) wrote :

I can now confirm that the patch from upstream solved the issue on Jaunty, and that it's the only change required.
I changed the affected project of this bug to mesa. (Well actually, I was trying to add mesa, but for some reason xserver-xorg-video-intel was replaced with mesa).

Revision history for this message
Ramon Casha (rcasha) wrote : Re: [Bug 146298] Re: [i965] intel gm965 compiz dual head issues

Any chance that this can also be applied to Intrepid?

Ramon Casha

2009/1/31 Khashayar Naderehvandi <email address hidden>

> I can now confirm that the patch from upstream solved the issue on Jaunty,
> and that it's the only change required.
> I changed the affected project of this bug to mesa. (Well actually, I was
> trying to add mesa, but for some reason xserver-xorg-video-intel was
> replaced with mesa).
>
> --
> [i965] intel gm965 compiz dual head issues
> https://bugs.launchpad.net/bugs/146298
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Revision history for this message
Geir Ove Myhr (gomyhr) wrote :

Closing from xserver-xorg-video-intel, since it is triaged for mesa.

Changed in xserver-xorg-video-intel:
status: New → Invalid
Revision history for this message
Ludovico Cavedon (cavedon) wrote :

The above mentioned fixed worked for me, thanks!!

I have uploaded a patched version for intrepid on my ppa:
https://edge.launchpad.net/~cavedon/+archive/ppa

Revision history for this message
mexlinux (mcanedo) wrote :

It works!
Thank you!

Revision history for this message
Ludovico Cavedon (cavedon) wrote :

I uploaded the fix also for jaunty on my PPA.
https://edge.launchpad.net/~cavedon/+archive/ppa

Could anyone test it, please?

Here is the debdiff:

Changed in mesa (Ubuntu):
status: Triaged → Confirmed
Revision history for this message
Shetil (kjetil-wikestad) wrote :

Graphic chip: Intel GMA X4500HD

Before: Visual corruption on the second display when using Compiz.

Installed: amd64 packages from Ludovico Cavedon

After: Dual display setup with compiz working on both

Thank you!

Revision history for this message
salvabalza (salvabalza) wrote :

Intel 965 graphic chip:

Before: Second display corrupted (max width 2048 problem)

Installed jaunty i386 package from Cavedon

After: Working well for a couple of seconds, then crashing back to login screen.

Can I add some useful log/config file?

Thanks.

Revision history for this message
Ludovico Cavedon (cavedon) wrote :

Clearly I also tested it with dual head, virtual size 3200x1024 and compiz and works.

Revision history for this message
Bryce Harrington (bryce) wrote :

[I see this patch upstream but not included in 7.4. Timo, you may want to look at including this in our mesa.]

Changed in mesa (Ubuntu):
assignee: nobody → tjaalton
importance: Undecided → High
status: Confirmed → Triaged
Revision history for this message
Bryce Harrington (bryce) wrote : Unsubscribing Sponsors.

I'm unsubscribing the Sponsors' Team for now. Please re-subscribe when ready.

Revision history for this message
Ludovico Cavedon (cavedon) wrote :

>Can I add some useful log/config file?

Sorry, I did not see your message beffore.
Could you include /var/log/Xorg.0.log and /var/log/Xorg.0.log.old *right after* the crash, please?

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

Ok I'll add it, but upstream declined it for 7.4 because it should need another commit which then broke ati r300.

Revision history for this message
salvabalza (salvabalza) wrote :

Update: now working; I deleted .compiz directory, reinstalled and reconfigured compiz, reinstalled the patch from ppa and now it's working.

It's up since about four hours without problems, before it crashed in the first minute.

Thanks all.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mesa - 7.4-0ubuntu1

---------------
mesa (7.4-0ubuntu1) jaunty; urgency=low

  * New upstream release, merge from debian-experimental
    (LP: #330476, #347171, #349127)
  * Drop 103_rs600_support.patch, included in this version.
  * Drop 104_swrast_fbconfigs.patch, included in this version.
  * Add 103_bump_965_texture_limit.diff. (LP: #146298)
  * Add 104_fix_dri2_ext_tfp.diff. (LP: #324854)

 -- Timo Aaltonen <email address hidden> Fri, 03 Apr 2009 12:42:06 +0300

Changed in mesa (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
Bryce Harrington (bryce) wrote :

[Reopening; even though we think this patch may solve this freeze, we need positive testing proof still.]

Changed in mesa (Ubuntu):
status: Fix Released → In Progress
Revision history for this message
Bryce Harrington (bryce) wrote :

er, let me try that again...

We suspect the fix for this bug has caused a more serious X freeze issue (bug 359392), so are reverting this patch for now. We might bring it back later if we can definitively prove what causes that freeze.

Revision history for this message
bigbrovar (bigbrovar) wrote :

i doubt the fix is the cause of the serious X freeze, i upgraded from beta to jaunty RC (clean install) and the first thing that greeted me was a freeze,

Revision history for this message
salvabalza (salvabalza) wrote :

Hi all,

with the patch of April, 3th it solved for me, I could see compiz and its effects on both screens.

With today jaunty update, I have the problem again, I can see compiz on only half on second screen (maximum 3D texture size (2048) problem).

Revision history for this message
Ludovico Cavedon (cavedon) wrote :

I uploaded in my ppa version 7.4-0ubuntu3+ppa1 which reenables the fix.

https://edge.launchpad.net/~cavedon/+archive/ppa

Revision history for this message
Matthias Blaicher (blaicher) wrote :

Your PPA is out of data again, it would be great if you could patch the most recent version as well (mesa-7.4-0ubuntu3.1). Also it seems that there is now a fix to the intel problems, and I bet this patch has nothing to do with it, as it was a bug in the intel driver and not mesa. (See Bug 359392)

Revision history for this message
Ludovico Cavedon (cavedon) wrote : Re: [Bug 146298] Re: [i965] intel gm965 compiz dual head issues

Matthias Blaicher wrote:
> Your PPA is out of data again, it would be great if you could patch the
> most recent version as well (mesa-7.4-0ubuntu3.1). Also it seems that
> there is now a fix to the intel problems, and I bet this patch has
> nothing to do with it, as it was a bug in the intel driver and not mesa.
> (See Bug 359392)

Updated! Thanks for letting me know!

Revision history for this message
Ludovico Cavedon (cavedon) wrote :

This fix was removed from the package just before release because it was thought to be the cause of bug 359392.
Now that it has been made clear that it is unreleated, would it be possible to make SRU for jaunty?

I am attaching a debdiff.

Revision history for this message
achansonjr (a-c-hansonjr) wrote :

Ludovico Cavedon's ppa repository has me up and working on a fully patched 9.04 install. Thanks Ludovico.

There have been no issues with cranky X crashes either.

Revision history for this message
mexlinux (mcanedo) wrote :

I also have the Cavedon's PPA packages, but I do have X crashes.
(I don't know if that's related or not)

Revision history for this message
Vitali Kulikou (sabotatore) wrote :

Ludovico Cavedon, Repository updated mesa-7.4-0ubuntu3.2. Need update your PPA.

Revision history for this message
Ludovico Cavedon (cavedon) wrote :

Vitali Kulikou wrote:
> Ludovico Cavedon, Repository updated mesa-7.4-0ubuntu3.2. Need update
> your PPA.

Uploaded, thanks for letting me know.

Revision history for this message
Vitali Kulikou (sabotatore) wrote :

Thanks! :)

Revision history for this message
Ramon Casha (rcasha) wrote :

Should this be working on jaunty? My compiz still checks for the resolution
and fails with the message

"Checking screen 1Comparing resolution (3200x1200) to maximum 3D texture
size (2048): Failed."

..before falling back to metacity. Did I leave something out?

Ramon Casha

2009/6/26 Vitali Kulikou <email address hidden>

> Thanks! :)
>
> --
> [i965] intel gm965 compiz dual head issues
> https://bugs.launchpad.net/bugs/146298
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Revision history for this message
Ludovico Cavedon (cavedon) wrote :

Ramon Casha wrote:
> Should this be working on jaunty? My compiz still checks for the resolution
> and fails with the message
>
> "Checking screen 1Comparing resolution (3200x1200) to maximum 3D texture
> size (2048): Failed."
>
> ..before falling back to metacity. Did I leave something out?

The mesa package in my ppa should fix the problem:
https://edge.launchpad.net/~cavedon/+archive/ppa

Revision history for this message
Ramon Casha (rcasha) wrote :

Yay it worked.
Not sure what I did though - first time I tried it, it didn't work. Maybe it needed a reboot?

Revision history for this message
Ochir (oabushinov) wrote :

I tried this patch for my intel GM 4500 MHD card and it works well.
Thanks!

Revision history for this message
Ochir (oabushinov) wrote :

sorry, I forgot to add. I applied patch by Ludovico Cavedon for Jaunty.

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

Fixed in karmic, which has mesa 7.5rc4. Too risky to put in jaunty.

Changed in mesa (Ubuntu):
assignee: Timo Aaltonen (tjaalton) → nobody
status: In Progress → Fix Released
Revision history for this message
David M. Lee (leedm777) wrote :

That's disappointing. Cavedon's PPA is working great for me.

Revision history for this message
Valentin Neacsu (valentin.neacsu) wrote :

Works with Ludovico Cavedon's PPA. Thanks!

Revision history for this message
Frantique (undernetangel) wrote :

Cavedon's PPA helped me too. Thanks!

Revision history for this message
Stuart Colville (muffinresearch) wrote :

I've tried Cavedon's PPA a couple of times but it always produced tearing even after reboot - so I downgraded back the packages that were replaced.

However just to be sure I'm not getting something wrong - could someone provide details of steps to install the patched version of mesa?

Revision history for this message
Johan van Zoomeren (amain) wrote :

Cavedon's PPA helped me too. Great Thanks!

Revision history for this message
dRewsus (drewsus) wrote :

Cavedon's PPA needs to be updated for Lucid and Mesa 7.8.1

Revision history for this message
Adam Koczur (sbv) wrote :

Really disappointing - still not fixed in Maverick.

Revision history for this message
Gerardo Lisboa (gvlx) wrote :

Latest packages for Natty still do not apply the patch already present in Mesa's HEAD branch.

Gerardo Lisboa (gvlx)
Changed in mesa (Ubuntu):
assignee: nobody → Gerardo Lisboa (gvlx)
Gerardo Lisboa (gvlx)
Changed in mesa:
status: New → Fix Released
Changed in hundredpapercuts:
assignee: nobody → Gerardo Lisboa (gvlx)
Revision history for this message
Vish (vish) wrote :

Thank you for bringing this bug to our attention. However, a paper cut should be a small usability issue, in the default Ubuntu install, that affects many people and is quick and easy to fix. So this bug can't be addressed as part of this project.

 - This is a bug and Not a papercut
For further information about papercuts criteria, please read https://wiki.ubuntu.com/PaperCut.
Don't worry though, this bug has been marked as "Invalid" only in the papercuts project.

affects: hundredpapercuts → null
Changed in null:
assignee: Gerardo Lisboa (gvlx) → nobody
status: New → Invalid
Curtis Hovey (sinzui)
no longer affects: null
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers