r300 Mesa driver not loading with KMS enabled

Bug #1432949 reported by Herminio on 2015-03-17
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Mesa
Fix Released
Medium
mesa (Ubuntu)
Medium
Unassigned

Bug Description

I cannot get 3D acceleration to work. I was expecting to see the gears via the command 'glxgears' I have KMS enable on my iBook G4 by using the following parameter

Linux radeon.modeset=1 video=offb:off video=1024x768-32 video=radeonfb:off radeon.agpmode=-1

Here are my Mesa and Xorg output

rican-linux@ibookG4-UbuntuMATE:~$ cat /var/log/Xorg.0.log |grep -e radeon -e dri2 -e drm -e KMS
[ 32.774] Kernel command line: root=UUID=fadadc01-6fd5-49fa-85f3-9e52d0fe6155 ro quiet splash video=offb:off video=1024x768-32 video=radeonfb:off radeon.modeset=1 video=offb:off video=1024x768-32 video=radeonfb:off radeon.agpmode=-1
[ 33.203] (II) xfree86: Adding drm device (/dev/dri/card0)
[ 35.011] (II) LoadModule: "radeon"
[ 35.012] (II) Loading /usr/lib/xorg/modules/drivers/radeon_drv.so
[ 35.337] (II) Module radeon: vendor="X.Org Foundation"
[ 35.604] (II) [KMS] Kernel modesetting enabled.
[ 35.697] (II) Loading sub module "dri2"
[ 35.697] (II) LoadModule: "dri2"
[ 35.697] (II) Module "dri2" already built-in
[ 35.870] (II) RADEON(0): KMS Color Tiling: enabled
[ 35.870] (II) RADEON(0): KMS Color Tiling 2D: disabled
[ 35.870] (II) RADEON(0): KMS Pageflipping: enabled
rican-linux@ibookG4-UbuntuMATE:~$ LIBGL_DEBUG=verbose glxinfo |grep render
libGL: screen 0 does not appear to be DRI3 capable
libGL: pci id for fd 4: 1002:4e56, driver r300
libGL: OpenDriver: trying /usr/lib/powerpc-linux-gnu/dri/tls/r300_dri.so
libGL: OpenDriver: trying /usr/lib/powerpc-linux-gnu/dri/r300_dri.so
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: r300
libGL: OpenDriver: trying /usr/lib/powerpc-linux-gnu/dri/tls/swrast_dri.so
libGL: OpenDriver: trying /usr/lib/powerpc-linux-gnu/dri/swrast_dri.so
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
Error: couldn't find RGB GLX visual or fbconfig
rican-linux@ibookG4-UbuntuMATE:~$ dpkg -l libgl1-mesa-dri
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-==============-============-============-=================================
ii libgl1-mesa-dr 10.5.0~rc1-0 powerpc free implementation of the OpenGL
rican-linux@ibookG4-UbuntuMATE:~$

rican-linux@ibookG4-UbuntuMATE:~$ lsb_release -rd
Description: Ubuntu Vivid Vervet (development branch)
Release: 15.04

rican-linux@ibookG4-UbuntuMATE:~$ apt-cache policy libgl1-mesa-dri
libgl1-mesa-dri:
  Installed: 10.5.0~rc1-0ubuntu1
  Candidate: 10.5.0-0ubuntu1
  Version table:
     10.5.0-0ubuntu1 0
        500 http://ports.ubuntu.com/ubuntu-ports/ vivid/main powerpc Packages
 *** 10.5.0~rc1-0ubuntu1 0
        100 /var/lib/dpkg/status

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: libgl1-mesa-dri 10.5.0~rc1-0ubuntu1
ProcVersionSignature: Ubuntu 3.18.0-13.14-powerpc-smp 3.18.5
Uname: Linux 3.18.0-13-powerpc-smp ppc
ApportVersion: 2.16.1-0ubuntu2
Architecture: powerpc
CurrentDesktop: MATE
Date: Tue Mar 17 00:58:43 2015
InstallationDate: Installed on 2015-03-17 (0 days ago)
InstallationMedia: Ubuntu-MATE 15.04 "Vivid Vervet" - Alpha powerpc (20150225)
SourcePackage: mesa
UpgradeStatus: No upgrade log present (probably fresh install)

Created attachment 89467
Xorg.log without configuration file

Without xorg.conf or with a pixel depth of 24 bits, any application linked to libGL will fails to load the "r300" driver and after it the "swarst" driver with the following message:

  libGL error: failed to load driver: r300
  libGL error: Try again with LIBGL_DEBUG=verbose for more details.
  libGL error: failed to load driver: swrast
  libGL error: Try again with LIBGL_DEBUG=verbose for more details.

This problem is present in all the Mesa 9.x release up to 9.2.3. But it is not in the 8 (which segfault at some point), 7.11 was working without config file.

After a bit of investigation, I found that driConvertConfigs() returns NULL in dri2CreateScreen() when trying to find matching visuals (src/glx/dri_glx.c:450). However if I specify a depth of 16 bits in my xorg.conf I cannot reproduce this problem.

This problem is present on OpenBSD -current (future 5.5) which has the drm drivers synced with Ubuntu's linux 3.8 kernel.

Created attachment 89468
Xorg.log with 16 bits depth in xorg.conf

Herminio (herminio-hernandezjr) wrote :
Herminio (herminio-hernandezjr) wrote :

By setting my DefaultDepth to 16 on my xorg.conf file I was able to get 3D working. However I believe this is a work around.

rican-linux@ibookG4-UbuntuMATE:~$ LIBGL_DEBUG=verbose glxinfo |grep render
libGL: screen 0 does not appear to be DRI3 capable
libGL: pci id for fd 4: 1002:4e56, driver r300
libGL: OpenDriver: trying /usr/lib/powerpc-linux-gnu/dri/tls/r300_dri.so
libGL: OpenDriver: trying /usr/lib/powerpc-linux-gnu/dri/r300_dri.so
direct rendering: Yes
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,
OpenGL renderer string: Gallium 0.4 on ATI RV350
    GL_MESA_ycbcr_texture, GL_NV_blend_square, GL_NV_conditional_render,
    GL_OES_fbo_render_mipmap, GL_OES_get_program_binary, GL_OES_mapbuffer,
rican-linux@ibookG4-UbuntuMATE:~$

I am seeing the same thing in Debian Testing. Those patches woorked all the way up to mesa 10.5.5 then they began to fail.

Created attachment 116274
glxinfo output

Alex Perez (aperez-6) wrote :

Can confirm, I have the same problem. Workaround of 16 bit defaultdepth is successful, albeit sub-optimal.

Download full text (4.1 KiB)

Sadly that is the known work around.

Sent from my iPhone

> On Aug 2, 2015, at 3:20 PM, Alex Perez <email address hidden> wrote:
>
> Can confirm, I have the same problem. Workaround of 16 bit defaultdepth
> is successful, albeit sub-optimal.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1432949
>
> Title:
> r300 Mesa driver not loading with KMS enabled
>
> Status in mesa package in Ubuntu:
> New
>
> Bug description:
> I cannot get 3D acceleration to work. I was expecting to see the gears
> via the command 'glxgears' I have KMS enable on my iBook G4 by using
> the following parameter
>
> Linux radeon.modeset=1 video=offb:off video=1024x768-32
> video=radeonfb:off radeon.agpmode=-1
>
> Here are my Mesa and Xorg output
>
> rican-linux@ibookG4-UbuntuMATE:~$ cat /var/log/Xorg.0.log |grep -e radeon -e dri2 -e drm -e KMS
> [ 32.774] Kernel command line: root=UUID=fadadc01-6fd5-49fa-85f3-9e52d0fe6155 ro quiet splash video=offb:off video=1024x768-32 video=radeonfb:off radeon.modeset=1 video=offb:off video=1024x768-32 video=radeonfb:off radeon.agpmode=-1
> [ 33.203] (II) xfree86: Adding drm device (/dev/dri/card0)
> [ 35.011] (II) LoadModule: "radeon"
> [ 35.012] (II) Loading /usr/lib/xorg/modules/drivers/radeon_drv.so
> [ 35.337] (II) Module radeon: vendor="X.Org Foundation"
> [ 35.604] (II) [KMS] Kernel modesetting enabled.
> [ 35.697] (II) Loading sub module "dri2"
> [ 35.697] (II) LoadModule: "dri2"
> [ 35.697] (II) Module "dri2" already built-in
> [ 35.870] (II) RADEON(0): KMS Color Tiling: enabled
> [ 35.870] (II) RADEON(0): KMS Color Tiling 2D: disabled
> [ 35.870] (II) RADEON(0): KMS Pageflipping: enabled
> rican-linux@ibookG4-UbuntuMATE:~$ LIBGL_DEBUG=verbose glxinfo |grep render
> libGL: screen 0 does not appear to be DRI3 capable
> libGL: pci id for fd 4: 1002:4e56, driver r300
> libGL: OpenDriver: trying /usr/lib/powerpc-linux-gnu/dri/tls/r300_dri.so
> libGL: OpenDriver: trying /usr/lib/powerpc-linux-gnu/dri/r300_dri.so
> libGL error: No matching fbConfigs or visuals found
> libGL error: failed to load driver: r300
> libGL: OpenDriver: trying /usr/lib/powerpc-linux-gnu/dri/tls/swrast_dri.so
> libGL: OpenDriver: trying /usr/lib/powerpc-linux-gnu/dri/swrast_dri.so
> libGL error: No matching fbConfigs or visuals found
> libGL error: failed to load driver: swrast
> Error: couldn't find RGB GLX visual or fbconfig
> rican-linux@ibookG4-UbuntuMATE:~$ dpkg -l libgl1-mesa-dri
> Desired=Unknown/Install/Remove/Purge/Hold
> | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
> |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
> ||/ Name Version Architecture Description
> +++-==============-============-============-=================================
> ii libgl1-mesa-dr 10.5.0~rc1-0 powerpc free implementation of the OpenGL
> rican-linux@ibookG4-UbuntuMATE:~$
>
> rican-linux@ibookG4-UbuntuMATE:~$ lsb_release -rd
> Description: Ubuntu Vivid Vervet (development branch)
> Release: 15.04
>
> rican-linux@ibookG4-UbuntuM...

Read more...

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mesa (Ubuntu):
status: New → Confirmed
Herminio (herminio-hernandezjr) wrote :

I also ran the OpenGL test suite piglit on my graphics card. I shared the result upstream to mesa but anyone can see them here:

https://drive.google.com/open?id=0ByNWUTbPhemsM1BMczBETndBeEk

Changed in mesa (Ubuntu):
importance: Undecided → Medium
ernsteiswuerfel (erhard-f) wrote :

Me too can confirm this bug on my Powerbook 5,8. Workaround of 16 bit defaultdepth is successful, albeit sub-optimal.

I noticed in the 11.0.3 release notes that this issue was fix. However I am running Lubuntu 16.04 (development) on my iBook G4 and I am still. Getting the same issue. When I change to Defaul Depth 16 I get 3D acceleration. I ran strace under both conditions and am post them plus my Xorg.0.log

Created attachment 119753
strace default depth 24

Created attachment 119754
strace default depth 16

Created attachment 119755
xorg log

I confirm that this bug is still present with Mesa 11.0.6.

Without forcing "DefaultDepth" to 16, I get:

  $ glxgears
  libGL error: No matching fbConfigs or visuals found
  libGL error: failed to load driver: r300
  libGL error: No matching fbConfigs or visuals found
  libGL error: failed to load driver: swrast

With Ubuntu Mate 16.04a2 on a G4 PowerBook5,8 I have to confirm, that this bug is still present with Mesa 11.1.1.

ernsteiswuerfel (erhard-f) wrote :

Bug persists on Ubuntu MATE 16.04 daily live, Powerbook 5,6.

Can confirm this bug on Ubuntu MATE 16.04 daily, Mesa 11.1.1. On a PowerBook 5,6.

Changed in mesa:
importance: Unknown → Medium
status: Unknown → Confirmed
ernsteiswuerfel (erhard-f) wrote :

Still here on todays Ubuntu MATE 16.04 LTS (mesa 11.2, xserver-xorg-video-radeon 7.7.0). Tested on a PowerMac G5 7,3.

Still here on mesa 11.2 (Ubuntu MATE 16.04 daily). Tested on a PowerMac G5 7,3.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1432949

tags: added: iso-testing

An updated patch is now available from:

https://lists.freedesktop.org/archives/mesa-dev/2016-April/114409.html

As mentioned over here:

https://lists.freedesktop.org/archives/mesa-dev/2016-April/114412.html

we'are actively looking forward for feedback.

I've also attached the patch directly to this bug tracker for convenience: r300g_be.patch

I also see in apitrace that GLXChooseVisual returns with NULL when I to run glxgears.

Created attachment 123267
proposed patch

Patched r300g_be.patch against mesa 11.1.3. -> No acceleration at Depth 24.This is Debian sid.

Same here. Glxinfo says r300 fails to load.

dan@powerbook2:~$ glxinfo
name of display: :0.0
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: r300
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
Error: couldn't find RGB GLX visual or fbconfig

...

Applied the patch on top of 43f46caf769b0a6d661850ce2fa64b6f4b085b9f, but unfortunately it didn't work. Tested on a PowerBook G4 5,6 with Linux 4.6-rc4 (5f44abd041c5f3be76d57579ab254d78e601315b) / Debian Sid.

Created attachment 123370
final fix?

Could you please test this patch?

Created attachment 123385
glxinfo output with final fix

Patched it on top of cbcd7b60f573d027337a2390e67f6010e9992aaa and that one did actually work! I've attached the full glxinfo output in case someone is interested.

Applied against Debian 11.1.3-1. 3-D acceleration at depth=24 works. Power consumption running foobillardplus is very high. Colors at the Cairo Dock are looking pastel shaded.

Elimar, Nathan or anyone else, can you try if the piglit sanity tests pass with this patch?

Also, do OpenGL compositing managers such as gnome-shell show correct colours?

Created attachment 123420
Piglit Sanity Check Results

I've attached the Piglit result of the sanity check to this issue, GNOME Shell also has a discolouration (the title bar and activity screen is red) and after using it for a couple of minutes it crashed (SIGSEGV):

[ 6088.876306] gnome-shell[8144]: unhandled signal 11 at 095b44c0 nip 095b44c0 lr 0de343b4 code 30001
[ 6112.441094] gnome-shell[8701]: unhandled signal 11 at 095b44c0 nip 095b44c0 lr 0de343b4 code 30001

Patched on top on 79b0e13913b5189bb8629e80439fea746f99fe79 and it works! Many thanks!

Machine used is a PowerMac G5 7,3 with an AGP Radeon 9600 Pro (Mac edition). Running Compton composting manager (Ubuntu MATE 16.04) and it runs without glitches so far, colours look good. Only thing I noticed is the desktop gets unresponsive and the mouse pointer very jerky during youtube video playback.

Will try Piglit tests the next days.

I believe that the testers should also make sure to use PCI instead of AGP during there testing. See bug: https://bugs.freedesktop.org/show_bug.cgi?id=95017.

Built piglit from svn on Ubuntu MATE 16.04 ppc. Already the sanity test fails, specifically:
root@T800:~/build/piglit# /root/build/piglit/bin/gl-1.0-readpixsanity -auto -fbo
 RGB(A) worst-case error was 6.641274 bits at (32, 80)
  expected (0.840188, 0.394383, 0.783099, 0.798440)
  got (0.799995, 0.784309, 0.396076, 0.839211)
 Depth worst-case error was 23.862089 bits at (107, 6)
  expected 0.911647; got 0.002813.
 Stencil failed at (0, 1).
  Expected 255; got 233.
PIGLIT: {"result": "fail" }

But I must admit that I've no experience with piglit, built and used it for the first time.

At this stage I just need a confirmation that more than 60% of apps work and show correct colors (mainly games). I don't expect all apps to be perfect right now.

That piglit sanity is failing with the patch may confirm my suspicion that something doesn't add up yet I'm afraid: Since the kernel driver and xf86-video-ati EXA code are using the same hardware formats for display/rendering with BE & LE, I was wondering how the patch could result in both display and glReadPixels working correctly for winsys buffers. Looks like indeed only display works correctly, which indicates that the GPU is effectively writing/reading PIPE_FORMAT_x8R8G8B8_* pixels like PIPE_FORMAT_B8G8R8x8_* (which is what the kernel driver and EXA code are using).

(In reply to Michel Dänzer from comment #29)
> That piglit sanity is failing with the patch may confirm my suspicion that
> something doesn't add up yet I'm afraid: Since the kernel driver and
> xf86-video-ati EXA code are using the same hardware formats for
> display/rendering with BE & LE, I was wondering how the patch could result
> in both display and glReadPixels working correctly for winsys buffers. Looks
> like indeed only display works correctly, which indicates that the GPU is
> effectively writing/reading PIPE_FORMAT_x8R8G8B8_* pixels like
> PIPE_FORMAT_B8G8R8x8_* (which is what the kernel driver and EXA code are
> using).

The patch is correct from the LE perspective. It simply adds ARGB support and was tested thoroughly on LE. The side effect is that BE can use the format now too, but there may be other issues with BE.

Download full text (4.2 KiB)

If this is the patch from the freedesktop thread then I am already running it will post my results soon.

Sent from my iPhone

> On Apr 30, 2016, at 2:52 PM, Marek Olšák <email address hidden> wrote:
>
> Created attachment 123370
> final fix?
>
> Could you please test this patch?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1432949
>
> Title:
> r300 Mesa driver not loading with KMS enabled
>
> Status in Mesa:
> Confirmed
> Status in mesa package in Ubuntu:
> Confirmed
>
> Bug description:
> I cannot get 3D acceleration to work. I was expecting to see the gears
> via the command 'glxgears' I have KMS enable on my iBook G4 by using
> the following parameter
>
> Linux radeon.modeset=1 video=offb:off video=1024x768-32
> video=radeonfb:off radeon.agpmode=-1
>
> Here are my Mesa and Xorg output
>
> rican-linux@ibookG4-UbuntuMATE:~$ cat /var/log/Xorg.0.log |grep -e radeon -e dri2 -e drm -e KMS
> [ 32.774] Kernel command line: root=UUID=fadadc01-6fd5-49fa-85f3-9e52d0fe6155 ro quiet splash video=offb:off video=1024x768-32 video=radeonfb:off radeon.modeset=1 video=offb:off video=1024x768-32 video=radeonfb:off radeon.agpmode=-1
> [ 33.203] (II) xfree86: Adding drm device (/dev/dri/card0)
> [ 35.011] (II) LoadModule: "radeon"
> [ 35.012] (II) Loading /usr/lib/xorg/modules/drivers/radeon_drv.so
> [ 35.337] (II) Module radeon: vendor="X.Org Foundation"
> [ 35.604] (II) [KMS] Kernel modesetting enabled.
> [ 35.697] (II) Loading sub module "dri2"
> [ 35.697] (II) LoadModule: "dri2"
> [ 35.697] (II) Module "dri2" already built-in
> [ 35.870] (II) RADEON(0): KMS Color Tiling: enabled
> [ 35.870] (II) RADEON(0): KMS Color Tiling 2D: disabled
> [ 35.870] (II) RADEON(0): KMS Pageflipping: enabled
> rican-linux@ibookG4-UbuntuMATE:~$ LIBGL_DEBUG=verbose glxinfo |grep render
> libGL: screen 0 does not appear to be DRI3 capable
> libGL: pci id for fd 4: 1002:4e56, driver r300
> libGL: OpenDriver: trying /usr/lib/powerpc-linux-gnu/dri/tls/r300_dri.so
> libGL: OpenDriver: trying /usr/lib/powerpc-linux-gnu/dri/r300_dri.so
> libGL error: No matching fbConfigs or visuals found
> libGL error: failed to load driver: r300
> libGL: OpenDriver: trying /usr/lib/powerpc-linux-gnu/dri/tls/swrast_dri.so
> libGL: OpenDriver: trying /usr/lib/powerpc-linux-gnu/dri/swrast_dri.so
> libGL error: No matching fbConfigs or visuals found
> libGL error: failed to load driver: swrast
> Error: couldn't find RGB GLX visual or fbconfig
> rican-linux@ibookG4-UbuntuMATE:~$ dpkg -l libgl1-mesa-dri
> Desired=Unknown/Install/Remove/Purge/Hold
> | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
> |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
> ||/ Name Version Architecture Description
> +++-==============-============-============-=================================
> ii libgl1-mesa-dr 10.5.0~rc1-0 powerpc free implementation of the OpenGL
> rican-linux@ibookG4-UbuntuMATE:~$
>
> rican-linux@ibookG4-UbuntuMATE:~$ lsb_release -rd
> Description: Ubuntu Vivid Vervet...

Read more...

Download full text (4.2 KiB)

I never use AGP it freezes the DE. I always have this set at yaboot radeon.agomode=-1

Sent from my iPhone

> On May 3, 2016, at 2:48 AM, Mathieu Malaterre <email address hidden> wrote:
>
> I believe that the testers should also make sure to use PCI instead of
> AGP during there testing. See bug:
> https://bugs.freedesktop.org/show_bug.cgi?id=95017.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1432949
>
> Title:
> r300 Mesa driver not loading with KMS enabled
>
> Status in Mesa:
> Confirmed
> Status in mesa package in Ubuntu:
> Confirmed
>
> Bug description:
> I cannot get 3D acceleration to work. I was expecting to see the gears
> via the command 'glxgears' I have KMS enable on my iBook G4 by using
> the following parameter
>
> Linux radeon.modeset=1 video=offb:off video=1024x768-32
> video=radeonfb:off radeon.agpmode=-1
>
> Here are my Mesa and Xorg output
>
> rican-linux@ibookG4-UbuntuMATE:~$ cat /var/log/Xorg.0.log |grep -e radeon -e dri2 -e drm -e KMS
> [ 32.774] Kernel command line: root=UUID=fadadc01-6fd5-49fa-85f3-9e52d0fe6155 ro quiet splash video=offb:off video=1024x768-32 video=radeonfb:off radeon.modeset=1 video=offb:off video=1024x768-32 video=radeonfb:off radeon.agpmode=-1
> [ 33.203] (II) xfree86: Adding drm device (/dev/dri/card0)
> [ 35.011] (II) LoadModule: "radeon"
> [ 35.012] (II) Loading /usr/lib/xorg/modules/drivers/radeon_drv.so
> [ 35.337] (II) Module radeon: vendor="X.Org Foundation"
> [ 35.604] (II) [KMS] Kernel modesetting enabled.
> [ 35.697] (II) Loading sub module "dri2"
> [ 35.697] (II) LoadModule: "dri2"
> [ 35.697] (II) Module "dri2" already built-in
> [ 35.870] (II) RADEON(0): KMS Color Tiling: enabled
> [ 35.870] (II) RADEON(0): KMS Color Tiling 2D: disabled
> [ 35.870] (II) RADEON(0): KMS Pageflipping: enabled
> rican-linux@ibookG4-UbuntuMATE:~$ LIBGL_DEBUG=verbose glxinfo |grep render
> libGL: screen 0 does not appear to be DRI3 capable
> libGL: pci id for fd 4: 1002:4e56, driver r300
> libGL: OpenDriver: trying /usr/lib/powerpc-linux-gnu/dri/tls/r300_dri.so
> libGL: OpenDriver: trying /usr/lib/powerpc-linux-gnu/dri/r300_dri.so
> libGL error: No matching fbConfigs or visuals found
> libGL error: failed to load driver: r300
> libGL: OpenDriver: trying /usr/lib/powerpc-linux-gnu/dri/tls/swrast_dri.so
> libGL: OpenDriver: trying /usr/lib/powerpc-linux-gnu/dri/swrast_dri.so
> libGL error: No matching fbConfigs or visuals found
> libGL error: failed to load driver: swrast
> Error: couldn't find RGB GLX visual or fbconfig
> rican-linux@ibookG4-UbuntuMATE:~$ dpkg -l libgl1-mesa-dri
> Desired=Unknown/Install/Remove/Purge/Hold
> | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
> |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
> ||/ Name Version Architecture Description
> +++-==============-============-============-=================================
> ii libgl1-mesa-dr 10.5.0~rc1-0 powerpc free implementation of the OpenGL
> rican-linux@ibookG4-UbuntuMATE:~$
>
> rican-linux@ibookG...

Read more...

Download full text (4.6 KiB)

I can verify the patch works. However there are some issues

1. I see my colors are off when I use compiz as my WM and try to rotate the
cube.

2.piglit samity tests fail with this error:
spec/!opengl 1.0/gl-1.0-readpixsanity/gl-1.0-readpixsanity: fail

3. games like alien-arean and supertuxkart crash my system when trying to
load the game.

4. I can play video in mpv using opengl but get the following error:
[vo/opengl] Could not create EGL context!

Herminio

On Fri, May 6, 2016 at 8:57 AM, Bug Watch Updater <
<email address hidden>> wrote:

> ** Bug watch added: freedesktop.org Bugzilla #95017
> https://bugs.freedesktop.org/show_bug.cgi?id=95017
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1432949
>
> Title:
> r300 Mesa driver not loading with KMS enabled
>
> Status in Mesa:
> Confirmed
> Status in mesa package in Ubuntu:
> Confirmed
>
> Bug description:
> I cannot get 3D acceleration to work. I was expecting to see the gears
> via the command 'glxgears' I have KMS enable on my iBook G4 by using
> the following parameter
>
> Linux radeon.modeset=1 video=offb:off video=1024x768-32
> video=radeonfb:off radeon.agpmode=-1
>
> Here are my Mesa and Xorg output
>
> rican-linux@ibookG4-UbuntuMATE:~$ cat /var/log/Xorg.0.log |grep -e
> radeon -e dri2 -e drm -e KMS
> [ 32.774] Kernel command line:
> root=UUID=fadadc01-6fd5-49fa-85f3-9e52d0fe6155 ro quiet splash
> video=offb:off video=1024x768-32 video=radeonfb:off radeon.modeset=1
> video=offb:off video=1024x768-32 video=radeonfb:off radeon.agpmode=-1
> [ 33.203] (II) xfree86: Adding drm device (/dev/dri/card0)
> [ 35.011] (II) LoadModule: "radeon"
> [ 35.012] (II) Loading /usr/lib/xorg/modules/drivers/radeon_drv.so
> [ 35.337] (II) Module radeon: vendor="X.Org Foundation"
> [ 35.604] (II) [KMS] Kernel modesetting enabled.
> [ 35.697] (II) Loading sub module "dri2"
> [ 35.697] (II) LoadModule: "dri2"
> [ 35.697] (II) Module "dri2" already built-in
> [ 35.870] (II) RADEON(0): KMS Color Tiling: enabled
> [ 35.870] (II) RADEON(0): KMS Color Tiling 2D: disabled
> [ 35.870] (II) RADEON(0): KMS Pageflipping: enabled
> rican-linux@ibookG4-UbuntuMATE:~$ LIBGL_DEBUG=verbose glxinfo |grep
> render
> libGL: screen 0 does not appear to be DRI3 capable
> libGL: pci id for fd 4: 1002:4e56, driver r300
> libGL: OpenDriver: trying /usr/lib/powerpc-linux-gnu/dri/tls/r300_dri.so
> libGL: OpenDriver: trying /usr/lib/powerpc-linux-gnu/dri/r300_dri.so
> libGL error: No matching fbConfigs or visuals found
> libGL error: failed to load driver: r300
> libGL: OpenDriver: trying
> /usr/lib/powerpc-linux-gnu/dri/tls/swrast_dri.so
> libGL: OpenDriver: trying /usr/lib/powerpc-linux-gnu/dri/swrast_dri.so
> libGL error: No matching fbConfigs or visuals found
> libGL error: failed to load driver: swrast
> Error: couldn't find RGB GLX visual or fbconfig
> rican-linux@ibookG4-UbuntuMATE:~$ dpkg -l libgl1-mesa-dri
> Desired=Unknown/Install/Remove/Purge/Hold
> |
> Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
...

Read more...

I can verify the patch works. However there are some issues

1. I see my colors are off when I use compiz as my WM and try to rotate the cube.

2.piglit samity tests fail with this error:
spec/!opengl 1.0/gl-1.0-readpixsanity/gl-1.0-readpixsanity: fail

3. games like alien-arean and supertuxkart crash my system when trying to load the game.

4. I can play video in mpv using opengl but get the following error:
[vo/opengl] Could not create EGL context!

(In reply to Marek Olšák from comment #30)
> The patch is correct from the LE perspective. It simply adds ARGB support
> and was tested thoroughly on LE. The side effect is that BE can use the
> format now too, but there may be other issues with BE.

Makes sense. Maybe we can use bug 43698 to track the remaining issues.

Fixed by 172bfdaa9e80342ade3f023f72d455d76713b866. Closing.

Changed in mesa:
status: Confirmed → Fix Released
ernsteiswuerfel (erhard-f) wrote :

As of Yakkety's todays daily iso (24.07.2016) this bug is gone due to an update mesa-11.2.1 -> mesa-12.0.1.

Changed in mesa (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.