Chrome causes segfault in i965_dri.so

Bug #1371834 reported by Joel Stanley on 2014-09-20
200
This bug affects 45 people
Affects Status Importance Assigned to Milestone
Chromium Browser
Unknown
Unknown
Debian
Fix Released
Unknown
mesa (Ubuntu)
High
Unassigned

Bug Description

Running chrome 38.0.2125.66-1 on Ubuntu 14.10, on Lenovo X230

When I start a new instance of chrome, it cannot enable WebGL. I have reported that bug separately to chrome at https://code.google.com/p/chromium/issues/detail?id=416207

I suspect the cause of the bug is in mesa, as dmesg contains evidence of a segfault:

[31979.398090] chrome[24013]: segfault at 20 ip 00007fbbd5ca5d83 sp 00007fffd7669ab0 error 4 in i965_dri.so[7fbbd59c4000+50a000]
[31979.585606] chrome[24104]: segfault at 20 ip 00007f7550c26d83 sp 00007fff970b4630 error 4 in i965_dri.so[7f7550945000+50a000]
[31979.737378] chrome[24117]: segfault at 20 ip 00007ffd06e45d83 sp 00007fffc989f440 error 4 in i965_dri.so[7ffd06b64000+50a000]

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: libgl1-mesa-dri 10.2.6-1ubuntu3
ProcVersionSignature: Ubuntu 3.16.0-16.22-generic 3.16.2
Uname: Linux 3.16.0-16-generic x86_64
ApportVersion: 2.14.7-0ubuntu2
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
CurrentDesktop: GNOME
Date: Sat Sep 20 11:17:41 2014
DistUpgraded: 2014-09-02 14:59:08,481 DEBUG failed to SystemUnLock() (E:Not locked)
DistroCodename: utopic
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, including running git bisection searches
GraphicsCard:
 Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:21fa]
MachineType: LENOVO 23301B9
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.16.0-16-generic root=/dev/mapper/hostname--vg-root ro splash quiet crashkernel=384M-:128M crashkernel=384M-:128M nomdmonddf nomdmonisw crashkernel=384M-:128M vt.handoff=7
SourcePackage: mesa
UpgradeStatus: Upgraded to utopic on 2014-09-02 (17 days ago)
dmi.bios.date: 07/09/2013
dmi.bios.vendor: LENOVO
dmi.bios.version: G2ET95WW (2.55 )
dmi.board.asset.tag: Not Available
dmi.board.name: 23301B9
dmi.board.vendor: LENOVO
dmi.board.version: 0B98401 Pro
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvrG2ET95WW(2.55):bd07/09/2013:svnLENOVO:pn23301B9:pvrThinkPadX230:rvnLENOVO:rn23301B9:rvr0B98401Pro:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 23301B9
dmi.product.version: ThinkPad X230
dmi.sys.vendor: LENOVO
version.compiz: compiz N/A
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.56-1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.2.6-1ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.2.6-1ubuntu3
version.xserver-xorg-core: xserver-xorg-core 2:1.16.0-1ubuntu1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.9.0-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.4.0-2ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.914-1~exp1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.11-1ubuntu2
xserver.bootTime: Fri Sep 19 15:45:16 2014
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 4204
 vendor AUO
xserver.version: 2:1.16.0-1ubuntu1

Joel Stanley (shenki) wrote :
Changed in debian:
status: Unknown → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mesa (Ubuntu):
status: New → Confirmed
Gérard Bigot (gerard-bigot) wrote :

Found [1] here a workaround :

run chrome with :

   LIBGL_DRI3_DISABLE=1 google-chrome

makes webgl come back.

[1]:https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=757435

Tito (tito-webtito) wrote :

I can confirm this very annoying bug with i915 driver (on Lenovo x220).

It creates all sorts of graphical difficulties in Chromium (no vsync, no interpolation of fullscreen videos, and of course no WebGL)

 LIBGL_DRI3_DISABLE=1 is a good fix.

william fischer (maxxjvx) wrote :

I tried the "fix" described in #3 and sure enough, I was able to use Google Maps with Earth view. With out the export, it just Satellite view and regular map view only.

[ 1240.775010] chromium-browse[6013]: segfault at 1f8 ip 00007f255e9ae63f sp 00007fffc5d9a490 error 4 in i965_dri.so[7f255e65b000+51c000]

Linux UBLNX415DK 3.16.0-24-generic #32-Ubuntu SMP Tue Oct 28 13:07:32 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
Description: Ubuntu 14.10
Release: 14.10
Codename: utopic

Changed in mesa (Ubuntu):
importance: Undecided → High
zob (zob) wrote :

I get this on a Toshiba satellite A200.

vera@vera-Satellite-A200:~$ lsb_release -a && uname -a && lspci | grep VGA && sudo lshw -C display && sudo tail -n 500 /var/log/syslog | grep segfault
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 14.10
Release: 14.10
Codename: utopic
Linux vera-Satellite-A200 3.16.0-24-generic #32-Ubuntu SMP Tue Oct 28 13:07:32 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) (rev 0c)
  *-display:0
       description: VGA compatible controller
       product: Mobile GM965/GL960 Integrated Graphics Controller (primary)
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 0c
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:47 memory:fc000000-fc0fffff memory:d0000000-dfffffff ioport:1800(size=8)
  *-display:1 UNCLAIMED
       description: Display controller
       product: Mobile GM965/GL960 Integrated Graphics Controller (secondary)
       vendor: Intel Corporation
       physical id: 2.1
       bus info: pci@0000:00:02.1
       version: 0c
       width: 64 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list
       configuration: latency=0
       resources: memory:fc100000-fc1fffff
Nov 7 13:45:14 vera-Satellite-A200 kernel: [ 278.520597] chrome[3252]: segfault at 1f8 ip 00007fcfec6e963f sp 00007fff01827f90 error 4 in i965_dri.so[7fcfec396000+51c000]
Nov 7 13:45:16 vera-Satellite-A200 kernel: [ 280.024896] chrome[3360]: segfault at 1f8 ip 00007f9f479e263f sp 00007fff3e64a660 error 4 in i965_dri.so[7f9f4768f000+51c000]
Nov 7 13:45:16 vera-Satellite-A200 kernel: [ 280.634651] chrome[3377]: segfault at 1f8 ip 00007f7d09e8763f sp 00007fffd97b16d0 error 4 in i965_dri.so[7f7d09b34000+51c000]
Nov 7 14:22:07 vera-Satellite-A200 kernel: [ 2491.312700] chrome[4597]: segfault at 1f8 ip 00007f1aed7e863f sp 00007fff40586950 error 4 in i965_dri.so[7f1aed495000+51c000]
Nov 7 14:22:08 vera-Satellite-A200 kernel: [ 2492.712524] chrome[4690]: segfault at 1f8 ip 00007f14516d063f sp 00007fffcd6ba780 error 4 in i965_dri.so[7f145137d000+51c000]
Nov 7 14:22:09 vera-Satellite-A200 kernel: [ 2493.416469] chrome[4701]: segfault at 1f8 ip 00007f3cf8ec863f sp 00007fff4ab763f0 error 4 in i965_dri.so[7f3cf8b75000+51c000]

zob (zob) wrote :

This happens in chrome-stable 38.0.2125.111-1, chrome-beta 39.0.2171.52-1, and chrome unstable 40.0.2209.0-1 when browsing chrome webstore (with this graphics card).

It does not happen when browsing chrome webstore with chromium 37.0.2062.120 or firefox 33.

http://ubuntuforums.org/showthread.php?t=2248299

zob (zob) wrote :

Btw. Those result were from a test in ubuntu 12.04.5 on both the 3.13 (trusty) and the 3.2 (precise) kernel and libgl1-mesa-dri 8.0.4-0ubuntu0.7

zob (zob) wrote :

Just tested this with the kernel from vivid (3.18rc2): http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.18-rc2-vivid/

On my system the bug is no longer present in that kernel, i.e. Chrome 38+ doesn't segfault when opening chrome webshop.

zob (zob) wrote :

Ok. Just tested quite a few kernels.
Chrome 38+ does not segfault when browsing to chrome webshop with the following:
linux-image-3.16.0-031600-generic
linux-image-3.16.1-031601-generic
linux-image-3.16.7-031607-generic
linux-image-3.17.1-031701-generic
linux-image-3.18.0-031800rc2-generic

Chrome 38+ segfaults when browsing to chrome webshop with the following:
linux-image-3.15.10-031510-generic
linux-image-3.13.0-39-generic
linux-image-3.13.0-32-generic
and with every other kernel that I have tested with a version number lower than that.

Now someone can probably say something more intelligent about when it was patched. I'm just a trial and error kind of guy.

NB: Chrome 37 and older does not crash with any of these kernels when browsing to chrome webshop.

zob (zob) wrote :
Changed in debian:
status: New → Confirmed
Changed in debian:
status: Confirmed → Fix Released
Timo Aaltonen (tjaalton) wrote :

should be fixed by now

Changed in mesa (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.