FFE: please enable opencl

Bug #1319835 reported by Oibaf on 2014-05-15
86
This bug affects 21 people
Affects Status Importance Assigned to Milestone
mesa (Ubuntu)
Wishlist
Unassigned

Bug Description

Please enable OpenCL in mesa package which is already available in debian package and was disabled in 10.1.0-1ubuntu1.

Thanks.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mesa (Ubuntu):
status: New → Confirmed
techzilla (techzilla) on 2014-06-28
tags: added: utopic
Maarten Lankhorst (mlankhorst) wrote :

I don't think there's a point to opencl at the moment, as soon as something in the archive really needs it feel free to reopen it.

Changed in mesa (Ubuntu):
status: Confirmed → Won't Fix
luke (lukefromdc) wrote :

GIMP may not be on the installer, but it's in repo and can use OpenCL. If Ubuntu compiles Mesa without OpenCL support, that means using OpenCL requires switching to the Oibaf PPA version or to Xorg-edgers. That, in turn, forces users other than hackers to use these PPA's, which are meant for people like myself familiar with system administration.

Unless someone wants to start a "mesa-stable" PPA like the "kdenlive-stable" (sunab) PPA, I see a lot of headaches coming from this decision. Not compiling in support is quite different than simply not including a library that can be brought in from the main repos.

I can only see one valid reason to disable something like OpenCL or VDPAU: if there is at least one videocard anywhere for which enabling them will generate a black screen, a refusal to modeset, or at least a refusal to run 3d graphics. Is this the case with OpenCL?

Graham Inggs (ginggs) on 2015-02-03
Changed in mesa (Ubuntu):
status: Won't Fix → New
Graham Inggs (ginggs) wrote :

Re-opening.

ocl-icd (LP: #1382086) and khronos-opencl-headers (LP: #1382091) have both now been included in main.
There are now many packages in Ubuntu that can make use of OpenCL:
bfgminer, erlang, wine, starpum viennacl, among others

Oibaf (oibaf) wrote :

Any reasons you are un-duplicating this while the references issue bug #1366709 is still open with more information?

Graham Inggs (ginggs) wrote :

Sorry for the bug noise. I needed to unmark this as a duplicate in order to re-open it.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mesa (Ubuntu):
status: New → Confirmed
Graham Inggs (ginggs) wrote :

Waiting on LP: #1412441

Changed in mesa (Ubuntu):
importance: Undecided → Wishlist
Mikado (roobsi93) wrote :

Is opencl support going to be in 15.10? That would be great

Graham Inggs (ginggs) wrote :

It doesn't seem likely. Apparently the updated libclc package requires llvm 3.7 which currently FTBFS on i386:
https://launchpad.net/ubuntu/+source/llvm-toolchain-3.7/1:3.7-1ubuntu1

Oibaf (oibaf) wrote :

Xenial has an updated libclc built with llvm 3.7. Can mesa OpenCL be enabled now? Note libclc is still in universe currently, see #1412441. Duplicate #1366709 lists packages that may use OpenCL.

Timo Aaltonen (tjaalton) wrote :

llvm 3.7 won't move to main, 3.8 will once it's available and mesa will switch to it too

Oibaf (oibaf) wrote :

llvm 3.8 is in xenial and builds fine now.

Timo Aaltonen (tjaalton) wrote :

good news; recent archive reorg makes it possible for mesa to build-depend on packages which are not in main so I'll enable this, which will also make the diff to debian a bit smaller.

summary: - please enable opencl
+ FFE: please enable opencl
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mesa - 11.2.0-1ubuntu2

---------------
mesa (11.2.0-1ubuntu2) xenial; urgency=medium

  * control, rules: Enable mesa-opencl-icd now that the archive reorg
    allows to build-depend on packages from universe. (LP: #1319835)

 -- Timo Aaltonen <email address hidden> Thu, 14 Apr 2016 14:20:56 +0300

Changed in mesa (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers