new upstream release 9.1.7

Bug #1236340 reported by Maarten Lankhorst on 2013-10-07
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mesa (Ubuntu)
High
Maarten Lankhorst
Raring
Undecided
Unassigned

Bug Description

[Impact]
Fixes following upstream bugs:
 (9.1.5)
    58384 - [i965 Bisected]Oglc max_values(advanced.fragmentProgram.GL_MAX_PROGRAM_ENV_PARAMETERS_ARB) segfault
    62647 - Wrong rendering of Dota 2 on Wine (apitrace attached) - Intel IVB HD4000
    63674 - [IVB]frozen at the first frame when run Unigine-heaven 4.0
    65910 - Killing weston-launch causes segv in desktop-shell
 (9.1.6)
    47824 - osmesa using --enable-shared-glapi depends on libgl
    62362 - Crash when using Wayland EGL platform
    63435 - [Regression since 9.0] Flickering in EGL OpenGL full-screen window with swap interval 1
    64087 - Webgl conformance shader-with-non-reserved-words crash when mesa is compiled without --enable-debug
    64330 - WebGL snake demo crash in loop_analysis.cpp:506: bool is_loop_terminator(ir_if*): assertion „inst != __null“ failed.
    65236 - [i965] Rendering artifacts in VDrift/GL2
    66558 - RS690: 3D artifacts when playing SuperTuxKart
    66847 - compilation broken with llvm 3.3
    66850 - glGenerateMipmap crashes when using GL_TEXTURE_2D_ARRAY with compressed internal format
    66921 - [r300g] Heroes of Newerth: HiZ related corruption
    67283 - VDPAU doesn't work on hybrid laptop through DRI_PRIME
 (9.1.7)
    55503 - Constant vertex attributes broken
    61635 - glVertexAttribPointer(id, GL_UNSIGNED_BYTE, GL_FALSE,...) does not work
    65958 - GPU Lockup on Trinity 7500G
    66292 - [SNB/IVB/HSW Bisected]Ogles3conform GL3Tests_depth24_depth24_basic.test fail
    67548 - glGetAttribLocation seems to be broken
    68195 - piglit tests vs-struct-pad and fs-struct-pad both fail
    68250 - Automatic mipmap generation with texture compression produces borders that fade to black
    69525 - [GM45, bisected] Piglit tex-shadow2drect fails

[Test case]
* A full piglit run will be done on i915, nouveau and ati. Unity dash will be explicitly tested on intel cards for any slowdowns.

[Regression potential]
* Saucy had mesa up to 9.1.6 before switching to the 9.2 branch. There were no specific regressions from the 9.1.4 version in raring-updates. But there's always the possibility for regressions like gpu lockups and rendering errors. Those should be watched.

[Other]
Mesa has a MRE.

Hello Maarten, or anyone else affected,

Accepted mesa into raring-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/mesa/9.1.7-1ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in mesa (Ubuntu):
status: In Progress → Invalid
Changed in mesa (Ubuntu Raring):
status: New → Fix Committed
tags: added: verification-needed
Chris Halse Rogers (raof) wrote :

Hello Maarten, or anyone else affected,

Accepted mesa into raring-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/mesa/9.1.7-1ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Maarten Lankhorst (mlankhorst) wrote :

G33: No slow dash, seems to work correctly.
Sandy bridge: Dash was fast, glx-copy-sub-buffer had 1 regression, but looks like it is a flaky test. It claims 1 fix too. Some other tests were fixed.

Maarten Lankhorst (mlankhorst) wrote :

radeon: works, one test that failed to link is now crashing. But it printed � before, so big chance it was just showing garbage and under the right conditions it would already crash.

Maarten Lankhorst (mlankhorst) wrote :

nouveau: 3 tests failing. retesting them on 9.1.4 shows that they're flaky before too, so not a real regression.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mesa - 9.1.7-1ubuntu2

---------------
mesa (9.1.7-1ubuntu2) raring-proposed; urgency=low

  * Fix build by installing drirc again.

mesa (9.1.7-1ubuntu1) raring-proposed; urgency=low

  * Merge from released unstable, new upstream release. (LP: #1236340)

mesa (9.1.7-1) unstable; urgency=low

  [ Andreas Beckmann ]
  * libgl1-mesa-glx: Add Breaks: glx-diversions (<< 0.4) because the old
    versions were not aware of libGL.so.1.2.0. (Closes: #720069)

  [ Maarten Lankhorst ]
  * New upstream release.

mesa (9.1.6-2) unstable; urgency=low

  * Don't run 'make -j' if DEB_BUILD_OPTIONS doesn't set parallel. Oops.

mesa (9.1.6-1) unstable; urgency=low

  [ Andreas Boll ]
  * New upstream release. (Closes: #717410)
  * Cherry-pick commit 0dbbfa0 (mesa: Fix MESA_PATCH version) from
    upstream.

  [ Julien Cristau ]
  * Don't run configure for different builds in parallel.

mesa (9.1.4-1) unstable; urgency=low

  [ Julien Cristau ]
  * Don't call wayland_buffer_is_drm from libgbm, it's in libEGL
    (closes: #712556).
  * Make sure libgbm doesn't have undefined symbols.

  [ Andreas Boll ]
  * Use dpkg-buildflags.
  * Disable silent rules.
  * Cherry-pick commit 0829b89 (mesa: Fix ieee fp on Alpha) from upstream
    (Fixes FTBFS on alpha)

  [ Timo Aaltonen ]
  * New upstream release.

  [ Julien Cristau ]
  * libegl1-mesa-drivers depends on libgl1-mesa-dri for libllvmradeon
    (closes: #714828)
 -- Maarten Lankhorst <email address hidden> Wed, 09 Oct 2013 11:47:40 +0200

Changed in mesa (Ubuntu Raring):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers