new upstream release 9.1.4

Bug #1197363 reported by Timo Aaltonen on 2013-07-03
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mesa (Ubuntu)
Undecided
Unassigned
Raring
High
Unassigned

Bug Description

[Impact]
Fixes following upstream bugs:

37871 - [bisected i965] Bus error (core dumped) on oglc texdecaltile
42182 - egl/opengles1/tri_x11 renders wrong
44958 - [SNB IVB HSW] mesa demo test texleak bus error
53494 - [snb] crash in texsubimage to a large atlas in clutter
60518 - glDrawElements segfault when compiled into display list
61821 - src/mesa/drivers/dri/common/xmlpool.h:96:29: fatal error: xmlpool/options.h
63520 - r300g regression (RV380): Strange rendering of light sources in Penumbra (bisected)
63701 - [HSW] support new haswell graphics [8086:0a2e]
64727 - [gm45, bisected] some piglit glsl 1.10 built-in-functions tests crash
64745 - [llvmpipe] SIGSEGV src/gallium/state_trackers/glx/xlib/glx_api.c:1374
64934 - [llvmpipe] SIGSEGV src/gallium/state_trackers/glx/xlib/glx_api.c:1363
65173 - segfault in _mesa_get_format_datatype and _mesa_get_color_read_type when state dumping with glretrace

[Test case]
* Package is uploaded to saucy, a full piglit run will be done on i915, nouveau and ati.

[Regression potential]
* There's always the possibility for regressions like gpu lockups and rendering errors. Those should be watched.

[Other]
Mesa has a MRE

Timo Aaltonen (tjaalton) on 2013-07-03
Changed in mesa (Ubuntu):
status: New → Fix Released
Changed in mesa (Ubuntu Raring):
status: New → In Progress
importance: Undecided → High

Hello Timo, or anyone else affected,

Accepted mesa into raring-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/mesa/9.1.4-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in mesa (Ubuntu Raring):
status: In Progress → Fix Committed
tags: added: verification-needed
Adam Conrad (adconrad) wrote :

Hello Timo, or anyone else affected,

Accepted mesa-lts-raring into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/mesa-lts-raring/9.1.4-0ubuntu0.1~precise1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Maarten Lankhorst (mlankhorst) wrote :

result from piglit runs 9.1.3 -> 9.1.4: snb has no regressions, some fixes

ati shows some regressions, but it looks like this is a bug in piglit with parallel runs, the failures I've examined are either known flaky tests, or of this format:
<type 'exceptions.IOError'>[Errno 9] Bad file descriptor

Backtrace:
  File "/home/mlankhorst/nfs/xorg/piglit/framework/core.py", line 462, in doRun
    result = self.run(env.valgrind)
  File "/home/mlankhorst/nfs/xorg/piglit/framework/exectest.py", line 87, in run
    self.get_command_result(command, fullenv)
  File "/home/mlankhorst/nfs/xorg/piglit/framework/exectest.py", line 192, in get_command_result
    out, err = proc.communicate()
  File "/usr/lib/python2.7/subprocess.py", line 806, in communicate
    return self._communicate(input)
  File "/usr/lib/python2.7/subprocess.py", line 1382, in _communicate
    stdout, stderr = self._communicate_with_poll(input)
  File "/usr/lib/python2.7/subprocess.py", line 1462, in _communicate_with_poll
    close_unregister_and_remove(fd)
  File "/usr/lib/python2.7/subprocess.py", line 1419, in close_unregister_and_remove
    fd2file[fd].close()

Maarten Lankhorst (mlankhorst) wrote :

Nouveau has some regressions since the last run a few months ago, but the failing tests all have in common that they have a M2MF copy error. Because nouveau has been completely untouched after 9.1.3 after restesting I couldn't get 9.1.3 to pass it looks like the tests didn't regress, and I have a kernel bug to track down. :P I'll retest ati shortly.

Maarten Lankhorst (mlankhorst) wrote :

Oh I forgot to add, the ati issues didn't appear to be regressions after retesting, it's just a kernel issue.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mesa - 9.1.4-0ubuntu0.1

---------------
mesa (9.1.4-0ubuntu0.1) raring-proposed; urgency=low

  * New upstream bugfix release 9.1.4. (LP: #1197363)
    - fix a GPU hang with GT3. (LP: #1197316)
  * Dropped patches that are included in this release
  * revert-a64c1eb9b110.diff: updated.
 -- Timo Aaltonen <email address hidden> Wed, 03 Jul 2013 13:54:33 +0300

Changed in mesa (Ubuntu Raring):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers