new upstream release 9.1.3

Bug #1183269 reported by Maarten Lankhorst on 2013-05-23
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
mesa (Ubuntu)
Undecided
Maarten Lankhorst
Raring
Undecided
Unassigned

Bug Description

[Impact]
 * Improves support for richland by adding new pci ids.
 * Closest the following upstream bugs in 9.1.3:
    39251 - Second Life viewers from release 2.7.4.235167 to the last 3.4.0.264911 crash on start.
    47478 - [wine] GLX_DONT_CARE does not work for GLX_DRAWABLE_TYPE or GLX_RENDER_TYPE
    56416 - [SNB bisected] SNB hang with rc6 and hiz on glxgears (and other GL apps) immediately after xinit.
    57436 - [GLSL1.40 IVB/HSW]Piglit spec/glsl-1.40/compiler_built-in-functions/inverse-mat2.frag fails    61554 - [ivb] Mesa 9.1 performance regression on KWin's Lanczos shader
    61773 - abort is an incredibly not-smart way to handle IR validation
    62868 - solaris build broken with missing ffsll
    62999 - glXChooseFBConfig with GLX_DRAWABLE_TYPE, GLX_DONT_CARE fails    63078 - EGL X11 Regression: Maximum swap interval is 0 (worked with 9.0)
    63447 - [i965 Bisected]Ogles1conform/Ogles2conform/Ogles3conform cases segfault
    64662 - [SNB 9.1 Bisected]Ogles2conform GL2ExtensionTests/depth_texture_cube_map/depth_texture_cube_map.test fail
 * Closes the following upstream bugs in 9.1.2:
    44567 - [965gm] green artifacts when using GLSL in XBMC
    59238 - many new symbols in libxatracker after recent automake work
    59445 - [SNB/IVB/HSW Bisected]Oglc draw-buffers2(advanced.blending.none) segfault
    59495 - [i965 Bisected]Oglc fbblit(advanced.blitFb-3d-cube.mirror.both) fails
    60503 - [r300g] Unigine Heaven 3.0: all objects are black
    60510 - Firefox 18.0.2 Crash On Nvidia GeForce2
    61197 - [SNB Bisected] kwin_gles screen corruption
    61317 - [IVB] corrupt rendering with UBOs
    61395 - glEdgeFlag can't be set to false
    61947 - nullpointer dereference causes xorg-server segfault when nouveau DRI driver is loaded
    62357 - llvmpipe: Fragment Shader with "return" in main causes back output
    62434 - [bisected] 3284.073] (EE) AIGLX error: dlopen of /usr/lib/xorg/modules
    Debian #349437 - mesa - FTBFS: error: 'IEEE_ONE' undeclared
    Redhat #918661 - crash in routine Avogadro UI manipulation

[Test Case]
 * Package is uploaded to saucy, a full piglit run will be done on i915, nouveau and ati.
 * Make sure that the unity dash blur is still fast on all cards.

[Regression Potential]
 * Previous mesa had a patch reverted that caused unity's dash blur effect to be slow. Fixes have been pulled into 9.1.3 for this, and the revert no longer applies.
 * There's always the possibility for regressions like gpu lockups and rendering errors. Those should be watched.

[Other Info]
 * Mesa has a MRE.

Timo Aaltonen (tjaalton) on 2013-05-23
tags: added: raring
bugbot (bugbot) on 2013-05-23
tags: added: kubuntu
Timo Aaltonen (tjaalton) wrote :

fixed in saucy

Changed in mesa (Ubuntu):
status: New → Fix Released
Chris Halse Rogers (raof) wrote :

Oooh, the ABI tag patch is now upstream? Yay!

Changed in mesa (Ubuntu Raring):
status: New → Fix Committed
tags: added: verification-needed

Hello Maarten, or anyone else affected,

Accepted mesa into raring-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/mesa/9.1.3-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

pablomme (pablomme) wrote :

The packages in proposed have brought back the slow dash bug for my Intel HD 4000 (Ivy Bridge, Core i7 3720QM).

Maarten Lankhorst (mlankhorst) wrote :

SNB seems unaffected, it's just ivy bridge with the slowness issue. I can reproduce it on my snb too. Can we keep the package in -proposed for a bit longer, to get better test coverage for the other hardware?

Edward Donovan (edward.donovan) wrote :

I edited the original report, above, removing the word 'bug' before all the upstream bug numbers. Launchpad had the wrong idea, linking them all to the wrong local bugs. It just makes for confusion, I think. Anyway, I'll try to report back later, on how this works on my Ivy Bridge system. Thanks.

description: updated
Edward Donovan (edward.donovan) wrote :

On my Ivy Bridge system, the dash now opens very slowly. Window and viewport switching are also glacially slow. A few other upgrades, like the kernel, arrived at the same time. But with pablomme's report, too, it seems more likely to be this.

Specifically it's Ivy Bridge GT2, aka HD 4500.

I'll try to grab the older packages, and downgrade mesa, to confirm.

Thanks.

description: updated
description: updated
Edward Donovan (edward.donovan) wrote :

Now I've found bug 1183269, and see that fixed packages are coming. Thanks.

Edward Donovan (edward.donovan) wrote :

Ugh, that was the number for this bug. I mean bug 1187500. Sorry for the bug spam.

Dave Chiluk (chiluk) wrote :

I think this should go to verification failed, as it introduced 1187500 which basically makes the dash and alt-tab unusable.

Chris Halse Rogers (raof) wrote :

Hello Maarten, or anyone else affected,

Accepted mesa into raring-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/mesa/9.1.3-0ubuntu0.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

pablomme (pablomme) wrote :

Version 9.1.3-0ubuntu0.2 fixes the slow blur problem for me.

Dave Chiluk (chiluk) wrote :

Yep 9.1.3-0ubuntu0.2 available from bug #1187500 resolves the issue .

Moved this bug to regression-proposed and verification-failed per the SRUVerification page.

tags: added: regression-proposed verification-failed
removed: verification-needed
tags: added: verification-done
removed: regression-proposed verification-failed
Maarten Lankhorst (mlankhorst) wrote :

Bit late, at most the verification-failed tag would have been appropriate for 9.1.3-0ubuntu0.1. Because this is fixed with a new upload to -proposed, so it no longer applies.

Anyway I did a piglit run, surprisingly here have been no regressions except two on my nvd9 with nouveau. ati and intel had none.

The first one was in EGL_NOK_swap_region -- but swapping and vblank were disabled because that card has no physical output, so I think it was a race.
The other test has been failing on intel too, with the exact same error message. I think the test may be unreliable.

I'm marking this bug as verification-done, considering there have been reports of #1187500 slowness being fixed I'll mark that as verification-done too. If the slowness issue persists modify that bug, not this one..

Maarten Lankhorst (mlankhorst) wrote :

The failing test passed on nvd9 after a manual retry, so I blame the test being flaky. :-)

Colin Watson (cjwatson) wrote :

Waiving the usual waiting period by a few hours since this is blocking progress on bug 1175533.

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mesa - 9.1.3-0ubuntu0.2

---------------
mesa (9.1.3-0ubuntu0.2) raring-proposed; urgency=low

  * Add back a patch that reverts a change which made blur slow on i915,
    add two other reverts so the big one applies cleanly. (LP: #1187500)

mesa (9.1.3-0ubuntu0.1) raring-proposed; urgency=low

  * New upstream micro-release. (LP: #1183269)
  * Drop revert-a64c1eb9b110.diff; it no longer applies.
    - The patch reverted the regression where the unity dash appeared
      very slowly, but should no longer be needed with the upstream fixes.
 -- Timo Aaltonen <email address hidden> Fri, 07 Jun 2013 17:33:27 +0300

Changed in mesa (Ubuntu Raring):
status: Fix Committed → Fix Released

Hello Maarten, or anyone else affected,

Accepted mesa-lts-raring into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/mesa-lts-raring/9.1.4-0ubuntu0.1~precise1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: removed: verification-done
tags: added: verification-needed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers