sis dri DDX interface outdated

Bug #118325 reported by joe on 2007-06-02
4
Affects Status Importance Assigned to Milestone
mesa (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-sis (Debian)
Fix Released
Unknown
xserver-xorg-video-sis (Ubuntu)
Medium
Bryce Harrington

Bug Description

The SiS driver currently included in Gutsy is the newest official version, however the DDX interface is incompatible with Xorg, so it complains when running glxinfo:

SiS DRI driver expected DDX version 0-0.8.x but got version 0.7.1

This disables DRI.

Solution: Current GIT version (19th September 07) of xserver-xorg-video-sis solves the issue completely.

This is true. I'm running a SiS630 laptop. Attached glxinfo.

The driver is outdated.

Changed in xserver-xorg-video-sis:
status: New → Confirmed

To be clear, this is Ubuntu Gutsy uptodate as of 18th September 2007.

The version of the SiS driver is 1:0.9.3-2 .

Changed in xserver-xorg-video-sis:
importance: Undecided → Medium
status: Confirmed → Triaged

After compiling today's GIT version of the SiS driver, I have working DRI in Gutsy current.

So the issue lies in the driver. It needs an update, despite the fact that there was no new official release beyond what's already in Gutsy. The GIT version works fine.

description: updated
description: updated
Changed in xserver-xorg-video-sis:
assignee: nobody → bryceharrington
Tormod Volden (tormodvolden) wrote :

Steps to patch and rebuild:

Download the patch as plain text from http://gitweb.freedesktop.org/?p=xorg/driver/xf86-video-sis.git;a=commitdiff_plain;h=391dad44fa305be4cded31cf2f9a4fba7420af99;hp=89d2f2118a2409d1bf0239448a4e3d2f6e7a1919

sudo apt-get install devscripts
sudo apt-get build-dep xserver-xorg-video-sis
apt-get source xserver-xorg-video-sis
cd xserver-xorg-video-sis-0.9.3
patch -p1 < the_patch_that_you_downloaded
debuild -b -us -uc
cd ..
sudo dpkg -i xserver-xorg-video-sis*.deb

Tormod Volden (tormodvolden) wrote :

  * commit 391dad44fa305be4cded31cf2f9a4fba7420af99 from upstream
    Fix xserver version detection. (LP: #118325)

Bryce Harrington (bryce) wrote :

This looks quite proper. It simply updates the -sis driver to accept the new xserver numbering scheme (i.e. 1.3.x versus the old 7.2.x based on xorg version numbers). +1 for uploading it.

Pretty much all the other drivers needed a change like this; presumably this one was missed just because it is not often updated.

Tormod Volden (tormodvolden) wrote :

xserver-xorg-video-sis (1:0.9.3-2ubuntu1) gutsy; urgency=low

  * commit 391dad44fa305be4cded31cf2f9a4fba7420af99 from upstream
    Fix xserver version detection. (LP: #118325)

 -- Tormod Volden <email address hidden> Wed, 19 Sep 2007 20:31:14 +0200

Changed in xserver-xorg-video-sis:
status: Triaged → Fix Released

The problem was with the sis x.org driver which failed to detect the X version, The issue is fixed. This wasn't a mesa problem, Setting as invalid.

Changed in mesa:
status: New → Invalid
Changed in xserver-xorg-video-sis:
status: Unknown → New
Changed in xserver-xorg-video-sis:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.