Ubuntu

3d applications with compiz enabled are not usable

Reported by suoko on 2007-05-25
22
Affects Status Importance Assigned to Milestone
DRI
Fix Released
Unknown
mesa (Debian)
Fix Released
Unknown
mesa (Ubuntu)
Medium
Unassigned
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: compiz

I have reported this bug many times in forums.
I have tried a fresh install of feisty with same results.
When I have compiz enabled and move the window of a 3d app (such as glxgears), the window moves but the content stays where it was.
With SL or 3d games, the application starts madly flickering.

intel 945GM GPU, ASUS notebook. feisty

Kelsey Sigurdur (kes) wrote :

I can confirm this with an intel 965g on feisty.

If you move the window a frozen shot of the app remains.

Changed in xserver-xorg-video-intel:
status: Unconfirmed → Confirmed
suoko (suoko) wrote :

INTEL 945GM IS THE GPU WHICH IS MOUNTED ON DELL NOTEBOOKS WHICH WILL BE SOLD WITH UBUNTU PREINSTALLED !!!
HOPE DELL SOLVED THE BUG OTHERWISE FOR BUYERS IT WON'T NICE TO DISCOVER THIS BUG...

Bluecircle (blue-circle) wrote :

I can confirm this with intel 915gm. When I run glxgears and move the window, the gears stay in place until I'm done dragging the window. After I place the window in a new location the gears then jump back into the window, AKA the gears do move, but not in sync with the window. Are there any other noticeable adverse affects? Ex. I play Open Arena all the time with no problems.

Mildred (mildred) wrote :

This also affect others distributions as well. maybe someone who know what happens could report this to the intel driver project or the compiz project.

Jacob Peddicord (jpeddicord) wrote :

Seems to be slightly fixed with Gutsy. Hopefully X.org 7.3 will bring some stability to the table with this bug.

OpenGL apps don't play well with OpenGL compositors.

kevinmedina (kevinmedina) wrote :

I can confirm this bug as well, using Intel 915gm on Feisty

Changed in mesa:
status: Unknown → New
Changed in dri:
status: Unknown → Confirmed

Running gutsy and still suffering, if anyones got it working, do you have an xorg.conf to share? Theres a 'fix' here: http://hoegsberg.blogspot.com/2007/08/redirected-direct-rendering.html but im not much of a dev, and I dont know how 'hacky' it is. I dont know how to pass on the link to the ubuntu devs though....

Timo Aaltonen (tjaalton) wrote :

Reassigning to mesa.

As mentioned in the upstream bug, don't hold your breath for this. Probably won't get fixed even for gutsy+1...

Changed in xserver-xorg-video-intel:
importance: Undecided → Low
Changed in mesa:
importance: Low → Medium
suoko (suoko) wrote :

what's wrong with the workaround suggested in hoegsberg blog?
Is it too difficult to port it to ubuntu ? Is it too "unstable"?
I'd like to try that workaround

Timo Aaltonen (tjaalton) wrote :

It's not a "workaround", but the real solution, and touches many places which makes it practically impossible to backport. Hardy+1 will most likely get it, if upstream manages to pull it off in time.

I dont thinks its particularly unstable, just not merged upstream yet. And Ive
never really compiled X before, it looks a bit scary :D. If you have any luck
please let me know, the sources are in freedesktop git

On Thursday 27 December 2007 15:04:32 suoko wrote:
> what's wrong with the workaround suggested in hoegsberg blog?
> Is it too difficult to port it to ubuntu ? Is it too "unstable"?
> I'd like to try that workaround

coulix (coulix) wrote :

Mac book intel 945G same problem with any opengl apps. Hoping for a fix

Changed in mesa:
status: New → Confirmed
Captain K (guido-lamsfuss) wrote :

Same problem here on a GMA 950 (i945gm) running with Gutsy and Hardy beta.

The problem was not solved with Gutsy, but even worse, it still exists in Hardy Heron beta. Not even the slightest hint of a solution in the final version of Hardy.

Given the fact that the intel integrated gfx chips are very widespread these days, and perform quite nice on the daily working desktop, this is a huge showstopper for compiz on these chipsets.

Changed in dri:
status: Confirmed → Fix Released
Changed in mesa:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.