installing libqt4-opengl-dev uninstalls renamed stack

Bug #1098215 reported by Maarten Lankhorst
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mesa (Ubuntu)
Undecided
Unassigned
Precise
Critical
Maarten Lankhorst

Bug Description

[Impact]
 * Installing packages that require opengl dev libraries can cause the renamed stack to be uninstalled.

[Test Case]
 * sudo apt-get install xserver-xorg-lts-quantal
 * sudo apt-get install libqt4-opengl-dev
 * Watch the suggested resolution being to go back to the unrenamed xserver, deleting all lts-quantal packages.

[Regression Potential]
 * Low, mostly it ends up being a rebuild of mesa
 * Unrenamed mesa-dev packages will work on the new stack, which is an untested combination, however the relevant packages are backwards compatible, and the abi will not change. The worst that can happen is not finding new opengl extensions.

[Other Info]
  * Important for 12.04.2

Changed in mesa (Ubuntu):
status: New → Invalid
Changed in mesa (Ubuntu Precise):
importance: Undecided → Critical
assignee: nobody → Maarten Lankhorst (mlankhorst)
milestone: none → ubuntu-12.04.2
status: New → In Progress
description: updated
Revision history for this message
Chris Halse Rogers (raof) wrote : Please test proposed package

Hello Maarten, or anyone else affected,

Accepted mesa into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/mesa/8.0.4-0ubuntu0.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in mesa (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Revision history for this message
Maarten Lankhorst (mlankhorst) wrote :

works for me!

tags: added: verification-done
removed: verification-needed
Revision history for this message
Adam Conrad (adconrad) wrote : Update Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mesa - 8.0.4-0ubuntu0.3

---------------
mesa (8.0.4-0ubuntu0.3) precise-proposed; urgency=low

  * Make some -dev packages coinstallable with the renamed stack (LP: #1098215)
    - libgl1-mesa-dev, old opengl headers and symlink should be compatible still.
    - libegl1-mesa-dev, similar story
    - mesa-common-dev, installable unrenamed, but renamed version should be usable
      as well when explicitly requested. This allows the renamed -dev packages to
      keep working.
    - libglu1-mesa-dev, has no replacement in the renamed stack,
      and moved out as a separate package in mesa 9 or later. Not built in the
      renamed stack, so unrenamed version is only option.
    - libosmesa6-dev: no significant changes, and killed from the renamed stack.

  * Explicitly not done:
    - libgles1-mesa-dev, libgles2-mesa-dev, libgbm-dev: have no rdepends afaict.
 -- Maarten Lankhorst <email address hidden> Fri, 11 Jan 2013 01:45:47 +0100

Changed in mesa (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers