[ati rs690m] Can not install 12.10 Alpha3 because of Graphic problem

Bug #1035737 reported by irv on 2012-08-11
This bug report is a duplicate of:  Bug #1029582: Unusable graphics with ATI RS690M. Edit Remove
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
mesa (Ubuntu)
Undecided
Unassigned

Bug Description

The only way I could get this bug report filed was to run in 2D. The 3D screen is corrupt. Also could not run in Live OS off DVD or USB. Could not install from either DVD or USB. Had to do an install of 12.04 then do an upgrade to 12.10. For more information please see this thread on the forum @ http://ubuntuforums.org/showthread.php?t=2039669&page=1. Please read all the post I made under user name irv. I will not add any screen shot yet but will try to include them in the comments. You can see them on the forum also.
There was another bug report filed but it was from 12.04 and the problem was in 12.10. You can either delete that bug report or mark it as a duplacate of this one.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: xorg 1:7.7+1ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-9.9-generic 3.5.0
Uname: Linux 3.5.0-9-generic x86_64
ApportVersion: 2.4-0ubuntu6
Architecture: amd64
Date: Sat Aug 11 16:15:05 2012
DistUpgraded: 2012-08-11 16:07:35,121 DEBUG enabling apt cron job
DistroCodename: quantal
DistroVariant: ubuntu
GraphicsCard:
 Advanced Micro Devices [AMD] nee ATI RS690M [Radeon X1200 Series] [1002:791f] (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:01fc]
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
MachineType: Dell Inc. Inspiron 1521
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-9-generic root=UUID=cfec6873-b7df-4c78-b1cb-0903d339fd58 ro recovery nomodeset
SourcePackage: xorg
Symptom: display
UpgradeStatus: Upgraded to quantal on 2012-08-11 (0 days ago)
dmi.bios.date: 10/30/2007
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A04
dmi.board.name: 0KY766
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA04:bd10/30/2007:svnDellInc.:pnInspiron1521:pvr:rvnDellInc.:rn0KY766:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Inspiron 1521
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.8+bzr3249-0ubuntu2
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.37-0ubuntu2
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.4-1ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.4-1ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.12.99.904-0ubuntu1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-2~ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.99.99~git20120713.6ef1ad6a-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.20.3-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.1-4~ubuntu1

irv (irv-hbci) wrote :
irv (irv-hbci) wrote :

I added on snap shot of what the 3D screen looks like. Totally unusable.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) wrote :

Collect all relevant information onto this bug report rather than just reference a forum post.

Changed in xorg (Ubuntu):
status: Confirmed → Incomplete
irv (irv-hbci) wrote :

Tried the Alpha 2 on the USB with same results. Tried the DVD with Alpha 3 same results.
Now the only way I could get Ubuntu installed was to first install 12.04 on spare HD do the updates and then install 12.10. I was able to get it to boot in 2D so I could run the bug report. I have never had to jump throw this many hoops before to get an OS to install.

irv (irv-hbci) wrote :

Another screen shot

bugbot (bugbot) on 2012-08-23
affects: xorg (Ubuntu) → xserver-xorg-video-ati (Ubuntu)
irv (irv-hbci) wrote :

It is Sept 1st, and I thought I would give the daily build another try. Downloaded, made a boot USB and booted into the Live OS. Here is another screen shot. Same thing yet.

Timo Aaltonen (tjaalton) on 2012-09-24
affects: xserver-xorg-video-ati (Ubuntu) → mesa (Ubuntu)
summary: - Can not install 12.10 Alpha3 because of Graphic problem
+ [ati rs690m] Can not install 12.10 Alpha3 because of Graphic problem
irv (irv-hbci) wrote :

Yes, I tried again on 9/23/2012 with the daily built. No change since the 9/1/2012. Graphics are still corrupt even on the live OS. We are getting closer to the final release I hop this problem will be fixed or this will be the first release I won't be able to use. I will have to stay with 12.04.
I was wondering if any one knows what was changed in 12.10 to bring on this problem?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers