package libgl1-mesa-dri-lts-vivid 10.5.9-2ubuntu1~trusty2 failed to install/upgrade: trying to overwrite shared '/etc/drirc', which is different from other instances of package libgl1-mesa-dri-lts-vivid:i386

Bug #1618545 reported by Brian Murray on 2016-08-30
40
This bug affects 5 people
Affects Status Importance Assigned to Milestone
mesa-lts-vivid (Ubuntu)
Undecided
Unassigned

Bug Description

I had installed the following packages for utopic and then tried to install them for Vivid and got the following crash.

bdmurray@upgrade-trusty-amd64:~$ sudo apt-get install --install-recommends linux-generic-lts-vivid xserver-xorg-core-lts-vivid xserver-xorg-lts-vivid xserver-xorg-video-all-lts-vivid xserver-xorg-input-all-lts-vivid libwayland-egl1-mesa-lts-vivid libgl1-mesa-glx-lts-vivid:i386

Preparing to unpack .../libgl1-mesa-dri-lts-vivid_10.5.9-2ubuntu1~trusty2_i386.deb ...
Unpacking libgl1-mesa-dri-lts-vivid:i386 (10.5.9-2ubuntu1~trusty2) ...
dpkg: error processing archive /var/cache/apt/archives/libgl1-mesa-dri-lts-vivid_10.5.9-2ubuntu1~trusty2_i386.deb (--unpack):
 trying to overwrite shared '/etc/drirc', which is different from other instances of package libgl1-mesa-dri-lts-vivid:i386
Errors were encountered while processing:
 /var/cache/apt/archives/libgl1-mesa-dri-lts-vivid_10.5.9-2ubuntu1~trusty2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

ProblemType: Package
DistroRelease: Ubuntu 14.04
Package: libgl1-mesa-dri-lts-vivid 10.5.9-2ubuntu1~trusty2
ProcVersionSignature: Ubuntu 3.19.0-66.74~14.04.1-generic 3.19.8-ckt22
Uname: Linux 3.19.0-66-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.21
Architecture: amd64
Date: Tue Aug 30 09:35:03 2016
DuplicateSignature: package:libgl1-mesa-dri-lts-vivid:10.5.9-2ubuntu1~trusty2:trying to overwrite shared '/etc/drirc', which is different from other instances of package libgl1-mesa-dri-lts-vivid:i386
ErrorMessage: trying to overwrite shared '/etc/drirc', which is different from other instances of package libgl1-mesa-dri-lts-vivid:i386
InstallationDate: Installed on 2016-07-28 (32 days ago)
InstallationMedia: Ubuntu 14.04.3 LTS "Trusty Tahr" - Beta amd64 (20150805)
RelatedPackageVersions:
 dpkg 1.17.5ubuntu5.7
 apt 1.0.1ubuntu2.14
SourcePackage: mesa-lts-vivid
Title: package libgl1-mesa-dri-lts-vivid 10.5.9-2ubuntu1~trusty2 failed to install/upgrade: trying to overwrite shared '/etc/drirc', which is different from other instances of package libgl1-mesa-dri-lts-vivid:i386
UpgradeStatus: No upgrade log present (probably fresh install)

Brian Murray (brian-murray) wrote :
tags: removed: need-duplicate-check
Brian Murray (brian-murray) wrote :

I ran the following two commands and the package installed successfully.

sudo apt-get remove libgl1-mesa-dri-lts-vivid:i386 libgl1-mesa-glx-lts-vivid:i386

sudo apt-get install libgl1-mesa-glx-lts-vivid:i386

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mesa-lts-vivid (Ubuntu):
status: New → Confirmed
Brian Murray (brian-murray) wrote :

This does not happen if you go from -lts-utopic to -lts-wily.

Brian Murray (brian-murray) wrote :

Nor does it happen if you go from -lts-utopic to -lts-xenial which is the path recommended by hwe-support-status.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers