E: Package 'libegl1-mesa-drivers-lts-vivid' has no installation candidate

Bug #1479251 reported by neon1ks on 2015-07-29
124
This bug affects 27 people
Affects Status Importance Assigned to Milestone
mesa-lts-vivid (Ubuntu)
Undecided
Unassigned

Bug Description

The community wiki page (https://wiki.ubuntu.com/Kernel/LTSEnablementStack) describes how to install the latest kernel and graphics.

Replace utopic with vivid, we get the install command:
sudo apt-get install --install-recommends linux-generic-lts-vivid xserver-xorg-lts-vivid libgl1-mesa-glx-lts-vivid libegl1-mesa-drivers-lts-vivid

Running this command, we get

sudo apt-get install --install-recommends linux-generic-lts-vivid xserver-xorg-lts-vivid libgl1-mesa-glx-lts-vivid libegl1-mesa-drivers-lts-vivid
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package libegl1-mesa-drivers-lts-vivid is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libegl1-mesa-drivers-lts-vivid' has no installation candidate

neon1ks (neon1ks) on 2015-07-29
tags: added: trusty
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mesa-lts-vivid (Ubuntu):
status: New → Confirmed
Revision history for this message
Adam Conrad (adconrad) wrote :

Wiki instructions have been updated with a command-line appropriate for lts-vivid.

Changed in mesa-lts-vivid (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
neon1ks (neon1ks) wrote :
Download full text (4.9 KiB)

sudo apt-get install --install-recommends linux-generic-lts-vivid xserver-xorg-core-lts-vivid xserver-xorg-lts-vivid xserver-xorg-video-all-lts-vivid xserver-xorg-input-all-lts-vivid libwayland-egl1-mesa-lts-vivid
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libwayland-egl1-mesa-lts-vivid : Depends: libegl1-mesa-lts-vivid (= 10.5.2-0ubuntu1~trusty1) but it is not going to be installed
                                  Conflicts: xorg-renamed-package-lts-utopic
 unity-control-center : Depends: libcheese-gtk23 (>= 3.4.0) but it is not going to be installed
                        Depends: libcheese7 (>= 3.0.1) but it is not going to be installed
 xserver-xorg-core-lts-vivid : Depends: libgbm1-lts-vivid (>= 8.1~0) but it is not going to be installed
                               Recommends: libgl1-mesa-dri-lts-vivid (>= 7.10.2-4) but it is not going to be installed
                               Conflicts: xorg-renamed-package-lts-utopic
 xserver-xorg-input-all-lts-vivid : Depends: xserver-xorg-input-evdev-lts-vivid but it is not going to be installed
                                    Depends: xserver-xorg-input-vmmouse-lts-vivid but it is not going to be installed
                                    Depends: xserver-xorg-input-synaptics-lts-vivid but it is not going to be installed
                                    Depends: xserver-xorg-input-wacom-lts-vivid but it is not going to be installed
 xserver-xorg-lts-vivid : Depends: xserver-xorg-input-evdev-lts-vivid but it is not going to be installed
                          Recommends: libgl1-mesa-dri-lts-vivid but it is not going to be installed
                          Recommends: libgl1-mesa-glx-lts-vivid but it is not going to be installed
                          Recommends: libegl1-mesa-lts-vivid but it is not going to be installed
                          Recommends: libegl1-mesa-drivers-lts-vivid but it is not installable
                          Recommends: libgbm1-lts-vivid but it is not going to be installed
                          Recommends: libgles2-mesa-lts-vivid but it is not going to be installed
                          Recommends: libgles1-mesa-lts-vivid but it is not going to be installed
                          Conflicts: libegl1-mesa (>= 0~)
                          Conflicts: libgl1-mesa-dri (>= 0~)
                          Conflicts: libgl1-mesa-dri:i386 (>= 0~)
                          Conflicts: libgl1-mesa-glx (>= 0~)
                          Conflicts: libgl1-mesa-glx:i386 (>= 0~)
                          Conflicts: libglapi-mesa (>= 0~)
                          Conflicts: libglapi-mesa:i386 (>= 0~)
                          Conflicts: libgles2-mesa (>= 0~)
                          Conflicts: xorg-renamed-package-lts-utopic
 xserver-xorg-video-all-lts-vivid : D...

Read more...

Changed in mesa-lts-vivid (Ubuntu):
status: Fix Released → New
Revision history for this message
neon1ks (neon1ks) wrote :

my patch:

--- control 2015-07-31 03:29:29.274595000 +0800
+++ control-new 2015-07-31 04:35:23.810478000 +0800
@@ -171,7 +171,7 @@
  libgl1-mesa-dri-lts-vivid (= ${binary:Version}),
 Provides:
  libegl1-mesa, xorg-renamed-package, xorg-renamed-package-lts-vivid, libegl1-mesa-drivers,
- libegl1-x11
+ libegl1-x11, libegl1-mesa-drivers-lts-vivid
 Conflicts:
  libegl1-mesa, xorg-renamed-package-lts-utopic,,
  libegl1-x11

Changed in mesa-lts-vivid (Ubuntu):
status: New → Fix Committed
neon1ks (neon1ks) on 2015-08-04
Changed in mesa-lts-vivid (Ubuntu):
status: Fix Committed → Confirmed
Revision history for this message
Thomas Mayer (thomas303) wrote :

Same for me when I replace utopic with vivid (I tracked apt usage of older installs of HESes on http://www.slicewise.net/debian/hardware-enablement-stack-fuer-ubuntu-1404-lts-trusty-tahr/):

sudo apt-get -s install --install-recommends linux-generic-lts-vivid xserver-xorg-lts-vivid libgl1-mesa-glx-lts-vivid libegl1-mesa-drivers-lts-vividPaketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Paket libegl1-mesa-drivers-lts-vivid ist nicht verfügbar, wird aber von einem anderen Paket
referenziert. Das kann heißen, dass das Paket fehlt, dass es abgelöst
wurde oder nur aus einer anderen Quelle verfügbar ist.

E: Für Paket »libegl1-mesa-drivers-lts-vivid« existiert kein Installationskandidat.

Revision history for this message
Thomas Mayer (thomas303) wrote :
Download full text (5.7 KiB)

https://wiki.ubuntuusers.de/LTS_Enablement_Stacks describes another way to install the 14.04.3 HES which also does not work:

sudo apt-get -s install --install-recommends linux-generic-lts-vivid xserver-xorg-core-lts-vivid xserver-xorg-lts-vivid xserver-xorg-video-all-lts-vivid xserver-xorg-input-all-lts-vivid libwayland-egl1-mesa-lts-vivid
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 empathy : Hängt ab von: libclutter-1.0-0 (>= 1.10.0) soll aber nicht installiert werden
           Hängt ab von: libclutter-gst-2.0-0 (>= 0.10.0) soll aber nicht installiert werden
           Hängt ab von: libclutter-gtk-1.0-0 (>= 1.4) soll aber nicht installiert werden
           Hängt ab von: libcogl15 (>= 1.15.8) soll aber nicht installiert werden
 libcheese-gtk23 : Hängt ab von: libclutter-1.0-0 (>= 1.13.2) soll aber nicht installiert werden
                   Hängt ab von: libclutter-gtk-1.0-0 (>= 0.91.8) soll aber nicht installiert werden
                   Hängt ab von: libcogl15 (>= 1.15.8) soll aber nicht installiert werden
 libcheese7 : Hängt ab von: libclutter-gst-2.0-0 (>= 0.10.0) soll aber nicht installiert werden
              Hängt ab von: gstreamer1.0-clutter soll aber nicht installiert werden
 libwayland-egl1-mesa-lts-vivid : Hängt ab von: libegl1-mesa-lts-vivid (= 10.5.2-0ubuntu1~trusty1) soll aber nicht installiert werden
                                  Kollidiert mit: xorg-renamed-package-lts-utopic
 xserver-xorg-core-lts-vivid : Hängt ab von: libgbm1-lts-vivid (>= 8.1~0) soll aber nicht installiert werden
                               Empfiehlt: libgl1-mesa-dri-lts-vivid (>= 7.10.2-4) soll aber nicht installiert werden
                               Kollidiert mit: xorg-renamed-package-lts-utopic
 xserver-xorg-input-all-lts-vivid : Hängt ab von: xserver-xorg-input-evdev-lts-vivid soll aber nicht installiert werden
                                    Hängt ab von: xserver-xorg-input-vmmouse-lts-vivid soll aber nicht installiert werden
                                    Hängt ab von: xserver-xorg-input-synaptics-lts-vivid soll aber nicht installiert werden
                                    Hängt ab von: xserver-xorg-input-wacom-lts-vivid soll aber nicht installiert werden
 xserver-xorg-lts-vivid : Hängt ab von: xserver-xorg-input-evdev-lts-vivid soll aber nicht installiert werden
                          Empfiehlt: libgl1-mesa-dri-lts-vivid soll aber nicht installiert werden
                          Empfiehlt: libgl1-mesa-glx-lts-vivid soll aber nicht installiert werden
                          Empfiehlt: libegl1-mesa-lts-vivid soll aber nicht installiert werden
                          Empfiehlt: libegl1-mesa-drivers-lts-vivid ist aber nicht installier...

Read more...

Revision history for this message
Thomas Mayer (thomas303) wrote :
Download full text (6.6 KiB)

For me, simulation works when I use libegl1-mesa-lts-vivid instead of libegl1-mesa-drivers-lts-vivid. libegl1-mesa-drivers-lts-utopic is removed by this.

sudo apt-get -s install --install-recommends linux-generic-lts-vivid xserver-xorg-lts-vivid libgl1-mesa-glx-lts-vivid libegl1-mesa-lts-vivid
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
  gcc-4.8-base:i386 libasound2:i386 libasound2-plugins:i386 libasyncns0:i386
  libaudio2:i386 libavahi-client3:i386 libavahi-common-data:i386
  libavahi-common3:i386 libcups2:i386 libdbusmenu-qt2:i386 libdrm-intel1:i386
  libdrm-nouveau2:i386 libdrm-radeon1:i386 libedit2:i386 libelf1:i386
  libexpat1:i386 libffi6:i386 libflac8:i386 libfontconfig1:i386
  libfreetype6:i386 libgcrypt11:i386 libglib2.0-0:i386 libgnutls26:i386
  libgpg-error0:i386 libgssapi-krb5-2:i386 libgstreamer-plugins-base1.0-0:i386
  libgstreamer1.0-0:i386 libice6:i386 libjack-jackd2-0:i386 libjbig0:i386
  libjpeg-turbo8:i386 libjpeg8:i386 libk5crypto3:i386 libkeyutils1:i386
  libkrb5-3:i386 libkrb5support0:i386 libllvm3.4:i386 libllvm3.5:i386
  libmysqlclient18:i386 libogg0:i386 liborc-0.4-0:i386 libp11-kit0:i386
  libpciaccess0:i386 libpulse0:i386 libqt4-dbus:i386 libqt4-declarative:i386
  libqt4-network:i386 libqt4-script:i386 libqt4-sql:i386 libqt4-sql-mysql:i386
  libqt4-xml:i386 libqt4-xmlpatterns:i386 libqtcore4:i386 libqtdbus4:i386
  libqtgui4:i386 libsamplerate0:i386 libsm6:i386 libsndfile1:i386
  libspeexdsp1:i386 libsqlite3-0:i386 libssl1.0.0:i386 libstdc++6:i386
  libtasn1-6:i386 libtiff5:i386 libtxc-dxtn-s2tc0:i386 libvorbis0a:i386
  libvorbisenc2:i386 libwrap0:i386 libx11-xcb1:i386 libxcb-dri2-0:i386
  libxcb-dri3-0:i386 libxcb-glx0:i386 libxcb-present0:i386 libxcb-sync1:i386
  libxdamage1:i386 libxfixes3:i386 libxi6:i386 libxml2:i386 libxrender1:i386
  libxshmfence1:i386 libxslt1.1:i386 libxss1:i386 libxt6:i386 libxv1:i386
  libxxf86vm1:i386 sni-qt:i386
Verwenden Sie »apt-get autoremove«, um sie zu entfernen.
Die folgenden zusätzlichen Pakete werden installiert:
  libgbm1-lts-vivid libgl1-mesa-dri-lts-vivid libglapi-mesa-lts-vivid
  libgles1-mesa-lts-vivid libgles2-mesa-lts-vivid libllvm3.6
  libxatracker2-lts-vivid linux-headers-3.19.0-25
  linux-headers-3.19.0-25-generic linux-headers-generic-lts-vivid
  linux-image-3.19.0-25-generic linux-image-extra-3.19.0-25-generic
  linux-image-generic-lts-vivid thermald xserver-xorg-core-lts-vivid
  xserver-xorg-input-all-lts-vivid xserver-xorg-input-evdev-lts-vivid
  xserver-xorg-input-mouse-lts-vivid xserver-xorg-input-synaptics-lts-vivid
  xserver-xorg-input-vmmouse-lts-vivid xserver-xorg-input-wacom-lts-vivid
  xserver-xorg-video-all-lts-vivid xserver-xorg-video-ati-lts-vivid
  xserver-xorg-video-cirrus-lts-vivid xserver-xorg-video-fbdev-lts-vivid
  xserver-xorg-video-intel-lts-vivid xserver-xorg-video-mach64-lts-vivid
  xserver-xorg-video-mga-lts-vivid xserver-xorg-video-neomagic-lts-vivid
  xserver-xorg-video-nouveau-lts-vivid xserver-xorg-video-openchrome-lts-vivid
  xserver-xorg-video-r128-lts-vivid xserver-xorg-v...

Read more...

Revision history for this message
Thomas Mayer (thomas303) wrote :

Replacing libegl1-mesa-drivers-lts-vivid with libegl1-mesa-lts-vivid instead worked for me:

sudo apt-get install --install-recommends linux-generic-lts-vivid xserver-xorg-lts-vivid libgl1-mesa-glx-lts-vivid libegl1-mesa-lts-vivid

after execution and reboot:

uname -a
Linux lat61 3.19.0-25-generic #26~14.04.1-Ubuntu SMP Fri Jul 24 21:16:20 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

Basically that means that for consistency there should be a meta package libegl1-mesa-drivers-lts-vivid which depends on libegl1-mesa-lts-vivid.

Revision history for this message
Thomas Mayer (thomas303) wrote :

I was also missing the Button “New Hardware Support is Available” in the update messenger. I assume this was because libegl1-mesa-drivers-lts-vivid was missing.

If you add a meta package with dependency to libegl1-mesa-lts-vivid the dependencies can be resolved and the button might appear.

Revision history for this message
father_ted (paulfourie-x) wrote :

If the various wiki's get updated please don't forget the UEFI users.

Revision history for this message
Roman Dinga (roman-dinga) wrote :

I managed to install the HES using the aptitude command. apt-get wouldn't work with any of the mentioned combinations. Maybe it will help someone...

SvenPM (svenpm) on 2015-08-21
description: updated
Revision history for this message
father_ted (paulfourie-x) wrote :

sudo apt-get install linux-generic-lts-vivid
sudo apt-get install linux-signed-generic-lts-vivid

sudo apt-get -s install --install-recommends xserver-xorg-core-lts-vivid xserver-xorg-lts-vivid xserver-xorg-video-all-lts-vivid xserver-xorg-input-all-lts-vivid libgl1-mesa-glx-lts-vivid libegl1-mesa-lts-vivid

gives me the following subsystems -
Linux XXXXXX-desktop 3.19.0-26-generic #28~14.04.1-Ubuntu SMP Wed Aug 12 14:09:17 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
XORG 1.17.1
MESA 10.5.2
libdrm-radeon1 2.4.60-2

Revision history for this message
father_ted (paulfourie-x) wrote :

The wiki seems to have been updated. The install i posted works mostly but wrecks wine.

https://wiki.ubuntu.com/Kernel/LTSEnablementStack

I haven't tested it at all.

Revision history for this message
libuntu (libuntu) wrote :

i got too similar error on my pc

Revision history for this message
father_ted (paulfourie-x) wrote :

I have used the MULTIARCH DESKTOP setup on a fresh desktop install and it all worked for me now.

I installed from the 14.04.2 media and then got the system fully patched. After that i ran the recommended wiki commands and it worked out well.

Revision history for this message
neon1ks (neon1ks) wrote :
Revision history for this message
Alan Franzoni (alanfranz) wrote :

I was unable to migrate from the Utopic to the Vivid stack with the provided commands; it seems that the --install-recommends breaks on some dependency to libegl1-mesa-drivers-lts-vivid, which is not installable.

My upgrade succeeded without the install recommends:

sudo apt-get install linux-generic-lts-vivid xserver-xorg-core-lts-vivid xserver-xorg-lts-vivid xserver-xorg-video-all-lts-vivid xserver-xorg-input-all-lts-vivid libwayland-egl1-mesa-lts-vivid libegl1-mesa-lts-vivid libgbm1-lts-vivid libgl1-mesa-dri-lts-vivid libgl1-mesa-glx-lts-vivid libgles2-mesa-lts-vivid libgles1-mesa-lts-vivid

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

the wiki has been updated, closing the bug

Changed in mesa-lts-vivid (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions