qtbase5-dev not installable on Ubuntu 14.04 LTS with utopic HWE stack

Bug #1435324 reported by Christian González on 2015-03-23
48
This bug affects 11 people
Affects Status Importance Assigned to Milestone
apt (Ubuntu)
Undecided
Unassigned
mesa-lts-vivid (Ubuntu)
Undecided
Unassigned
qtbase-opensource-src (Ubuntu)
Undecided
Unassigned

Bug Description

I discovered the problem when I tried to compile a Qt5 QML program firstly.
I have an Ubuntu 14.04.2 LTS with all updates, no significant PPAs (only nodejs and owncloud, not affecting this problem here) and with all the -lts-utopic upgrade packages installed.

With that system, I tried to install qtbase5-dev, and apt told me:

[...]
The following packages have unmet dependencies:
 qtbase5-dev : Depends: libgles2-mesa-dev or
                        libgles2-dev but it is not installable
 unity-control-center : Depends: libcheese-gtk23 (>= 3.4.0) but it is not going to be installed
                        Depends: libcheese7 (>= 3.0.1) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

So this package seems to be not installable. This tried in synaptic, it tries to uninstall all -lts-utopic packages (inclusive all xserver*.deb) and install the "old" ones instead of them.

So the problem somewhere lies within the new lts packages that seem not to be compatible with qtbase5-dev (and its dependency: libgles2-mesa-dev - but I am not able to find out further.

The problem is: Qt5 development on an Ubuntu 14.04.2 LTS machine is NOT possible without a fix. The make process always complains about not finding gl libraries.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: qtbase5-dev (not installed)
ProcVersionSignature: Ubuntu 3.16.0-31.43~14.04.1-generic 3.16.7-ckt5
Uname: Linux 3.16.0-31-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.7
Architecture: amd64
CurrentDesktop: Unity
Date: Mon Mar 23 14:01:20 2015
InstallationDate: Installed on 2015-02-25 (26 days ago)
InstallationMedia: Ubuntu 14.04.2 LTS "Trusty Tahr" - Release amd64 (20150218.1)
SourcePackage: qtbase-opensource-src
UpgradeStatus: No upgrade log present (probably fresh install)

Christian González (droetker) wrote :
Timo Jyrinki (timo-jyrinki) wrote :

This is a bug in the 14.04.2 LTS hardware support stack, tracked in bug #1424466 and bug fix should actually already be published to all users but it seems the SRU team has not yet done so.

Timo Jyrinki (timo-jyrinki) wrote :

(fix now being published)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in qtbase-opensource-src (Ubuntu):
status: New → Confirmed
sgon00 (sgon00) wrote :

Well, I don't know if the duplicate status is wrong or not. But I am meeting the same problem. The duplicate bug said the fix was released in the -updates repo, but my problem is not fixed until now. I did "sudo apt-get dist-upgrade" to the latest release. I can not install qt5-default and the following is the errors:

$ sudo apt-get install qt5-default
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 qt5-default : Depends: qtbase5-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

--------------------------------

$ sudo apt-get install qtbase5-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 qtbase5-dev : Depends: libgles2-mesa-dev or
                        libgles2-dev but it is not installable
               Depends: libqt5gui5 (= 5.2.1+dfsg-1ubuntu14.2) but it is not going to be installed
               Depends: libqt5printsupport5 (= 5.2.1+dfsg-1ubuntu14.2) but it is not going to be installed
               Depends: libqt5widgets5 (= 5.2.1+dfsg-1ubuntu14.2) but it is not going to be installed
               Recommends: libqt5opengl5-dev (= 5.2.1+dfsg-1ubuntu14.2) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

sgon00 (sgon00) wrote :

This is VERY weird.
The unmet dependencies errors are fixed by `apt-get install libgles2-mesa-dev` manually.

Rodrigo (rodrigolopezguerra) wrote :

sgon00 is right , weird but true

Silviu C. (silviucc) wrote :

This is also affecting the obs-project ppa. The builds for trusty fail as can be observed from the build log:

https://launchpadlibrarian.net/211257553/buildlog_ubuntu-trusty-amd64.obs-studio_0.11.1-197~trusty_BUILDING.txt.gz

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

affects: xorg-lts-vivid (Ubuntu) → mesa-lts-vivid (Ubuntu)
Changed in mesa-lts-vivid (Ubuntu):
status: New → Confirmed
Timo Jyrinki (timo-jyrinki) wrote :

I'm not aware of what could be done on the Qt side, as it's related to the 14.04.X LTS HWE upgrades where X >= 2. The upgrade is complex and some of the mesa packages have seen slight changes (in addition to being just -lts-vivid suffixed).

It's not as qtbase5-dev could not be installed as such, it's that apt needs to be hinted additionally with eg that libgles2-mesa-dev for the install to succeed. So apt could handle the situation better, or something could maybe improved in the HWE packages.

Changed in qtbase-opensource-src (Ubuntu):
status: Confirmed → Incomplete
tags: added: unmetdeps
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apt (Ubuntu):
status: New → Confirmed
Changed in mesa-lts-vivid (Ubuntu):
status: New → Confirmed
Nicholas Skaggs (nskaggs) wrote :

For those who might come across this issue, I was able to workaround it and install things by manually specifying all the needed dependencies.

sudo apt-get install libgles2-mesa-dev libegl1-mesa-dev libwayland-dev qtbase5-dev

Should this occur in the future, you likely can build a similar string of depends that apt isn't picking up on and install them together.

Ludo (ludonago) wrote :

I have the same unmet dependencies and broken packages issue when trying to install qt5-default but the solution proposed by Nicholas on 2015-09-11 didn't work for me. Nicholas's solution also results in held broken packages. Ubuntu 14.04.

Jeremy Bicha (jbicha) wrote :

(not a xenial backports issue)

affects: xenial-backports → null-and-void
Changed in null-and-void:
status: New → Invalid
Mathew Hodson (mhodson) on 2016-08-11
affects: null-and-void → ubuntu-translations
no longer affects: ubuntu-translations
summary: - qtbase5-dev not installable on Ubuntu 14.04 LTS
+ qtbase5-dev not installable on Ubuntu 14.04 LTS with utopic HWE stack
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments