Menulibre does not start

Bug #1825511 reported by Ciro Mazzardo on 2019-04-19
This bug affects 10 people
Affects Status Importance Assigned to Milestone
menulibre (Ubuntu)

Bug Description

1) ~$ lsb_release -rd
Description: Ubuntu 19.04
Release: 19.04

2) ~$ apt-cache policy menulibre
  Installato: 2.2.0-2
  Candidato: 2.2.0-2
  Tabella versione:
 *** 2.2.0-2 500
        500 disco/universe amd64 Packages
        500 disco/universe i386 Packages
        100 /var/lib/dpkg/status

3) I expected the program to start.

4) The program does not start.

When I boot it from the terminal:
~$ menulibre

(menulibre:20957): Gtk-WARNING **: 13:45:54.319: gtk_menu_attach_to_widget(): menu already attached to GtkMenuButton

(menulibre:20957): Gtk-WARNING **: 13:45:54.366: gtk_menu_attach_to_widget(): menu already attached to GtkMenuButton
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/menulibre/", line 2217, in do_activate = MenulibreWindow(self, headerbar)
  File "/usr/lib/python3/dist-packages/menulibre/", line 250, in __init__
  File "/usr/lib/python3/dist-packages/menulibre/", line 589, in configure_application_treeview
    self.treeview = MenulibreTreeview.Treeview(self, builder)
  File "/usr/lib/python3/dist-packages/menulibre/", line 48, in __init__
  File "/usr/lib/python3/dist-packages/menulibre/", line 59, in _configure_treeview
    treestore = MenuEditor.get_treestore()
  File "/usr/lib/python3/dist-packages/menulibre/", line 123, in get_treestore
    return menu_to_treestore(treestore, None, menu)
  File "/usr/lib/python3/dist-packages/menulibre/", line 111, in menu_to_treestore
    treestore = menu_to_treestore(treestore, treeiter, item[3])
  File "/usr/lib/python3/dist-packages/menulibre/", line 100, in menu_to_treestore
    tooltip = escapeText(item[2]['comment'])
  File "/usr/lib/python3/dist-packages/menulibre/", line 99, in escapeText
    return GLib.markup_escape_text(text, len(text))
  File "/usr/lib/python3/dist-packages/gi/overrides/", line 415, in markup_escape_text
    return GLib.markup_escape_text(text, length)
UnicodeDecodeError: 'utf-8' codec can't decode byte 0xc3 in position 39: unexpected end of data

ProblemType: Bug
DistroRelease: Ubuntu 19.04
Package: menulibre 2.2.0-2
ProcVersionSignature: Ubuntu 5.0.0-13.14-generic 5.0.6
Uname: Linux 5.0.0-13-generic x86_64
ApportVersion: 2.20.10-0ubuntu27
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Fri Apr 19 13:41:49 2019
InstallationDate: Installed on 2019-04-19 (0 days ago)
InstallationMedia: Ubuntu 19.04 "Disco Dingo" - Release amd64 (20190416)
PackageArchitecture: all
 PATH=(custom, no user)
SourcePackage: menulibre
UpgradeStatus: No upgrade log present (probably fresh install)

Ciro Mazzardo (fenekkugitsune) wrote :
Rafael Costa (rcostarega) wrote :

Searching, I found the following solution:

Edit the file menulibre

sudo nano /usr/lib/python3/dist-packages/menulibre/

Search for:

return GLib.markup_escape_text(text, len(text))

Replace with:

return GLib.markup_escape_text(text)

This has worked for me.

Ciro Mazzardo (fenekkugitsune) wrote :

This solution works for me too.
Grazie mille man.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in menulibre (Ubuntu):
status: New → Confirmed
Laurent Dinclaux (dreadlox) wrote :

The fix works for me too

description: updated
Claudio Fior (caiofior) wrote :

Thanks for the solution: it worked

ugonegnome (ugonegnome) wrote :

This solution works for me too.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers