Can't hide entries sourced from /usr/share/applications/kde4/

Bug #1313682 reported by b3nmore on 2014-04-28
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
MenuLibre
Undecided
Sean Davis
menulibre (Ubuntu)
Undecided
Unassigned

Bug Description

Menu entries sourced form /usr/share/applications/kde4/ can not be hidden using menulibre. When restarting menulibre, it lists two entries of the modified one (the original and the overwrite in .local) and the menu still shows the entry (but only one).

I've tested it with several entries from /usr/share/applications/kde4, so I guess its reproducible with every application storing its .desktop file in this directory.

Related branches

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/1313682

tags: added: package-qa-testing
b3nmore (b3nmore) wrote :

To fix this, menulibre should reproduce subdirectories (if existent) to allow merging of desktop files.

For this case all kde .desktop files are stored in <system_app_dir>/kde4/ and should be mapped to <user_app_dir>/kde4/ or more specific: /usr/share/applications/kde4/ -> ~/.local/share/applications/kde4/

b3nmore (b3nmore) wrote :

Still an issue with menulibre 2.0.6 and vivid.

The attached patch should map the original subdirectory structure to the user directory.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in menulibre (Ubuntu):
status: New → Confirmed

The attachment "util_subdir.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Sean Davis (bluesabre) wrote :

Thanks for the patch, works like a charm! Committed to 2.0.x and 2.1.x and will be in the next releases.

2.0.x: https://bazaar.launchpad.net/~menulibre-dev/menulibre/master/revision/287
2.1.x: https://bazaar.launchpad.net/~menulibre-dev/menulibre/2.1/revision/261

Changed in menulibre:
status: New → Fix Committed
Sean Davis (bluesabre) on 2015-08-09
Changed in menulibre:
milestone: none → 2.0.7
status: Fix Committed → Fix Released
assignee: nobody → Sean Davis (bluesabre)
Sean Davis (bluesabre) wrote :
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package menulibre - 2.1.0-0ubuntu1

---------------
menulibre (2.1.0-0ubuntu1) wily; urgency=low

  * New upstream release.
  * Merge from Debian unstable. Remaining changes:
    - debian/patches/01_upstream_strings.patch:
      + Dropped, now using upstream strings.

menulibre (2.0.7-1) unstable; urgency=medium

  * New upstream release.
    - Fixes saving launchers in subdirectories (LP: #1313682)
  * debian/control:
    - Bump Standards-Version to 3.9.6

 -- Sean Davis <email address hidden> Wed, 19 Aug 2015 22:16:08 -0400

Changed in menulibre (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints