install-info warning: no info dir entry

Bug #391466 reported by arky on 2009-06-24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
ispell (Ubuntu)
menu (Ubuntu)

Bug Description

Binary package hint: texinfo

Some installation warnings

(Reading database ... 307950 files and directories currently installed.)
Preparing to replace install-info 4.13a.dfsg.1-4 (using .../install-info_4.13a.dfsg.1-4_i386.deb) ...
Unpacking replacement install-info ...
Processing triggers for man-db ...
Setting up install-info (4.13a.dfsg.1-4) ...
install-info: warning: no info dir entry in `/usr/share/info/'
install-info: warning: no info dir entry in `/usr/share/info/'

ProblemType: Bug
Architecture: i386
Date: Wed Jun 24 10:14:08 2009
 libgcc1 1:4.4.0-8ubuntu2
 gcc-4.4-base 4.4.0-8ubuntu2
 findutils 4.4.2-1
 libc6 2.9-9ubuntu2
DistroRelease: Ubuntu 9.10
Package: install-info 4.13a.dfsg.1-4
 PATH=(custom, user)
ProcVersionSignature: Ubuntu 2.6.30-10.12-generic
SourcePackage: texinfo
Uname: Linux 2.6.30-10-generic i686

Related branches

Norbert Preining (preining) wrote :

Bugs to all packages having these problems have been reported to the Debian BTS, please see
- for an overview of the dpkg to GNU i-i transition
-<email address hidden>;tag=texinfo-transition for the bugs reported, there is one for menu and one for ispell

Ryan (ubuntu-draziw) wrote :

install-info: warning: no info dir entry in `/usr/share/info/'
is against menu

install-info: warning: no info dir entry in `/usr/share/info/'
is against ispell

The issue is these info files are missing:
<info on package>

ispell upstream

For menu it is fixed:
Source: menu
Source-Version: 2.1.42

We believe that the bug you reported is fixed in the latest version of
menu, which is due to be installed in the Debian FTP archive:

  to pool/main/m/menu/menu_2.1.42.dsc
  to pool/main/m/menu/menu_2.1.42.tar.gz
  to pool/main/m/menu/menu_2.1.42_amd64.deb

affects: texinfo (Ubuntu) → menu (Ubuntu)
Changed in menu (Ubuntu):
status: New → Confirmed
Changed in ispell (Ubuntu):
status: New → Confirmed
Ryan (ubuntu-draziw) on 2009-09-25
Changed in menu (Ubuntu):
assignee: nobody → MOTU (motu)

Here is a simple way to reproduce this bug:

# update-info-dir
install-info: warning: no info dir entry in `/usr/share/info/'
install-info: warning: no info dir entry in `/usr/share/info/'

The bug is still in this package version:

Package: ispell
Architecture: i386

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package menu - 2.1.42ubuntu1

menu (2.1.42ubuntu1) lucid; urgency=low

  * Merge from Debian testing (LP: #498112), remaining changes:
    - debian/conffiles, debian/su-to-rootrc, debian/rules, doc/su-to-root.1:
      Set default of SU_TO_ROOT_SU to "sudo" in conffile.
      This is specific to Ubuntu.
  * New upstream release 2.1.42:
    - Adds @direntry to (LP: #391466)
    - Uses dh_installinfo instead of install-info (LP: #434445)
 -- Ilya Barygin <email address hidden> Fri, 18 Dec 2009 11:48:39 +0300

Changed in menu (Ubuntu):
status: Confirmed → Fix Released

This bug is fixed in lucid.

Changed in ispell (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.