package menu 2.1.47ubuntu2 failed to install/upgrade: dependency problems - leaving triggers unprocessed

Bug #1768905 reported by Nikkus on 2018-05-03
188
This bug affects 37 people
Affects Status Importance Assigned to Milestone
apt (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
Artful
Undecided
Unassigned
Bionic
Undecided
Unassigned
menu (Debian)
New
Unknown
menu (Ubuntu)
High
Unassigned
Xenial
Undecided
Unassigned
Artful
Undecided
Unassigned
Bionic
Undecided
Unassigned

Bug Description

[Impact]
Breaks some upgrades, depending on install order.

[Test case]
N/A. After consultation with the dpkg maintainer and investigating the situation, it's reasonably safe to assume that noawait is the right thing to do:

* the intended use for the trigger is to run _after_ packages with .menu
files are configured, not before; therefore
* the file trigger is triggered manually from the postinst again, discussion has been that the file trigger is not actually needed.

[Regression potential]
Menu might not be updated correctly

[Original bug report]
I get this error when I update to 18.04

ProblemType: Package
DistroRelease: Ubuntu 18.04
Package: menu 2.1.47ubuntu2
ProcVersionSignature: Ubuntu 4.15.0-20.21-generic 4.15.17
Uname: Linux 4.15.0-20-generic x86_64
ApportVersion: 2.20.9-0ubuntu7
Architecture: amd64
Date: Thu May 3 16:51:28 2018
Dependencies:
 gcc-8-base 8-20180414-1ubuntu2
 libc6 2.27-3ubuntu1
 libgcc1 1:8-20180414-1ubuntu2
 libstdc++6 8-20180414-1ubuntu2
ErrorMessage: dependency problems - leaving triggers unprocessed
InstallationDate: Installed on 2018-04-11 (22 days ago)
InstallationMedia: Ubuntu-MATE 17.10 "Artful Aardvark" - Release amd64 (20180106)
Python3Details: /usr/bin/python3.6, Python 3.6.5, python3-minimal, 3.6.5-3
PythonDetails: /usr/bin/python2.7, Python 2.7.15rc1, python-minimal, 2.7.15~rc1-1
RelatedPackageVersions:
 dpkg 1.19.0.5ubuntu2
 apt 1.6.1
SourcePackage: menu
Title: package menu 2.1.47ubuntu2 failed to install/upgrade: dependency problems - leaving triggers unprocessed
UpgradeStatus: Upgraded to bionic on 2018-05-03 (0 days ago)

Nikkus (nikkus) wrote :
tags: removed: need-duplicate-check
Brian Murray (brian-murray) wrote :

This was an upgrade from Ubuntu 17.10 to Ubuntu 18.04.

tags: added: rls-bb-incoming
Changed in menu (Ubuntu):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in menu (Ubuntu):
status: New → Confirmed
Brian Murray (brian-murray) wrote :

Could you provide us with an apt-clone file from before the upgrade to Ubuntu 18.04? You should be able to find one at /var/log/dist-upgrade/apt-clone_system_state.tar.gz. Thanks in advance.

Changed in menu (Ubuntu):
status: Confirmed → Incomplete

Of course.. :)

2018-05-08 19:54 GMT+02:00 Brian Murray <email address hidden>:

> Could you provide us with an apt-clone file from before the upgrade to
> Ubuntu 18.04? You should be able to find one at /var/log/dist-upgrade
> /apt-clone_system_state.tar.gz. Thanks in advance.
>
> ** Changed in: menu (Ubuntu)
> Status: Confirmed => Incomplete
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1768905
>
> Title:
> package menu 2.1.47ubuntu2 failed to install/upgrade: dependency
> problems - leaving triggers unprocessed
>
> Status in menu package in Ubuntu:
> Incomplete
>
> Bug description:
> I get this error when I update to 18.04
>
> ProblemType: Package
> DistroRelease: Ubuntu 18.04
> Package: menu 2.1.47ubuntu2
> ProcVersionSignature: Ubuntu 4.15.0-20.21-generic 4.15.17
> Uname: Linux 4.15.0-20-generic x86_64
> ApportVersion: 2.20.9-0ubuntu7
> Architecture: amd64
> Date: Thu May 3 16:51:28 2018
> Dependencies:
> gcc-8-base 8-20180414-1ubuntu2
> libc6 2.27-3ubuntu1
> libgcc1 1:8-20180414-1ubuntu2
> libstdc++6 8-20180414-1ubuntu2
> ErrorMessage: dependency problems - leaving triggers unprocessed
> InstallationDate: Installed on 2018-04-11 (22 days ago)
> InstallationMedia: Ubuntu-MATE 17.10 "Artful Aardvark" - Release amd64
> (20180106)
> Python3Details: /usr/bin/python3.6, Python 3.6.5, python3-minimal,
> 3.6.5-3
> PythonDetails: /usr/bin/python2.7, Python 2.7.15rc1, python-minimal,
> 2.7.15~rc1-1
> RelatedPackageVersions:
> dpkg 1.19.0.5ubuntu2
> apt 1.6.1
> SourcePackage: menu
> Title: package menu 2.1.47ubuntu2 failed to install/upgrade: dependency
> problems - leaving triggers unprocessed
> UpgradeStatus: Upgraded to bionic on 2018-05-03 (0 days ago)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/menu/+bug/1768905/+subscriptions
>

--
----------------------------------------------------------------------------------------------------------
BM-2cT46RLBH7AiTxnk5gEuYUH5eQ1xLtrKLZ
BTC: 1NikkusCFVtadafW15HZw3up9xo23fi5UD
PGP Key:
http://pool.sks-keyservers.net:11371/pks/lookup?op=get&search=0xBBAB337F14D69D08
ToxID: *6E179B4A85329D20274DC8142BB03B**2006486CA1C5327DF000A87A1065FE*
*425934B7706AD96F*
j=abs(j-1)
----------------------------------------------------------------------------------------------------------

tags: added: triggers-unprocessed
Changed in menu (Ubuntu):
status: Incomplete → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apt (Ubuntu):
status: New → Confirmed
Julian Andres Klode (juliank) wrote :

I restored the apt-clone file in a container (with rc-policy.d disabling services), tried a straight apt dist-upgrade, and that worked. Will check with do-release-upgrade tomorrrow.

Julian Andres Klode (juliank) wrote :

do-release-upgrade worked as well, so what I'd need for further investigation is /var/log/dpkg.log from after the failed upgrade. That might be dpkg.log.1 or dpkg.log.2 or something.

Changed in apt (Ubuntu):
status: Confirmed → Incomplete
tags: added: id-5afdc48d9d556db07dc88b67
Julian Andres Klode (juliank) wrote :

I think it's a fundamental problem that interest triggers are not considered for ordering packages, and hence cannot be used reliably. Fixing this bug is probably a matter of making all the triggers noawait, although I can't reproduce it, so I can't test any SRU.

Brian Murray (brian-murray) wrote :

Could any of the reporters of duplicates of this bug provide their apt-clone file for testing? You should be able to find one at /var/log/dist-upgrade/apt-clone_system_state.tar.gz. Thanks in advance.

James Grimaldi (jag567) wrote :

Brian,

I think this the file you want.

On Wed, May 30, 2018 at 11:10 AM, Brian Murray <email address hidden> wrote:

> Could any of the reporters of duplicates of this bug provide their apt-
> clone file for testing? You should be able to find one at /var/log/dist-
> upgrade/apt-clone_system_state.tar.gz. Thanks in advance.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1768905
>
> Title:
> package menu 2.1.47ubuntu2 failed to install/upgrade: dependency
> problems - leaving triggers unprocessed
>
> Status in apt package in Ubuntu:
> Incomplete
> Status in menu package in Ubuntu:
> Confirmed
>
> Bug description:
> I get this error when I update to 18.04
>
> ProblemType: Package
> DistroRelease: Ubuntu 18.04
> Package: menu 2.1.47ubuntu2
> ProcVersionSignature: Ubuntu 4.15.0-20.21-generic 4.15.17
> Uname: Linux 4.15.0-20-generic x86_64
> ApportVersion: 2.20.9-0ubuntu7
> Architecture: amd64
> Date: Thu May 3 16:51:28 2018
> Dependencies:
> gcc-8-base 8-20180414-1ubuntu2
> libc6 2.27-3ubuntu1
> libgcc1 1:8-20180414-1ubuntu2
> libstdc++6 8-20180414-1ubuntu2
> ErrorMessage: dependency problems - leaving triggers unprocessed
> InstallationDate: Installed on 2018-04-11 (22 days ago)
> InstallationMedia: Ubuntu-MATE 17.10 "Artful Aardvark" - Release amd64
> (20180106)
> Python3Details: /usr/bin/python3.6, Python 3.6.5, python3-minimal,
> 3.6.5-3
> PythonDetails: /usr/bin/python2.7, Python 2.7.15rc1, python-minimal,
> 2.7.15~rc1-1
> RelatedPackageVersions:
> dpkg 1.19.0.5ubuntu2
> apt 1.6.1
> SourcePackage: menu
> Title: package menu 2.1.47ubuntu2 failed to install/upgrade: dependency
> problems - leaving triggers unprocessed
> UpgradeStatus: Upgraded to bionic on 2018-05-03 (0 days ago)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/apt/+bug/1768905/+subscriptions
>

--
James A. Grimaldi

Julian Andres Klode (juliank) wrote :

I could not reproduce this with that file in my lxd testing setup either. It might depend on PPA packages changing the order. That said, fixing the trigger to be noawait is definitely the right thing to do-

Changed in menu (Ubuntu):
status: Confirmed → In Progress
Julian Andres Klode (juliank) wrote :

Adding tasks for down to xenial, but not sure what we want to do. I don't foresee any trouble with that change, but we can't test it, and even if we get a failing upgrade, we can only test for that release.

Changed in menu (Ubuntu):
status: In Progress → Fix Committed
description: updated
Changed in menu (Ubuntu Xenial):
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package menu - 2.1.47ubuntu3

---------------
menu (2.1.47ubuntu3) cosmic; urgency=medium

  * Switch triggers to use noawait (LP: #1768905)

 -- Julian Andres Klode <email address hidden> Tue, 05 Jun 2018 10:48:23 -0700

Changed in menu (Ubuntu):
status: Fix Committed → Fix Released
Changed in menu (Debian):
status: Unknown → New

Hello Nikkus, or anyone else affected,

Accepted menu into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/menu/2.1.47ubuntu1.16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in menu (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-xenial
Changed in menu (Ubuntu Artful):
status: New → Fix Committed
tags: added: verification-needed-artful
Robie Basak (racb) wrote :

Hello Nikkus, or anyone else affected,

Accepted menu into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/menu/2.1.47ubuntu1.17.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in menu (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed-bionic
Robie Basak (racb) wrote :

Hello Nikkus, or anyone else affected,

Accepted menu into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/menu/2.1.47ubuntu2.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-done-artful verification-done-bionic
removed: verification-needed-artful verification-needed-bionic
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apt (Ubuntu Artful):
status: New → Confirmed
Changed in apt (Ubuntu Bionic):
status: New → Confirmed
Changed in apt (Ubuntu Xenial):
status: New → Confirmed
Julian Andres Klode (juliank) wrote :

I have not heard about any regressions in proposed, so I think we should start releasing the update for bionic and artful now and watch out for those in the release pocket. If we don't see issues with that, we can then roll out xenial next week to give it some more time to mature in a less used release.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package menu - 2.1.47ubuntu1.17.10.1

---------------
menu (2.1.47ubuntu1.17.10.1) artful; urgency=medium

  * Switch triggers to use noawait (LP: #1768905)

 -- Julian Andres Klode <email address hidden> Tue, 05 Jun 2018 10:48:23 -0700

Changed in menu (Ubuntu Artful):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for menu has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package menu - 2.1.47ubuntu2.1

---------------
menu (2.1.47ubuntu2.1) bionic; urgency=medium

  * Switch triggers to use noawait (LP: #1768905)

 -- Julian Andres Klode <email address hidden> Tue, 05 Jun 2018 10:48:23 -0700

Changed in menu (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.