Duplicate menu entries in gnome-shell if menu-xdg is installed

Bug #862313 reported by Julien Olivier
52
This bug affects 11 people
Affects Status Importance Assigned to Milestone
menu-xdg (Ubuntu)
Undecided
Unassigned

Bug Description

Since I installed the "gnome" package in Oneiric, the menu-xdg package was recommanded for installation. The problem is that, since I installed menu-xdg, I'm getting double menu entries in gnome-shell.

I have made some investigations and it seems that the duplicate entries come from there: /var/lib/menu-xdg/applications/menu-xdg/

I have found a similar older bug (bug #14861) but it has been closed as fixed, so whether the bug is back, or it wasn't properly fixed.

Revision history for this message
bekirserifoglu@gmail.com (bekirserifoglu) wrote :

i can attest this bug on oneiric. once you remove the folder "/var/lib/menu-xdg/applications/menu-xdg/", the problem seems to be gone. naturally, it should be addressed in a more professional way.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in menu-xdg (Ubuntu):
status: New → Confirmed
Revision history for this message
Thiago Bellini (bellini666) wrote :

Not only duplicating, but showing cli apps too.
Also, the duplicated apps have very ugly icons.

I'm attaching a record I just made (using Gnome-shell CTRL+ALT+SHIFT+R) showing my applications menu.

Revision history for this message
Thiago Bellini (bellini666) wrote :

Maybe the fix is just stopping suggesting 'menu-xdg' package when installing the meta-package 'gnome'? Obviously, if it's not needed for some gnome core functionality (which I think it's not, but I can be wrong).

What do you think?

Revision history for this message
Rolf Leggewie (r0lf) wrote :

I also have this problem in lucid. This looks like menu-xdg left over some cruft or double-installs things.

$ ls ~/.local/share/applications/menu-xdg/*.desktop|wc -l
248
$ ll /var/lib/menu-xdg/applications/menu-xdg/*.desktop|wc -l
273

It looks like my double and triple entries (which I find in Alt+F2, "Run Application") come from those two directories.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers