Ubuntu

menu-cached crashed with SIGSEGV in malloc()

Reported by Александр on 2013-01-11
210
This bug affects 42 people
Affects Status Importance Assigned to Milestone
LXDE
Unknown
Unknown
menu-cache (Ubuntu)
Medium
Unassigned

Bug Description

I post this bug on first apport crash notification after install LXDE and Unity freeze.

ProblemType: Crash
DistroRelease: Ubuntu 13.04
Package: libmenu-cache2 0.4.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-0.2-generic 3.8.0-rc3
Uname: Linux 3.8.0-0-generic x86_64
ApportVersion: 2.8-0ubuntu1
Architecture: amd64
CrashCounter: 1
Date: Sat Jan 12 01:49:11 2013
ExecutablePath: /usr/lib/x86_64-linux-gnu/libmenu-cache2/libexec/menu-cached
InstallationDate: Installed on 2013-01-11 (0 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20130108)
MarkForUpload: True
ProcCmdline: /usr/lib/x86_64-linux-gnu/libmenu-cache2/libexec/menu-cached
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=ru_RU.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7fcc6664b92a: mov 0x8(%rbx),%rax
 PC (0x7fcc6664b92a) ok
 source "0x8(%rbx)" (0x100000007) not located in a known VMA region (needed readable region)!
 destination "%rax" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: menu-cache
StacktraceTop:
 ?? () from /lib/x86_64-linux-gnu/libc.so.6
 ?? () from /lib/x86_64-linux-gnu/libc.so.6
 malloc () from /lib/x86_64-linux-gnu/libc.so.6
 ?? () from /lib/x86_64-linux-gnu/libc.so.6
 iconv_open () from /lib/x86_64-linux-gnu/libc.so.6
Title: menu-cached crashed with SIGSEGV in malloc()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

StacktraceTop:
 malloc_consolidate (av=av@entry=0x7fcc66988740 <main_arena>) at malloc.c:4128
 _int_malloc (av=av@entry=0x7fcc66988740 <main_arena>, bytes=bytes@entry=32640) at malloc.c:3421
 __GI___libc_malloc (bytes=32640) at malloc.c:2858
 __gconv_open (toset=0x0, toset@entry=0x7fff9d9598e0 "ANSI_X3.4-1968//", fromset=0x133cb80 "\002", fromset@entry=0x7fff9d9598c0 "UTF-8//", handle=handle@entry=0x7fff9d959900, flags=flags@entry=0) at gconv_open.c:283
 iconv_open (tocode=0x7fff9d9598e0 "ANSI_X3.4-1968//", tocode@entry=0x1348730 "ANSI_X3.4-1968", fromcode=0x7fff9d9598c0 "UTF-8//", fromcode@entry=0x7fcc66a19587 "UTF-8") at iconv_open.c:71

Changed in menu-cache (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in menu-cache (Ubuntu):
status: New → Confirmed
information type: Private → Public
Sasa Paporovic (melchiaros) wrote :

Normally this report would get upstream to LXDE project, but regarding to the reporters description the unity desctop is affected by the menu-cache library.

In respect to this I add the unity project and because two users are affected I set the status there to confiremed.

affects: lxde → unity
Changed in unity:
status: New → Confirmed
Sasa Paporovic (melchiaros) wrote :

Александр (sash0k-v),

has you installed the LXDE desktop additional?

The information would help to triage the report.

Sasa Paporovic (melchiaros) wrote :

Regarding to dublicate

https://bugs.launchpad.net/ubuntu/+source/menu-cache/+bug/1099693

this crasher is also observable by LXDE desktop alone.

Anyway,

unity should not get freezed by this.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

affects: lxde → lxde-common (Ubuntu)
Changed in lxde-common (Ubuntu):
status: New → Confirmed
Changed in lxde-common (Ubuntu):
status: New → Confirmed
Sasa Paporovic (melchiaros) wrote :

In respect to

https://bugs.launchpad.net/ubuntu/+source/menu-cache/+bug/1099693

which shows that the crasher is observable on pure LXDE(but with not so strange consequences as described here) the LXDE ubuntu package is added.

Александр (sash0k-v) wrote :

melchiaros (melchiaros), yes, I have LXDE installed as second environment. Cause Unity is unusable on my hardware (see my bug description above). I post this bug on first apport crash notification after install LXDE and Unity freeze. In fact, system report and my report is 2 different bugs.

Didn't know, how to post report on my problem. On today's build (3.8.0-5-generic #10-Ubuntu SMP Thu Feb 7 17:57:08 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux) Unity still unusable for me. Seems, its a problem at Nouveau for my hardware.

Sasa Paporovic (melchiaros) wrote :

Aha, when I unserstand you correct that you have mixed it up.

The crash was detected by the system and you gave it a from the crash different summary and description.

o.K. in this case we have to adapt the report. I give the crash the focus, because apport collected files are related to this.

For reporting the unity problem you can use from terminal or with a command line called with

ALT + F2

ubuntu-bug unity

or when you want to report against the kernel directly(int the case you think it is more on the driver)

ubuntu-bug linux

I also adapt the summary.

You can find your old one under old summary(for copy past to your new report).

I know this gives extra work to you, but see it from the other side. It is very hard to work on a report when the parts of it do not fit to each other.

This is the prefered style.

description: updated
Sasa Paporovic (melchiaros) wrote :

This gives you your original description directly:

https://bugs.launchpad.net/ubuntu/+source/menu-cache/+bug/1098732/comments/0

Sasa Paporovic (melchiaros) wrote :
no longer affects: unity
summary: - unity crashes and freeze system on click dash button
+ menu-cached crashed with SIGSEGV in malloc()
Александр (sash0k-v) wrote :

melchiaros (melchiaros), thanks!
I posted my problem here now: https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1121715
Apport suggest to post problem for Xorg. Screenshot attached.
Can you check, is my report right this time?

Sasa Paporovic (melchiaros) wrote :

Yes, looks good.

Shao-Wen, Young (b00507031) wrote :

I'm using Lubuntu 13.04 (amd64) with kernel version of 3.8.0-generic-3.8.0-16-26; just after I logged in Lubuntu today, an apport dialogue appeared.

Sasa Paporovic (melchiaros) wrote :

In respect that b00507031 has used a pure Lubuntu, the crash is definitivly not caused by the Unity desktop system in any way.

Sasa Paporovic (melchiaros) wrote :

It is a little bit evil behave, but for those who comes new here, it might help more to get to the upstream report at

http://sourceforge.net/tracker/index.php?func=detail&aid=3603920&group_id=180858&atid=894869

and give it a ping or +1 or whatever.

tags: added: saucy

Happened after closing synaptic in Gnome 3.8 session in Ubuntu 13.10 (Saucy) kernel 3.10 Previous session was LXDE

Julien Lavergne (gilir) on 2013-07-08
no longer affects: lxde-common (Ubuntu)
Changed in menu-cache (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package menu-cache - 0.5.0-0ubuntu1

---------------
menu-cache (0.5.0-0ubuntu1) saucy; urgency=low

  * New upstream release.
   - menu-cached crashed with SIGSEGV in malloc() (LP: #1098732)
  * debian/conrol:
   - Soname bump to libmenu-cache3
  * debian/libmenu-cache3.install
   - Soname bump to libmenu-cache3
  * debian/rules:
   - Update with the soname change.
   - Enable hardening flags.
 -- Julien Lavergne <email address hidden> Tue, 09 Jul 2013 00:51:39 +0200

Changed in menu-cache (Ubuntu):
status: In Progress → Fix Released
Stan Williams (stanwmusic) wrote :

Upon reading these posts I decided to ad, just in case it is of help to anyone that I was also using LXDE ( Lubuntu) when this ocurred.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.