Setting up memtest86+ hangs because of "grub-probe: error: unknown filesystem"

Bug #970260 reported by Laurent Riffard on 2012-03-31
158
This bug affects 33 people
Affects Status Importance Assigned to Milestone
grub2 (Debian)
Fix Released
Unknown
grub2 (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
Quantal
Undecided
Unassigned
Raring
Undecided
Unassigned
memtest86+ (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
Quantal
Undecided
Unassigned
Raring
Undecided
Unassigned
os-prober (Ubuntu)
High
Unassigned
Precise
Undecided
Unassigned
Quantal
Undecided
Unassigned
Raring
High
Unassigned

Bug Description

Installation of package memtest86+ fails, it does hang and never ends if lvm snapshot is present.

Prepare:
* create active lvm snapshot

Test case:
$ sudo apt-get install --reinstall memtest86+

<hang>

Recover from the hang with:
$ sudo pkill -f 'frontend /var/lib/dpkg/info/memtest86\+.postinst'
$ sudo killall grub-mount
$ sudo umount /var/lib/os-prober/mount

(don't kill grub-mount nor umount if you want the next run to "succeed", well not run)

Actual problem:
update-grub / os-prober leave stray grub-mount behing.
workarounds applied in os-prober 1.57 doesn't actually help here.
upgrading to quantal's grub2 package resolves the hangs.
A minimal backport from grub has not been identified yet.

This evening, I noticed that "dpkg --configure memtest86 +" produced a "grub-mount" process :

# ps axf
[...]
21980 pts/2 S+ 0:00 \_ sudo apt-get -f install
21981 pts/2 S+ 0:01 \_ apt-get -f install
21989 pts/4 Ss+ 0:00 \_ /usr/bin/dpkg --status-fd 67 --configure memtest86+:amd64 ubuntu-standard:amd64
21990 pts/4 S+ 0:00 \_ /usr/bin/perl -w /usr/share/debconf/frontend /var/lib/dpkg/info/memtest86+.postinst configure 4.20-1ubuntu1
21997 pts/4 Z+ 0:00 \_ [memtest86+.post] <defunct>
[...]
23816 ? Ss 0:00 grub-mount /dev/mapper/vglinux1-lv_ubunutu_oneiric /var/lib/os-prober/mount
[...]

Killing this "grub-mount" process allows dpkg to complete successfully.

So the problem was not the Reiser4 filesystems, it was the LVM snapshot.

# lvdisplay /dev/mapper/vglinux1-lv_ubunutu_oneiric
  --- Logical volume ---
  LV Name /dev/vglinux1/lv_ubunutu_oneiric
  VG Name vglinux1
  LV UUID e8GxvT-YwJx-HQXW-ryD9-5zya-tI0g-J7Qosz
  LV Write Access read/write
  LV snapshot status active destination for /dev/vglinux1/lv_ubuntu
  LV Status available
  # open 0
  LV Size 10,00 GiB
  Current LE 2560
  COW-table size 10,00 GiB
  COW-table LE 2560
  Allocated to snapshot 50,56%
  Snapshot chunk size 512,00 KiB
  Segments 2
  Allocation inherit
  Read ahead sectors auto
  - currently set to 256
  Block device 252:13

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in memtest86+ (Ubuntu):
status: New → Confirmed
Sylwester (ubuntulinux-org) wrote :

My upgrade from oneiric to precise has been hanging for 8 hours because of this bug. I also have made a snapshot of my EXT4 root. I'm unsure but /etc/fstab in this snapshot will point to the same drives so grub-mount might try to mount something already mounted elsewhere maybe??

Rob Hasselbaum (rhasselbaum) wrote :

Same issue. I also took an LVM snapshot of root before upgrading, so it does seem that's the trigger. Ironic.

pipe (pipatron) wrote :

I just upgraded to precise, and found my computer with this memtest-issue after several hours. I did *not* take a snapshot of my root, but my root is on a logical volume on an encrypted physical volume. I had to perform the same kill as the original reporter did.

I am continuing the upgrade now, seemingly without any issues.

pipe (pipatron) wrote :

Now it happened again, at the "Cleaning up" part of the upgrade.

I suspect it has nothing to do with memtest. It might be that memtest is the last thing it sees, and perhaps os-prober is the culprit.

Karl Maier (w-wall2001) wrote :

Thanks, killing grub-mount did the trick for me. Bug #986833 might be related. My error message when the computer hang was

...
Found memtest86+ image: /memtest86+.bin
File descriptor 3 (pipe:[15340]) leaked on lvs invocation. Parent PID 4755: /bin/sh
rmdir: konnte »/var/lib/os-prober/mount“ nicht entfernen: Das Gerät oder die Ressource ist belegt
rmdir: konnte »/var/lib/os-prober/mount“ nicht entfernen: Das Gerät oder die Ressource ist belegt
grub-probe: Fehler: no such disk.

Manuel (manuel-vacelet) wrote :

I got the same issue when upgrading from 11.10 to 12.04, always on memtest. Killing grub-mount work around the issue.

I just got an upgrade of the kernel and I got the same issue.

I'm not using LVM. Just plain ext4 partition on a goo'old macbook 5.1

In my case, grub was trying to mount an eSATA connected NTFS drive and hanging there.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in os-prober (Ubuntu):
status: New → Confirmed
Changed in os-prober (Ubuntu):
importance: Undecided → High
Changed in memtest86+ (Ubuntu Precise):
status: New → Invalid
Changed in memtest86+ (Ubuntu Quantal):
status: New → Invalid
Changed in memtest86+ (Ubuntu Raring):
status: Confirmed → Invalid
Changed in os-prober (Ubuntu Quantal):
status: New → Fix Released
Changed in os-prober (Ubuntu Raring):
status: Confirmed → Fix Released
Changed in os-prober (Ubuntu Precise):
status: New → Confirmed
Changed in grub2 (Ubuntu Raring):
status: New → Fix Released
Changed in grub2 (Ubuntu Quantal):
status: New → Fix Released
Changed in grub2 (Ubuntu Precise):
status: New → Confirmed
description: updated
Changed in memtest86+ (Ubuntu Precise):
status: Invalid → Confirmed
Changed in grub2 (Debian):
status: Unknown → Fix Released

Ubuntu 13.04 Raring 64 Bit, btrfs
update-grub hangs at memtest86+
Ubuntu does not start.
My workaround: copied the old grub.cfg into /boot/grub/

taka k. (scar) wrote :

how do we permanently fix this? the pkill -f 'frontend /var/lib/dpkg/info/memtest86\+.postinst' command recovers from the hang, but memtest86+ is still not properly installed, and hangs everytime 'dpkg --configure' is called, or when kernel is updated, etc.

taka k. (scar) wrote :

why did you release a fix for the non-LTS releases but Precise is still waiting? very frustrated....

taka k. (scar) wrote :

hello how do we fix this on 12.04?

Eric (eric-woodruff) wrote :

Killing grub-mount (there were like 5 running on an upgrade to 15.04) allowed the upgrade to continue.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.