memtest86+ fails on efi systems

Bug #883017 reported by albatros
246
This bug affects 52 people
Affects Status Importance Assigned to Milestone
memtest86+ (Ubuntu)
Triaged
Medium
Bernard Burette

Bug Description

memtest86+ fails to load on an amd64 in EFI-mode system using grub-efi, I do not know if the error also occurs when using grub-pc on amd64.

Memtest86+ entries are included in the GRUB boot menu. Booting these options results in an error however:
'error: unknown command 'linux16'.'

Changing linux16 to linux results in another error:
'error: zImage doesn't support 32-bit boot.'
(bug #424506)

It seems grub-efi (or maybe actually grub on amd64(http://www.gnu.org/software/grub/manual/grub.html#linux16) does not support linux16.

I have not found a solution. If there is no solution yet, I would suggest not adding the Memtest86+ boot options on amd64 systems (I believe efi&64 bit support is planned for memtest86+ version 5)

Tags: patch
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in memtest86+ (Ubuntu):
status: New → Confirmed
Revision history for this message
ruediix@gmail.com (ruedii) wrote :

This bug has to do with the EFI version of grub not supporting loading real mode binaries.

You might be able to workarround this by using the chainloader mode to bootstrap into another capable bootloader, and then launching memtest86 from the secondary loader. The .iso image form of memtest86(+) could be used for this. However, I am uncertain if even this would work. (Although, it is worth a try.)

Revision history for this message
Colin Watson (cjwatson) wrote :

memtest86+ (4.20-1.1ubuntu2) quantal; urgency=low

  * Don't present the GRUB menu option on EFI systems, since it won't work
    (see LP #883017).

 -- Colin Watson <email address hidden> Thu, 11 Oct 2012 14:14:55 +0100

Leaving this bug open, though, since it would still be nice to have a way to run this on EFI.

Changed in memtest86+ (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Revision history for this message
Bernard Burette (bburette) wrote :

Hi,

I have built a version of memtest86+ that looks like a bzImage not a zImage and can be loaded and run from EFI-GRUB, I would be pleased to release this code, but I don't know where nor how to do it. I'm I at the right place ?

Regards,

Changed in memtest86+ (Ubuntu):
assignee: nobody → Bernard Burette (bburette)
Revision history for this message
Michael Stucki (mstucki) wrote :

Maybe it is worth mentioning that booting SystemRescueCD from a CD or memory stick is a nice workaround for this problem...

Revision history for this message
Jure Sah (dustwolfy) wrote :

So is this bug ever going to be fixed?

Revision history for this message
Anton Fedorov (datacompboy) wrote :

Bernard Burette: how do you boot with your changes? I have just tried "linux", tried "chainloader" -- neither works...

Revision history for this message
ray green (lefromagevert) wrote :

Affects me and 22 others ??? Must be 22 Million.

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

Bernard, please provide a diff instead..

Revision history for this message
Bernard Burette (bburette) wrote :

Hi,

Thanks for finally looking at this bug.

I have attached a patch file suitable for the command "patch", here is how to use it : unpack the original memtest86+ version 4.20 source files from http://www.memtest.org/download/4.20/memtest86+-4.20.tar.gz in a directory called "memtest86+-4.20" (the name from the original TAR file). Make a copy of these original files: "cp -rp memtest86+-4.20/ memtest86+-4.20.original/" and apply the patch there : "patch < patch-diff".

Then you can build the memtest.bin image. The command "file" should display it as "bzImage" instead of the original "zImage" so GRUB can load it through its "linux" command in place of "linux16". The program calls itself version 4.50 which never existed.

Unfortunately, I made this patch more than a year ago and now I'm blind when testing it: more precisely my Ubuntu box boots with GRUB2 and GRUB2 is a mess and shows incapable of keeping the screen in basic text mode whatever its options are set to. All my attempts turned to a blind boot, still the program is probably running OK although not displaying anything because a press on ESC reboots my computer properly. I will try ELILO or rEFInd to see if they can help...

Best regards.

Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "Patch for memtest86+ (v4.20 to v4.50, zImage to bzImage)" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Revision history for this message
Walter Neumann (neumann-g) wrote :

I followed Bernard's instructions, and it seems to run, but as he says it runs blind, so it is not much use. Bernard: did you find any fix for this?

Revision history for this message
Mantas Kriaučiūnas (mantas) wrote :

I think this bug should be fixed only after bug #1234612 fix (Please update memtest86+ to the latest 5.0.x release - memtest86 in Ubuntu 14.04 LTS is 2 years old!)

Revision history for this message
RichardNeill (ubuntu-richardneill) wrote :

Still broken...surely it's not good enough to leave a vital testing tool like this in a state where it is "known not to work" with most modern computers?

Revision history for this message
Osteoboon (w-accounts) wrote :

I'm also affected by this. Any updates?

Revision history for this message
Luis Alvarado (luisalvarado) wrote :

This is also affecting all version I have tested from 14.04 to 16.10

Revision history for this message
Fantu (fantonifabio) wrote (last edit ):

5.31b+dfsg-4 now in Jammy include latest upstream version and other patches that solves all freeze/crashes I saw (except the multiboot one) and memtest86+ is now returned to work well.
Uefi support is still missed but upstream developer replied me that will do upstream git and is contacting developers of various fork to merge them upstream and one have initial a good part of the uefi support made, so probably memtest86+ 6.00 will have it.

For 5.31b+dfsg-4 (in Jammy) include also:
  * Merge from ubuntu:
    ...
    - Don't present in GRUB menu on EFI systems, since it won't work.
      (Closes: #695246)
  * Warn that don't support EFI instead of exit silently (LP: 1863940)

Revision history for this message
Fantu (fantonifabio) wrote :

memtest86+ v6 add efi support, is in developement and for now in debian experimental (a git snapshot build)

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Bug attachments