New experimental multiboot version of memtest86+ only sees 640K of memory

Bug #641155 reported by Burt P.
This bug affects 1 person
Affects Status Importance Assigned to Milestone
memtest86+ (Debian)
Fix Released
memtest86+ (Ubuntu)
Fix Released

Bug Description

Binary package hint: memtest86+

The two new memtest86+ options added in the maverick beta load memtest but only see 640K of memory.
This is on a system that has this problem too:

Now four unusable memtest options in default grub menu.

Tags: patch
Revision history for this message
Burt P. (pburt0) wrote :

If I choose (C) configure -> (3) Memory Sizing -> (2) Probe, it will see the full 2GB of memory.
I tried using the official memtest booted directly from a disk, and it worked with (1) BIOS - Std, so this is only happening with this multiboot version.

Revision history for this message
Ken (kenmailis) wrote :

I modified to multiboot memtest ELF bootable at different memory locations:

the recompiled memtest ELF bootable booted, but had same problem, it see only 640K memory.
if I select probe, the system hang, I had to cycle power to bring system up again.

Changed in memtest86+ (Debian):
status: Unknown → New
Revision history for this message
Mantas Kriaučiūnas (mantas) wrote :

Vladimir 'φ-coder' Serbinenko <email address hidden> wrote a patch for fixing memtest86+ multiboot memory detection - I'm attaching that patch from Debian bugreport 568176, but I don't know if this patch will work with new memtest86+ 5.0.1, released at year 2013.

tags: added: patch
Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "Patch for fixing memtest86+ 4.20 multiboot memory detection" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

Revision history for this message
Fantu (fantonifabio) wrote :

I'm working on a new build for debian experimental with version 5.31b but I don't have knowledge about assembly and the boot part except a little something done years ago that I hardly remember anything about, I don't have enough time recently to read up and study the parts. Is there anyone with enough knowledge about it to help me get the correct multiboot part please?

work done for now about memtest86+ package is here:

Revision history for this message
Fantu (fantonifabio) wrote :

today I did a fast test applying the "newer" multiboot patch I found from coreboot repo ( based on Vladimir Serbinenko taken here), refreshed for 5.31b (, did also a small change to fix build fails

but testing it on one computer on multiboot entry memtest freeze always at start, so seems another changes/fix are needed

if someone want test it:

Changed in memtest86+ (Debian):
status: New → Fix Released
Fantu (fantonifabio)
Changed in memtest86+ (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.